parole crashed with SIGSEGV in parole_provider_player_get_stream_position()

Bug #1374887 reported by David Pires
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
parole (Ubuntu)
Undecided
Unassigned

Bug Description

Parole crashed while fast forwarding with the playback slider.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: parole 0.6.1-0ubuntu3.1
Uname: Linux 3.14.0-031400-generic i686
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: i386
CurrentDesktop: XFCE
Date: Sun Sep 28 01:57:56 2014
InstallationDate: Installed on 2013-01-25 (610 days ago)
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
SourcePackage: parole
UpgradeStatus: Upgraded to trusty on 2014-04-20 (160 days ago)

Revision history for this message
David Pires (slickymaster) wrote :
Revision history for this message
David Pires (slickymaster) wrote :

Adding the stack trace of the crash.

tags: added: xubuntu
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
Paul White (paulw2u)
tags: added: zesty
Revision history for this message
Paul White (paulw2u) wrote :

On 17.04 seems to affect 32-bit only, at least for me.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1374887

tags: added: iso-testing
Revision history for this message
Sean Davis (bluesabre) wrote :

Confirming that it seems to only affect 32-bit, and is caused by the MPRIS2 plugin. It's still unclear what exactly is causing the failure.

Revision history for this message
Sean Davis (bluesabre) wrote :

I've isolated the issue, and disabled the offending code. This functionality is otherwise unavailable in Xfce, so it should be a non-issue.

https://git.xfce.org/apps/parole/commit/?id=20329751a5ef17918a75bf942d578963a664a62c

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parole - 1.0.0-0ubuntu1

---------------
parole (1.0.0-0ubuntu1) bionic; urgency=medium

  * New upstream release.
    - Fixes crash on clear history (LP: #1214514)
    - Fixes crash on seek (LP: #1374887)

 -- Sean Davis <email address hidden> Wed, 28 Feb 2018 23:33:58 -0500

Changed in parole (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers