xdg-screensaver resume does not restore previous X11 screensaver timeout

Bug #1363540 reported by Sea Little on 2014-08-31
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Xdg-utils
Confirmed
Medium
parole
Invalid
Medium
parole (Ubuntu)
Medium
Unassigned
xdg-utils (Ubuntu)
Medium
Unassigned

Bug Description

Description: Ubuntu 14.04.1 LTS
Release: 14.04

parole:
  Installed: 0.6.1-0ubuntu3.1
  Candidate: 0.6.1-0ubuntu3.1
  Version table:
 *** 0.6.1-0ubuntu3.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     0.6.1-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

 Parole sets screen saver timeout and cycle to 600 on exit. It does not matter what the vaules are before starting the program. Also, it does not matter whether the option to prevent the screen saver is on or off in parole preferences.

xset q before running parole media player:
Screen Saver:
  prefer blanking: yes allow exposures: yes
  timeout: 0 cycle: 0

xset q while runing parole:
Screen Saver:
  prefer blanking: yes allow exposures: yes
  timeout: 0 cycle: 0

xset q after exit:
Screen Saver:
  prefer blanking: yes allow exposures: yes
  timeout: 600 cycle: 600

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
Elfy (elfy) on 2014-12-06
tags: added: vivid

Parole relies on xdg-screensaver to control the screensaver behavior. However, this external shell script only runs "xset s default" to re-enable the screensaver, so it does not restore the previous timeout value.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1363540

tags: added: package-qa-testing

Parole sets screen saver timeout and cycle to 600 on exit. It does not matter what the vaules are before starting the program. Also, it does not matter whether the option to prevent the screen saver is on or off in parole preferences.

  xset q before running parole media player:
  Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 0 cycle: 0

  xset q while runing parole:
  Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 0 cycle: 0

  xset q after exit:
  Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 600 cycle: 600

Downstream bugreport: https://bugs.launchpad.net/bugs/1363540

Changed in parole (Ubuntu):
importance: Undecided → Medium
Changed in xdg-utils (Ubuntu):
importance: Undecided → Medium

Actually this is a bug in xdg-screensaver (or simply put: the functionality of restoring the previous setting of screenblanking isn't implemented there) and not a bug in Parole.

Obviously this should be tackled in xdg-screensaver (if at all, since I haven't heard anybody complaining about this issue before ever).

Changed in parole:
importance: Unknown → Medium
status: Unknown → Invalid

The current implementation runs "xset s default" as resume action for X11's screensaver. This sets the timeout to 600 while ignoring the previous value which will be lost.

Created attachment 111967
Patch to improve X11 screensaver timeout handling

Changed in parole (Ubuntu):
status: Confirmed → Invalid
summary: - Parole resets screen timeout to 600 on exit
+ xdg-screensaver resume does not restore previous X11 screensaver timeout
Changed in xdg-utils:
importance: Unknown → Medium
status: Unknown → Confirmed

I have applied my patch to the current upstream version of xdg-screensaver. If you want to test it, please download the attached file and move it to /usr/local/bin .

I did forget to mention that you need to make the file executable.

sudo chown +x /usr/local/bin/xdg-screensaver

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1363540

tags: added: iso-testing
Simon Steinbeiß (ochosi) wrote :

This bug has been fixed in the package 1.1.0~rc1-2ubuntu9 in Ubuntu Vivid.

Changed in xdg-utils (Ubuntu):
status: Confirmed → Fix Released

*** Bug 12610 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.