Parole Media Player fails to play audio CD

Bug #1322384 reported by apsaras on 2014-05-22
64
This bug affects 14 people
Affects Status Importance Assigned to Milestone
parole
Fix Released
Medium
parole (Ubuntu)
Undecided
Unassigned

Bug Description

If I insert an audio CD (pre-recorded standard music CD) then Parole comes up, but this is quickly followed by the error message:

GStreamer backend error
Could not handle CDDA URI

and the CD fails to play.

I am using a clean (and updated) installation of Xubuntu 14.04.

~$ lsb_release -rd
Description: Ubuntu 14.04 LTS
Release: 14.04

~$ apt-cache policy parole
parole:
  Installed: 0.6.1-0ubuntu3.1
  Candidate: 0.6.1-0ubuntu3.1
  Version table:
 *** 0.6.1-0ubuntu3.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     0.6.1-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

Expected result: CD can be played

Actual result: CD cannot be played; above error message produced

Reproducible: always (or at least, every time I've tried it)

I've assumed this is a problem with Parole, but apologies if I've misattributed it.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: parole 0.6.1-0ubuntu3.1
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri May 23 00:32:08 2014
InstallationDate: Installed on 2014-05-19 (3 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
SourcePackage: parole
UpgradeStatus: No upgrade log present (probably fresh install)

I am running Parole 0.6.1. It is unable to play audio cd's. The reported error is:-

GStreamer backend error
Could not handle CDDA URI

I am running this program in Ubuntu Studio 14.04. It is also the same in xubuntu 14.04. However, xubuntu 12.04 did not have this problem, whatever version of Parole it had.

apsaras (c-launchpad1) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
jrr (pdr3535) wrote :

I get the same error message

apsaras (c-launchpad1) wrote :

As noted here http://xubuntu.fr/forum/viewtopic.php?f=2&t=2343, it looks like the problem is with the invocation.

In Settings -> Removable Drives and Media -> Multimedia, under Audio CD, changing

parole --device=%d

to

parole --device=% cdda://

seems to fix it. (I don't know if this is technically correct, but it works for me.)

jrr (pdr3535) wrote :

I'm on 32bit architecture and US archive with same problem:
parole:
  Installed: 0.6.1-0ubuntu3.1
  Candidate: 0.6.1-0ubuntu3.1
  Version table:
 *** 0.6.1-0ubuntu3.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     0.6.1-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages

Changed in parole:
importance: Unknown → Medium
status: Unknown → Confirmed

This is a regression with the new dvd location support. It has been fixed in trunk and will be included in the next release.

Changed in parole:
status: Confirmed → Fix Released
Alf Haakon Lund (alf-c) wrote :

Will the released fix be backported to 14.04?

tags: removed: amd64
Brian (balano) wrote :
Download full text (12.3 KiB)

The above fix did not work for me.
My current Audio CD launch command was: parole --device=%d
and now is: parole --device=%d cdda://
but neither works.

At first, when launched from the command line, I got errors related to connecting to gstreamer. A software update fixed this automagically. I think gstreamer1.0 was not installed at first. However I still got the same error message from the GUI as reported originally in this bug report.

$ lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

$ apt-cache policy parole
parole:
  Installed: 0.6.1-0ubuntu3.1
  Candidate: 0.6.1-0ubuntu3.1
  Version table:
 *** 0.6.1-0ubuntu3.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     0.6.1-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages

$ apt-cache policy gstreamer1.0
gstreamer1.0-fluendo-mp3:
  Installed: 0.10.23.debian-3
  Candidate: 0.10.23.debian-3
  Version table:
 *** 0.10.23.debian-3 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status
gstreamer1.0-vaapi:
  Installed: (none)
  Candidate: 0.5.7-0ubuntu4
  Version table:
     0.5.7-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
gstreamer1.0-audiosource:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-vaapi-doc:
  Installed: (none)
  Candidate: 0.5.7-0ubuntu4
  Version table:
     0.5.7-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
gstreamer1.0-clutter:
  Installed: (none)
  Candidate: 2.0.8-1build1
  Version table:
     2.0.8-1build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
gstreamer1.0-alsa:
  Installed: (none)
  Candidate: 1.2.4-1~ubuntu1
  Version table:
     1.2.4-1~ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
     1.2.3-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
gstreamer1.0-videosink:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-visualization:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-plugins-base-apps:
  Installed: (none)
  Candidate: 1.2.4-1~ubuntu1
  Version table:
     1.2.4-1~ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
     1.2.3-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
gstreamer1.0-tools:
  Installed: 1.2.4-0ubuntu1
  Candidate: 1.2.4-0ubuntu1
  Version table:
 *** 1.2.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1.2.3-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
libgstreamer1.0-0-dbg:
  Installed: (none)
  Candidate: 1.2.4-0ubuntu1
  Version table:
     1.2.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
     1.2.3-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
gstreamer1.0-pulseaudio:
  Installed: 1.2.4-1~ubuntu1
  Candidate: 1.2.4-1~ubu...

hpnetonline (hpnetonline83) wrote :

The Parole are installed on Ubuntu 14.04.

Parole version 0.6.1 with GStreamer version 1.2.4

The Parole application cannot play these video codecs as below:

RealMedia
Flash
vc1
vp6
avs

The Parole application cannot play these audio codecs as below:

DTSLBR
DTSAC3
DTSEC3
DTSES
PCM
G711
DVDA
avs
hevc
vc1

The Parole application cannot play these pictures codecs as below:
jpeg
bitmap

KitchM (tech-frontrowcomputer) wrote :

Currently have same exact problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.