parole crashed with SIGSEGV in SmcInteractDone()

Bug #1228627 reported by Munawar Ahmed on 2013-09-21
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
parole (Ubuntu)
Medium
Unassigned

Bug Description

Problem occurred while Parole was trying to download a plugin!

---
https://bugs.launchpad.net/ubuntu/+source/parole/+bug/1831549 has been tagged duplicate of this
Error report (amd64 on eoan [19.10] & focal [20.04] on shutdown, no (added) plugins involved
crash occurs because parole wasn't closed before shutdown

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: parole 0.5.2-1
ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
Uname: Linux 3.11.0-7-generic i686
ApportVersion: 2.12.4-0ubuntu1
Architecture: i386
Date: Sat Sep 21 22:30:09 2013
ExecutablePath: /usr/bin/parole
InstallationDate: Installed on 2013-09-11 (10 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130902.1)
MarkForUpload: True
ProcCmdline: parole /media/username/PENDRIVE/appear\ in\ the\ window.wma
SegvAnalysis:
 Segfault happened at: 0xb675d52d <SmcInteractDone+29>: mov 0x34(%esi),%eax
 PC (0xb675d52d) ok
 source "0x34(%esi)" (0x00000034) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: parole
StacktraceTop:
 SmcInteractDone () from /usr/lib/i386-linux-gnu/libSM.so.6
 ?? () from /usr/lib/i386-linux-gnu/libxfce4ui-1.so.0
 _SmcProcessMessage () from /usr/lib/i386-linux-gnu/libSM.so.6
 IceProcessMessages () from /usr/lib/i386-linux-gnu/libICE.so.6
 ?? () from /usr/lib/i386-linux-gnu/libxfce4ui-1.so.0
Title: parole crashed with SIGSEGV in SmcInteractDone()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Munawar Ahmed (munawar-ahmed) wrote :

StacktraceTop:
 SmcInteractDone (smcConn=0xaaaaaaaa, cancelShutdown=0) at ../../src/sm_client.c:492
 xsmp_interact (smc_conn=0xb852eb80, client_data=0xb852a090) at xfce-sm-client.c:1200
 _SmcProcessMessage (iceConn=0xb8531920, clientData=0xb852eb80, opcode=6, length=0, swap=0, replyWait=0x0, replyReadyRet=0xbf9ba678) at ../../src/sm_process.c:290
 IceProcessMessages (iceConn=iceConn@entry=0xb8531920, replyWait=replyWait@entry=0x0, replyReadyRet=replyReadyRet@entry=0x0) at ../../src/process.c:386
 xsmp_process_ice_messages (channel=0xb852eae0, condition=G_IO_IN, client_data=client_data@entry=0xb8531920) at xfce-sm-client.c:800

Changed in parole (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Jackson Doak (noskcaj) on 2014-03-25
information type: Private → Public
tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
tags: added: yakkety
tags: added: artful
tags: added: eoan
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1228627

tags: added: iso-testing
Chris Guiver (guiverc) wrote :

QA-test Xubuntu 19.10 July-7-2019

I'd finished my testing, had left the room to go to another pc where I comment my testing and this crash occurred whilst gone, so I didn't notice anything sorry

Chris Guiver (guiverc) wrote :

QA-test Xubuntu 19.10 daily

As with last comment, I'd finished testing and was shutting down system and this crash occurred, it sat & refused to open a terminal, firefox to lodge lp.bug etc. No issues appeared on screen. The bug-report was completed on a netbook; shutdown later completed from text terminal.

This has occurred this 19.10 cycle on two boxes; both are same model but different motherboards (different IO ports on back anyway); 8gb ram machine today.

dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)
dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)

Chris Guiver (guiverc) wrote :

QA-test Xubuntu 19.10 daily
hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

As with last comment, I finished testing and was shutting down system and crash occurred. Parole had NOT been closed this time, nor many windows - I'd completed the iso.qa.ubuntu.com report so just shutdown machine using gui, and it stopped, then apport window appeared and got stuck on uploading...

A different box to those mentioned in prior comment.

Chris Guiver (guiverc) wrote :

QA-test Xubuntu 19.10 daily
dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)
As with last two prior comments, I had finished my testing and was shutting down the system (firefox still streaming news in one window, parole playing music in another with no other windows open) & crash.

Chris Guiver (guiverc) wrote :

QA-test (live) Xubuntu 20.04 daily on
dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)
I had used thunar to open explore hdd partition & then open files using installed apps; which included parole. Parole hadn't been closed (it was left playing in the background) & on completion of test - it would not shutdown.
Crash report found in /var/crash; which it wanted to submit... but apps (firefox, term) would no longer open...

tags: added: focal
description: updated
Chris Guiver (guiverc) wrote :

QA-test (live) of Xubuntu groovy/20.10 daily on
dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)
QA-test including opening random found files from installed system using default apps which included a .wav file that was left playing in background. It hadn't been stopped before I shutdown system thus this issue occurred again

tags: added: amd64 groovy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers