Parole failes to play DVD

Bug #1098323 reported by Unit 193 on 2013-01-10
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
parole (Ubuntu)
Medium
Sean Davis

Bug Description

When I try to play a DVD (region 1, and unregioned), it gives a gstreamer backend error about not being able to read the title, but seemingly has already found the title as it is in the playlist correctly.

unit193@Sigma:~$ parole --device /dev/dvd2

libdvdread: Using libdvdcss version 1.2.12 for DVD access
libdvdread: Can't stat /dev/dvd
No such file or directory
libdvdread: Could not open /dev/dvd

Sean Davis (bluesabre) on 2013-01-10
Changed in parole (Ubuntu):
assignee: nobody → Sean Davis (smd-seandavis)
Lionel Le Folgoc (mrpouit) wrote :

Hi,

Which version are you using? (precise: 0.2.x, quantal: 0.3.x, raring: 0.4.x, and there's 0.4.x for precise and quantal in the xfce-4.12 ppa)

Lionel Le Folgoc (mrpouit) wrote :

Ah, sorry, just read the backlog on #xubuntu-devel. So 0.4.0 that is. ;-)

Logan D. Johns (logan85) wrote :

I have noticed this same issue on Xubuntu 12.10 and Xubuntu 13.04, parole auto-loads the disc and then I get a gstreamer backend error cannot load title. Not sure if this matters, but on both of the systems I am using, I have installed VLC and it will successfully play DVDs.

Sean Davis (bluesabre) wrote :

To play DVDs, Parole needs libdvdcss2 installed. Please see https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

Unit 193 (unit193) wrote :

libdvdcss2 is installed, as seen in the bug report, it's just trying to read /dev/dvd when the system only has /dev/dvd2. A quick workdaround for now would be to sudo ln -s dvd2 /dev/dvd (Which for me, is a link to sr0)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in parole (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1098323

tags: added: package-qa-testing
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1098323

tags: added: iso-testing
Akshar Patel (akshar-patel-47) wrote :

I'm getting this bug in xubuntu 13.10 eveb after installing libdvdcss2.

frenchy82 (cartes) wrote :

Tried on xubuntu 14.04 trusty and i got same error

Try adding ppa xfce 4.12 with parole 0.5.9 and the problem is still present

(parole:11348): parole-CRITICAL **: parole_provider_module_new_plugin: assertion 'PAROLE_IS_PROVIDER_PLUGIN (PAROLE_PROVIDER_PLUGIN (module->instance))' failed
libdvdread: Using libdvdcss version 1.2.13 for DVD access
libdvdread: Can't stat /dev/dvd
Aucun fichier ou dossier de ce type
libdvdread: Could not open /dev/dvd

 read same dvd with totem with no problem

MattJ (mwild1) wrote :

I also have this problem, on 13.10. It seemed that /dev/dvd did not exist, but my DVD device was available as /dev/sr0. A symlink fixed it:

  sudo ln -s /dev/sr0 /dev/dvd

I guess this might only be temporary though (i.e. until I reboot).

It's worth noting that VLC played the DVD fine without the symlink.

Bug is alive at Xubuntu 13.10 i386 fresh install.

Besides the workaround from comment #11 there's another workaround that will survive after the reboot:

From description of bug #1248194:

As a TEMPORARY fix, I added to /etc/rc.local:
ln -s /dev/sr0 /dev/dvd
exit 0

This adds a /dev/dvd link to /dev/sr0 each time I reboot partially fixes the problem but does not fix the bug that everyone else will run into.

My 2 cents.

Best regards,
Iberê

Jackson Doak (noskcaj) on 2014-01-23
Changed in parole (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Pip (allred-b) wrote :

Can confirm this bug in xubuntu 14.04.
ln -s /dev/sr0 /dev/dvd fixes it for the moment.

This seems to affect other media players as well.

applies to gnome mplayer at Lubuntu 14.04.

see bug.txt attached, pls.

bug report from ubuntu-bug.

screen shot with error message.

btw, instructions from https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs were followed and libdvdread4 is installed properly.

just installed VLC and i do not know why, but VLC plays the DVD correctly.

gnome mplayer not playing dvd yet.

workaround from comment #11 is working to make gnome mplayer play dvds correctly.

however the workaround breaks VLC. error message is:
Playback failure:
DVDRead could not open the disc "/dev/dvd1".
Your input can't be opened:
VLC is unable to open the MRL 'dvd:///dev/dvd1'. Check the log for details.

tks,
ibere

codeslinger (codeslinger) wrote :
Sean Davis (bluesabre) wrote :

We've actually released a fix for this, should make it's way to trusty soon. See this commit:
http://git.xfce.org/apps/parole/commit/?id=62f3b404a41bdce368fd3777328c966f87b860f4

Parole detects the DVD location ( /dev/sr0 seems to be a popular one ), and uses the the dvd uri... dvd:///dev/sr0 to function correctly.

Sean Davis (bluesabre) on 2014-03-30
no longer affects: parole
Changed in parole (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parole - 0.6.1-0ubuntu1

---------------
parole (0.6.1-0ubuntu1) trusty; urgency=medium

  * New upstream release.
    - Properly use specified device, use correct URI (lp: #1098323)
 -- Jackson Doak <email address hidden> Sun, 30 Mar 2014 13:32:17 +1100

Changed in parole (Ubuntu):
status: In Progress → Fix Released

Using Ubuntu Trusty and Parole 0.6.1-0ubuntu3 installed, everytime I insert a DVD gstreamer says it Could not read from resource. The 'Insert disc' menu entry is also greyed out but I can manualy open dvd:///dev/sr0 and play DVD's with no issues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints