Paraview does not render results (distribution-specific)

Bug #1877464 reported by MakisH
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
paraview (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

In Ubuntu 20.04, ParaView (if installed from APT, version 5.7.0) does not seem to rended any results and no errors are reported (neither in ParaView nor in the terminal). It just shows an empty render view.

Downloading the precompiled binaries for the same version [1] seems to work normally.

How to reproduce:
1. In Ubuntu 20.04, install ParaView from APT: `sudo apt install paraview`
2. Open any ParaView-compatible file (some examples shipped with the precompiled binaries)
3. Click "Apply" --> Normally the geometry should appear in the render view, but here nothing appears.

How to check the precompiled binaries:
1. Download and extract the same version of ParaView from the website [1]
2. Run `ParaView-5.7.0-MPI-Linux-Python3.7-64bit/bin/paraview`
3. Open an example from `ParaView-5.7.0-MPI-Linux-Python3.7-64bit/share/paraview-5.7/examples/`, e.g. `can.ex2`.
4. Click "Apply" --> The results render normally and a shape appears on the right of the screen.

If I remember correctly, this problem did not exist in Ubuntu 19.10.

[1]: https://www.paraview.org/paraview-downloads/download.php?submit=Download&version=v5.7&type=binary&os=Linux&downloadFile=ParaView-5.7.0-MPI-Linux-Python3.7-64bit.tar.gz

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in paraview (Ubuntu):
status: New → Confirmed
Revision history for this message
Martin D. Weinberg (martin-weinberg-5) wrote :

I tried Wayland, too, same problem.

My workaround was to remove the Ubuntu package and compile Paraview from scratch by cloning the git master branch. It takes some time, but it works. Follow the instructions here: https://www.paraview.org/Wiki/ParaView:Build_And_Install

Revision history for this message
MakisH (makishourdakis) wrote :

Maybe a helpful detail is that the complete rendering area can disappear, e.g. after trying to add another render view (see attached screenshot).

I also just tried on Debian Bullseye and I could not reproduce the same issue, so it looks like it is Ubuntu-specific.

Revision history for this message
MakisH (makishourdakis) wrote :
Revision history for this message
MakisH (makishourdakis) wrote :

The Ubuntu 20.10 package of the same ParaView version (5.7.0) seem to be working now! What are the differences between the two packages/dependencies? (I am not sure where to find the recipes)

In any case, it would be good to backport any fixes to 20.04 LTS, as the current version is essentially unusable there.

Revision history for this message
MakisH (makishourdakis) wrote :

This bug seems to have been fixed also on Ubuntu 20.04. I just tried on a clean system with the same setup as my original report (VirtualBox VM on the same host, same settings).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers