empathy doesn't connect to msn - blocked connection

Bug #663670 reported by Jonatan Schroeder on 2010-10-20
806
This bug affects 184 people
Affects Status Importance Assigned to Milestone
telepathy-butterfly
Fix Released
Critical
papyon (Ubuntu)
High
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
telepathy-butterfly (Ubuntu)
Low
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: empathy

I'm trying to find a bug that is related to this one, but none of the options I found matches. When opening Empathy, and trying to connect to my MSN accounts (I have two), Empathy keeps trying to connect, but nothing happens. There is no error message (so this is not the classic "Network error" bug that is solved by killing telepathy-butterfly), but the connection is not finalized. Checking the debug window, these are the last messages for butterfly:

>>> POST /abservice/abservice.asmx HTTP/1.0
Content-Length: 1519
Proxy-Connection: Keep-Alive
SOAPAction: http://www.msn.com/webservices/AddressBook/ABFindAll
Host: contacts.msn.com:80
Accept: text/*
User-Agent: gnet/0.1 (Linux i686)
Connection: Keep-Alive
Cache-Control: no-cache
Content-Type: text/xml; charset=utf-8
Accept-Encoding: gzip

<?xml version='1.0' encoding='utf-8'?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><ABApplicationHeader xmlns="http://www.msn.com/webservices/AddressBook"><ApplicationId xmlns="http://www.msn.com/webservices/AddressBook">996CDE1E-AA53-4477-B943-2BE802EA6166</ApplicationId><IsMigration xmlns="http://www.msn.com/webservices/AddressBook">false</IsMigration><PartnerScenario xmlns="http://www.msn.com/webservices/AddressBook">Initial</PartnerScenario></ABApplicationHeader><ABAuthHeader xmlns="http://www.msn.com/webservices/AddressBook"><ManagedGroupRequest xmlns="http://www.msn.com/webservices/AddressBook">false</ManagedGroupRequest><TicketToken xmlns="http://www.msn.com/webservices/AddressBook">t=9xCdFY6ARAad22feO5Sqed4j13RAYGkqdRKTAVZ0QoqR!uqnD2AM8UrgP2wuGwlw5PkavEKGXLq9SS!gomhwcNXVts6RgM!X3aJqqFmCKDWtdwoKwkUA*ZJ4C5xKw!zIx7sa0!L7BY!eY$&amp;p=9xjATSClgG2kOi0KVdQNsQFsqqGzwFIWh3rui4kRMCcnftlp8Ctuh1SRVwIxem1A4x7mqjItHZhnuEijWP*NGwmny2ZUicbdSbLcIXyIuu8wBR2xT8!1JihxBU3P1C*jPM373hiDbuGagvBnhVgzIKrsPWYFA*YOLdUDqWNDk9Xi9uW9u8WQPGtJledRTpiUBrEjxr9r62hE*eOlz5*m3Nnw$$</TicketToken></ABAuthHeader></soap:Header><soap:Body><ABFindAll xmlns="http://www.msn.com/webservices/AddressBook"><abId>00000000-0000-0000-0000-000000000000</abId><abView>Full</abView><deltasOnly>false</deltasOnly><lastChange>0001-01-01T00:00:00.0000000-08:00</lastChange></ABFindAll></soap:Body></soap:Envelope>
>>> POST /abservice/SharingService.asmx HTTP/1.0
Content-Length: 1606
Proxy-Connection: Keep-Alive
SOAPAction: http://www.msn.com/webservices/AddressBook/FindMembership
Host: contacts.msn.com:80
Accept: text/*
User-Agent: gnet/0.1 (Linux i686)
Connection: Keep-Alive
Cache-Control: no-cache
Content-Type: text/xml; charset=utf-8
Accept-Encoding: gzip

<?xml version='1.0' encoding='utf-8'?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><ABApplicationHeader xmlns="http://www.msn.com/webservices/AddressBook"><ApplicationId xmlns="http://www.msn.com/webservices/AddressBook">996CDE1E-AA53-4477-B943-2BE802EA6166</ApplicationId><IsMigration xmlns="http://www.msn.com/webservices/AddressBook">false</IsMigration><PartnerScenario xmlns="http://www.msn.com/webservices/AddressBook">Initial</PartnerScenario></ABApplicationHeader><ABAuthHeader xmlns="http://www.msn.com/webservices/AddressBook"><ManagedGroupRequest xmlns="http://www.msn.com/webservices/AddressBook">false</ManagedGroupRequest><TicketToken xmlns="http://www.msn.com/webservices/AddressBook">t=9xCdFY6ARAad22feO5Sqed4j13RAYGkqdRKTAVZ0QoqR!uqnD2AM8UrgP2wuGwlw5PkavEKGXLq9SS!gomhwcNXVts6RgM!X3aJqqFmCKDWtdwoKwkUA*ZJ4C5xKw!zIx7sa0!L7BY!eY$&amp;p=9xjATSClgG2kOi0KVdQNsQFsqqGzwFIWh3rui4kRMCcnftlp8Ctuh1SRVwIxem1A4x7mqjItHZhnuEijWP*NGwmny2ZUicbdSbLcIXyIuu8wBR2xT8!1JihxBU3P1C*jPM373hiDbuGagvBnhVgzIKrsPWYFA*YOLdUDqWNDk9Xi9uW9u8WQPGtJledRTpiUBrEjxr9r62hE*eOlz5*m3Nnw$$</TicketToken></ABAuthHeader></soap:Header><soap:Body><FindMembership xmlns="http://www.msn.com/webservices/AddressBook"><serviceFilter xmlns="http://www.msn.com/webservices/AddressBook"><Types xmlns="http://www.msn.com/webservices/AddressBook"><ServiceType xmlns="http://www.msn.com/webservices/AddressBook">Messenger</ServiceType></Types></serviceFilter></FindMembership></soap:Body></soap:Envelope>

Received error code 500 (Internal Server Error) from contacts.msn.com:80
Transport Error :500
Received error code 500 (Internal Server Error) from contacts.msn.com:80
Transport Error :500

I noticed that in the past other clients got this error and solved it by contacting omega.contacts.msn.com instead of contacts.msn.com, but I might be mistaken. This wasn't happening yesterday (Oct. 18), but started happening today (Oct. 19). I installed some updates, but nothing that looks related to this issue. Here is my /var/log/apt/history.log related to today:

Start-Date: 2010-10-19 11:59:36
Install: cups-ppdc:i386 (1.4.4-6ubuntu2.1)
Upgrade: evolution-common:i386 (2.30.3-1ubuntu6, 2.30.3-1ubuntu7), gcalctool:i386 (5.32.0-0ubuntu2, 5.32.0-0ubuntu3), libcupscgi1:i386 (1.4.4-6ubuntu2, 1.4.4-
6ubuntu2.1), sun-java6-plugin:i386 (6.21-1ubuntu1, 6.22-0ubuntu1~10.10), evolution-exchange:i386 (2.30.3-0ubuntu1, 2.30.3-0ubuntu2), evolution:i386 (2.30.3-1u
buntu6, 2.30.3-1ubuntu7), cups-client:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), libcupsmime1:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), libwebkit-1.0-2:i386 (1.2
.4-1ubuntu1, 1.2.5-0ubuntu0.10.10.1), libdrm-intel1:i386 (2.4.21-1ubuntu2, 2.4.21-1ubuntu2.1), libcamel1.2-14:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), libedat
a-cal1.2-7:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), sun-java6-fonts:i386 (6.21-1ubuntu1, 6.22-0ubuntu1~10.10), sun-java6-bin:i386 (6.21-1ubuntu1, 6.22-0ubuntu
1~10.10), libevolution:i386 (2.30.3-1ubuntu6, 2.30.3-1ubuntu7), rhythmbox-ubuntuone-music-store:i386 (0.1.8-0ubuntu1, 0.1.9-0ubuntu1), libcupsppdc1:i386 (1.4.
4-6ubuntu2, 1.4.4-6ubuntu2.1), libdrm2:i386 (2.4.21-1ubuntu2, 2.4.21-1ubuntu2.1), cups-common:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), sun-java6-jdk:i386 (6.21-1ubuntu1, 6.22-0ubuntu1~10.10), libcups2:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), bzr:i386 (2.2.0-1, 2.2.1-0ubuntu1), sun-java6-jre:i386 (6.21-1ubuntu1, 6.22-0ubuntu1~10.10), libegroupwise1.2-13:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), alsa-utils:i386 (1.0.23-2ubuntu3, 1.0.23-2ubuntu3.2), libecal1.2-7:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), libpoppler7:i386 (0.14.3-0ubuntu1, 0.14.3-0ubuntu1.1), libgdata1.2-1:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), libedataserver1.2-13:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), cups:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), libdrm-nouveau1:i386 (2.4.21-1ubuntu2, 2.4.21-1ubuntu2.1), libgdata-google1.2-1:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), libcupsdriver1:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), libebook1.2-9:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), evolution-plugins:i386 (2.30.3-1ubuntu6, 2.30.3-1ubuntu7), libedataserverui1.2-8:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), libedata-book1.2-2:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), evolution-data-server:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), libdrm-radeon1:i386 (2.4.21-1ubuntu2, 2.4.21-1ubuntu2.1), cups-bsd:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), libldap-2.4-2:i386 (2.4.23-0ubuntu3, 2.4.23-0ubuntu3.2), libcupsimage2:i386 (1.4.4-6ubuntu2, 1.4.4-6ubuntu2.1), poppler-utils:i386 (0.14.3-0ubuntu1, 0.14.3-0ubuntu1.1), pitivi:i386 (0.13.5-1ubuntu2, 0.13.5-1ubuntu3), libebackend1.2-0:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), evolution-data-server-common:i386 (2.30.3-2ubuntu1, 2.30.3-2ubuntu2), libwebkit-1.0-common:i386 (1.2.4-1ubuntu1, 1.2.5-0ubuntu0.10.10.1), libpoppler-glib5:i386 (0.14.3-0ubuntu1, 0.14.3-0ubuntu1.1)
End-Date: 2010-10-19 12:12:25

Start-Date: 2010-10-19 16:18:23
Commandline: apt-get upgrade
Upgrade: linux-headers-2.6.35-22:i386 (2.6.35-22.34, 2.6.35-22.35), linux-libc-dev:i386 (2.6.35-1022.34, 2.6.35-1022.35), linux-headers-2.6.35-22-generic:i386 (2.6.35-22.34, 2.6.35-22.35), linux-image-2.6.35-22-generic:i386 (2.6.35-22.34, 2.6.35-22.35)
End-Date: 2010-10-19 16:21:37

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: empathy 2.32.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Tue Oct 19 21:29:09 2010
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_CA.UTF-8
SourcePackage: empathy

Related branches

This bug is common to every application using "papyon" library: aMSN2 and emesene2 both stopped connecting. I can confirm it started to happen on 19/oct. I think MS modified their servers' behaviour, again....

Hansen (moteprime) wrote :

I also have this problem today with a MSN account not able to connect with no error messenge, using fresh and updated 10.10 installation.
Triend with pidgin, and it works fine.

Mohammad AbuShady (coalwater) wrote :

I couldn't connect today and i used empathy's debug and i got the same error message
"Received error code 500 (Internal Server Error) from contacts.msn.com:80"
I tried connecting using amsn and it successfully connected though

Zup Arkhen (zup-mondesvirtuels) wrote :

Same error here:
Received error code 500 (Internal Server Error) from contacts.msn.com:80
Transport Error :500

Zup Arkhen (zup-mondesvirtuels) wrote :

Update to 2.32.0.1 (proposed) but error too.

Øyvind Stegard (oyvinst) wrote :

Confirmed, Empathy on Ubuntu 10.04 can no longer connect to MSN. Problem appeared today for me.

empathy 2.30.3-0ubuntu1
telepathy-butterfly 0.5.11-0ubuntu1

Juninho Bill (billv6) wrote :

Empathy on Ubuntu 10.10 can no longer connect to MSN. Problem appeared yesterday for me.

Empathy 2.32.0

zonyl (zonyl) wrote :

10.10. Doesnt connect.. Same error.

I'm seeing the same thing on Ubuntu 10.10 with Empathy 2.32.0 and Telepathy-Butterfly 0.5.14-1. However, Pidgin 2.7.3-1ubuntu3 works fine.

Bram Bonné (brambonne) wrote :

Please click on 'This Bug Affects Me Too' instead of commenting that it affects you. This makes it much easier for developers to see the comments that matter.

Pablo Piaggio (papibe) wrote :

Same here. I've also tried the " killall telepathy-butterfly" trick and does NOT work. This is the error I'm getting:

empathy/Dispatcher-DEBUG: 10/20/2010 13:59:07.369226: dispatcher_connection_invalidated_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 13:59:07.369354: connection_ready_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 13:59:14.371049: dispatcher_connection_invalidated_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 13:59:14.371165: connection_ready_cb: Error: Name owner lost (service crashed?)
empathy/Account-DEBUG: 10/20/2010 13:59:23.279560: empathy_accounts_dialog_show_application: Launching empathy-accounts (if_needed: 0, hidden: 0, account: /org/freedesktop/Telepathy/Account/butterfly/msn/papibe_40hotmail_2ecom0)
empathy/Dispatcher-DEBUG: 10/20/2010 13:59:25.374660: dispatcher_connection_invalidated_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 13:59:25.374785: connection_ready_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 13:59:36.465696: dispatcher_connection_invalidated_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 13:59:36.465811: connection_ready_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 14:00:11.394676: dispatcher_connection_invalidated_cb: Error: Name owner lost (service crashed?)
empathy/Dispatcher-DEBUG: 10/20/2010 14:00:11.394793: connection_ready_cb: Error: Name owner lost (service crashed?)

Omer Akram (om26er) wrote :

the issue is confirmed and seems to me msn changed something on their server side and hence made telepathy uncompatible could anyone please try pidgin or amsn and see if they work

Changed in empathy (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Juninho Bill (billv6) wrote :

Confirmed, worked fine on pidgin here.

Omer Akram (om26er) on 2010-10-20
affects: empathy (Ubuntu) → telepathy-butterfly (Ubuntu)
Changed in telepathy-butterfly (Ubuntu):
status: Confirmed → Triaged
kakaroto (kakaroto) wrote :

Hi,
Found the bug and fixed. It should get committed and released soon.
In the meantime, to fix it, apply this patch on papyon (in something like /usr/lib/python2.6/site-packages/papyon) and it should fix it :
diff --git a/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py b/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py
index 73c1127..42d7497 100644
--- a/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py
+++ b/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py
@@ -21,7 +21,7 @@
 import xml.sax.saxutils as xml

 class LiveService(object):
- CONTACTS = ("contacts.msn.com", "?fs=1&id=24000&kv=7&rn=93S9SWWw&tw=0&ver=2.1.6000.1")
+ CONTACTS = ("contacts.msn.com", "MBI")
     MESSENGER = ("messenger.msn.com", "?id=507")
     MESSENGER_CLEAR = ("messengerclear.live.com", "MBI_KEY_OLD")
     MESSENGER_SECURE = ("messengersecure.live.com", "MBI_SSL")

f1anker (ianspigeon) wrote :

Thanks kakaroto, that fixed it for me.

Sebastien Bacher (seb128) wrote :

Ken, could you try to backport that commit?

Changed in telepathy-butterfly (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Basher Aobasher (aobasher) wrote :

Empathy on Ubuntu 10.10 can no longer connect to MSN. Problem appeared yesterday for me.

Empathy 2.32.0

Juninho Bill (billv6) wrote :

Here is a workaround until the bug isn't fixed.

Remove telepathy-butterfly from synaptic and you should just have telepathy-haze installed. Remove and create your msn account and try connecting again.

affects: telepathy-butterfly (Ubuntu) → papyon (Ubuntu)
sami (sam-gdah) on 2010-10-21
description: updated
Marcos Roriz (marcosrorizinf) wrote :

I'm with the same error. Just did a clean install on maverick.

1 comments hidden view all 121 comments
FaberfoX (faberfox) wrote :

Confirming kakaroto's patch fixed it for me, file to patch was /usr/share/pyshared/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py on 10.10 with the telepathy ppa enabled (http://ppa.launchpad.net/telepathy/ppa/ubuntu)

Omer Akram (om26er) wrote :

there is a proposed patch upstream

fix solved the problem for me. For the default instalation on Ubuntu 10.10 (no related ppa enabled) I changed /usr/lib/pymodules/python2.6/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py.

Thiago Bellini (hackedbellini) wrote :

Kakaroto's patch worked for me too!

Rudolf Olah (omouse) wrote :

I just tried the patch it worked well. Thanks a lot :D

Kakaroto's patch worked for me too !

tdptst (tdptst) wrote :

And how do I install that patch.. I'm sorry I'm still pretty new to Linux... :o(

Please, excuse my ignorance... How can I add the lalaroto's patch??
I've tried to add http://ppa.launchpad.net/telepathy/ppa/ubuntu into the source.list but doesn't work.

Thanks

excuse me... kakaroto's patch... :)

Thanks kakarato. Quick fix :]

@tdptst / @intruder

I'm on 10.04 / Lucid. Just worked for me.

Go to terminal >
cd /usr/lib/pymodules/python2.6/papyon/service/description/SingleSignOn
sudo gedit RequestMultipleSecurityTokens.py

replace the line
CONTACTS = ("contacts.msn.com", "?fs=1&id=24000&kv=7&rn=93S9SWWw&tw=0&ver=2.1.6000.1")
with
CONTACTS = ("contacts.msn.com", "MBI")

should work. good luck.

ooooh! it fixed for me too!!
thanks @Dennis Trinh.
after fix, empathy has connected at first hit.

Andrew (andrew-d-wilkie) wrote :

Patch by doing:

1. $ sudo vi /usr/lib/pymodules/python2.6/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py

2. Make single line edit as described by diff in post #15 above by kakaroto

3. Restart Empathy and tick Enabled.

tdptst (tdptst) wrote :

@Dennis Trinh

Thx .. It worked fine!! I tried to open the file in Gnome so I was not in root mode... That's why I couldn't edit the file I think.
But in a terminal session with sudo it worked fine! thx again ! :D

jan37 (dotjan-msn) wrote :

When would that patch will be released? :)

Giovanni Mellini (merlos) wrote :

Tks , editing file /usr/lib/pymodules/python2.6/papyon/service/description/SingleSignOn fixed the issue for me :)

rod singleton (rod40cool) wrote :

Thx, the edit described in #31 fixed me too.

Vlad Novak (vnovak06) wrote :

The fix described in #31 solved the issue, Empathy now connects to MSN normally.

@kakaroto, thanks for the solution, and @Dennis Trinh, thanks for the manual how to apply it.

Marcos Roriz (marcosrorizinf) wrote :

I hate to manually patch stuff, I wonder if this is going to be backported soon?

Marios Kosma (mkosmas1989) wrote :

#31 fixed the problem! Thank you @Dennis Trinh

Martin Pitt (pitti) on 2010-10-21
Changed in papyon (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) on 2010-10-21
tags: added: verification-done
removed: verification-needed
Changed in papyon (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-10-22
Changed in papyon (Ubuntu):
status: Triaged → Fix Released
Changed in papyon (Ubuntu Lucid):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Changed in papyon (Ubuntu Lucid):
status: Fix Committed → Fix Released
41 comments hidden view all 121 comments

It seems like Microsoft might have changed something again - I'm getting the same old 500 Internal Server Error messages again.

Ubuntu 10.10,
empathy 2.32.0.1-0ubuntu1,
telepathy-butterfly 0.5.14-1

I've just had the same issue and golved with comment #31.

Ubuntu 10.04

edcervantes (edgarcervan) wrote :

Hi... after update Empathy to the 2.30.3 version, my acount of MSN not working more.
I installed the MSN-PECAN and this solved my problem.

Ubuntu 10.04
empathy 2.30.3~0ubuntu1
telepathy-butterfly 0.5.14.1~ppa10.04+1
msn-pecan 0.1.0~rc4-0ubuntu1

edcervantes (edgarcervan) wrote :

Again here... msn_pecan leave connect the MSN account, but the services is bad, if some want contact you using video, your Empathy session break and reset. Other thing is: the name for display from you and your contact not is updated.
The best solution was given for "Kakaroto".

Thank you Kakaroto.

Omer Akram (om26er) on 2010-11-29
Changed in papyon (Ubuntu Karmic):
assignee: nobody → Omer Akram (om26er)
status: New → In Progress
Brian Curtis (bcurtiswx) wrote :

Omer, you're fixing this for karmic?

Omer Akram (om26er) wrote :

> Omer, you're fixing this for karmic?
yes since its fixed in lucid and maverick and yesterday there was a bug report from karmic user.

Chris Coulson (chrisccoulson) wrote :

Thanks Omer, taking this for sponsoring

Changed in papyon (Ubuntu Karmic):
assignee: Omer Akram (om26er) → Chris Coulson (chrisccoulson)
Changed in papyon (Ubuntu Karmic):
assignee: Chris Coulson (chrisccoulson) → nobody
status: In Progress → Triaged

Accepted papyon into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in papyon (Ubuntu Karmic):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Martin Pitt (pitti) wrote :

I'm sorry, the upload couldn't be accepted, you have to bump the version. (In the past there was an 1.1 upload which got removed from -proposed):

FAILED: papyon (The source papyon - 0.4.3-1ubuntu1.1 is already accepted in ubuntu/karmic and you cannot upload the same version within the same distribution. You have to modify the source version and re-upload

Changed in papyon (Ubuntu Karmic):
status: Fix Committed → In Progress
Omer Akram (om26er) wrote :

changed it from -1ubuntu1.1 to -1ubuntu2 chris can you please upload again.

Franz (franzbischoff) wrote :

My empathy does have the fix already, worked until yesterday morning, and I get Connection Error again. The bug is alive again?

thanks!

Chris Coulson (chrisccoulson) wrote :

I've reuploaded this as 0.4.3-1ubuntu1.2. 0.4.3-1ubuntu2 has already been published in lucid

1 comments hidden view all 121 comments
Jonathan Riddell (jr) wrote :

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in papyon (Ubuntu Karmic):
status: In Progress → Fix Committed
Gantry York (gantry-york) wrote :

Well, let me just throw my $0.02 in here:

Ubuntu 10.10
Empathy 2.32.1
python-papyon 0.5.1-0ubuntu2
telepathy-butterfly 0.5.14-1
msn-pecan currently not installed, but I tried it with 0.1.1-0ubuntu1

And once again, I can't connect to MSN either. It's been like this for over a month.

Changed the .py accordingly, but no change. "Network error"

Ubuntu 10.04
change mentioned in #31 worked fine for me
... did some automatic offered updates in last weeks (f.e kernel 2.6.32-27.49) - did not realize immediatly, that manual change was overwritten by updates :(
... why? i thought this change is part of new updates?
did manual change again today like mentioned in #31, and again it works now.

what's up with updates in lucid lynx?

the bug is fixed in Ubuntu 10.04 and 10.10 and also a fix for 9.10 is also
in the karmic-proposed.

On Sat, Jan 1, 2011 at 4:00 AM, Ing. Josef Klotzner <
<email address hidden>> wrote:

> Ubuntu 10.04
> change mentioned in #31 worked fine for me
> ... did some automatic offered updates in last weeks (f.e kernel
> 2.6.32-27.49) - did not realize immediatly, that manual change was
> overwritten by updates :(
> ... why? i thought this change is part of new updates?
> did manual change again today like mentioned in #31, and again it works
> now.
>
> what's up with updates in lucid lynx?
>
> --
> You received this bug notification because you are a member of
> Telepathy, which is subscribed to papyon in ubuntu.
> https://bugs.launchpad.net/bugs/663670
>
> Title:
> empathy doesn't connect to msn - blocked connection
>
> --
> Ubuntu-telepathy mailing list
> <email address hidden>
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-telepathy
>

Martin Pitt (pitti) wrote :

Any testers for the karmic proposed update?

Ueghio (gavvi86) wrote :

Thanks for the fix.Empathy 2.32.0

Roberto (roberto-meyer) wrote :

For me it worked uninstalling package telepathy-buterfly, then I deleted and created the account again. Some months ago there was a problem with password length; mine is 18 characters and don't have problem with it.

Changed in telepathy-butterfly:
status: Unknown → Fix Released
Martin Pitt (pitti) wrote :

As there was no feedback at all for the karmic update, I removed the proposed kamic update from the archive again.

Changed in papyon (Ubuntu Karmic):
status: Fix Committed → Won't Fix
Changed in telepathy-butterfly:
importance: Unknown → Critical
Changed in papyon (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Sebastien Bacher (seb128) wrote :

is that still an issue in natty?

Changed in telepathy-butterfly (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Mohammad AbuShady (coalwater) wrote :

Ok just wondering, why is this still an issue anyway, didn't it get fixed long way ago, like couple of days after the problem started, is there some people who are still facing this problem? might be because of something else.

Download full text (9.9 KiB)

I am running 10.4 LTS
natty is 10.10 ?

i have several installations and can upgrade one and check as soon as i
have time

Am Donnerstag, den 10.03.2011, 13:22 +0000 schrieb Sebastien Bacher:

> is that still an issue in natty?
>
> ** Changed in: telepathy-butterfly (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: telepathy-butterfly (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/663670
>
> Title:
> empathy doesn't connect to msn - blocked connection
>
> Status in telepathy-butterfly:
> Fix Released
> Status in “papyon” package in Ubuntu:
> Fix Released
> Status in “telepathy-butterfly” package in Ubuntu:
> Incomplete
> Status in “papyon” source package in Lucid:
> Fix Released
> Status in “telepathy-butterfly” source package in Lucid:
> New
> Status in “papyon” source package in Maverick:
> Fix Released
> Status in “telepathy-butterfly” source package in Maverick:
> New
> Status in “papyon” source package in Karmic:
> Won't Fix
> Status in “telepathy-butterfly” source package in Karmic:
> New
>
> Bug description:
> Binary package hint: empathy
>
> I'm trying to find a bug that is related to this one, but none of the
> options I found matches. When opening Empathy, and trying to connect
> to my MSN accounts (I have two), Empathy keeps trying to connect, but
> nothing happens. There is no error message (so this is not the classic
> "Network error" bug that is solved by killing telepathy-butterfly),
> but the connection is not finalized. Checking the debug window, these
> are the last messages for butterfly:
>
> >>> POST /abservice/abservice.asmx HTTP/1.0
> Content-Length: 1519
> Proxy-Connection: Keep-Alive
> SOAPAction: http://www.msn.com/webservices/AddressBook/ABFindAll
> Host: contacts.msn.com:80
> Accept: text/*
> User-Agent: gnet/0.1 (Linux i686)
> Connection: Keep-Alive
> Cache-Control: no-cache
> Content-Type: text/xml; charset=utf-8
> Accept-Encoding: gzip
>
> <?xml version='1.0' encoding='utf-8'?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><ABApplicationHeader xmlns="http://www.msn.com/webservices/AddressBook"><ApplicationId xmlns="http://www.msn.com/webservices/AddressBook">996CDE1E-AA53-4477-B943-2BE802EA6166</ApplicationId><IsMigration xmlns="http://www.msn.com/webservices/AddressBook">false</IsMigration><PartnerScenario xmlns="http://www.msn.com/webservices/AddressBook">Initial</PartnerScenario></ABApplicationHeader><ABAuthHeader xmlns="http://www.msn.com/webservices/AddressBook"><ManagedGroupRequest xmlns="http://www.msn.com/webservices/AddressBook">false</ManagedGroupRequest><TicketToken xmlns="http://www.msn.com/webservices/AddressBook">t=9xCdFY6ARAad22feO5Sqed4j13RAYGkqdRKTAVZ0QoqR!uqnD2AM8UrgP2wuGwlw5PkavEKGXLq9SS!gomhwcNXVts6RgM!X3aJqqFmCKDWtdwoKwkUA*ZJ4C5xKw!zIx7sa0!L7BY!eY$&amp;p=9xjATSClgG2kOi0KVdQNsQFsqqGzwFIWh3rui4kRMCcnftlp8Ctuh1SRVwIxem1A4x7mqjItHZhnuEijWP*NGwmny2ZUicbdSbLcI...

François Tissandier (baloo) wrote :

It's fixed in Natty & Maverick I think. Both are connecting fine on MSN accounts today.

Mohammad AbuShady (coalwater) wrote :

@josef
10.10 is maverick, natty is 11.04

Chris Austin (sarahorchris) wrote :
Download full text (10.0 KiB)

It was fixed in Maverick and still works in Natty.
-----Original Message-----
From: Coalwater <email address hidden>
Sender: <email address hidden>
Date: Thu, 10 Mar 2011 13:37:12
To: <email address hidden>
Reply-To: Bug 663670 <email address hidden>
Subject: [Bug 663670] Re: empathy doesn't connect to msn - blocked connection

Ok just wondering, why is this still an issue anyway, didn't it get
fixed long way ago, like couple of days after the problem started, is
there some people who are still facing this problem? might be because of
something else.

--
You received this bug notification because you are a direct subscriber
of the bug.
https://bugs.launchpad.net/bugs/663670

Title:
  empathy doesn't connect to msn - blocked connection

Status in telepathy-butterfly:
  Fix Released
Status in “papyon” package in Ubuntu:
  Fix Released
Status in “telepathy-butterfly” package in Ubuntu:
  Incomplete
Status in “papyon” source package in Lucid:
  Fix Released
Status in “telepathy-butterfly” source package in Lucid:
  New
Status in “papyon” source package in Maverick:
  Fix Released
Status in “telepathy-butterfly” source package in Maverick:
  New
Status in “papyon” source package in Karmic:
  Won't Fix
Status in “telepathy-butterfly” source package in Karmic:
  New

Bug description:
  Binary package hint: empathy

  I'm trying to find a bug that is related to this one, but none of the
  options I found matches. When opening Empathy, and trying to connect
  to my MSN accounts (I have two), Empathy keeps trying to connect, but
  nothing happens. There is no error message (so this is not the classic
  "Network error" bug that is solved by killing telepathy-butterfly),
  but the connection is not finalized. Checking the debug window, these
  are the last messages for butterfly:

  >>> POST /abservice/abservice.asmx HTTP/1.0
  Content-Length: 1519
  Proxy-Connection: Keep-Alive
  SOAPAction: http://www.msn.com/webservices/AddressBook/ABFindAll
  Host: contacts.msn.com:80
  Accept: text/*
  User-Agent: gnet/0.1 (Linux i686)
  Connection: Keep-Alive
  Cache-Control: no-cache
  Content-Type: text/xml; charset=utf-8
  Accept-Encoding: gzip

  <?xml version='1.0' encoding='utf-8'?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><ABApplicationHeader xmlns="http://www.msn.com/webservices/AddressBook"><ApplicationId xmlns="http://www.msn.com/webservices/AddressBook">996CDE1E-AA53-4477-B943-2BE802EA6166</ApplicationId><IsMigration xmlns="http://www.msn.com/webservices/AddressBook">false</IsMigration><PartnerScenario xmlns="http://www.msn.com/webservices/AddressBook">Initial</PartnerScenario></ABApplicationHeader><ABAuthHeader xmlns="http://www.msn.com/webservices/AddressBook"><ManagedGroupRequest xmlns="http://www.msn.com/webservices/AddressBook">false</ManagedGroupRequest><TicketToken xmlns="http://www.msn.com/webservices/AddressBook">t=9xCdFY6ARAad22feO5Sqed4j13RAYGkqdRKTAVZ0QoqR!uqnD2AM8UrgP2wuGwlw5PkavEKGXLq9SS!gomhwcNXVts6RgM!X3aJqqFmCKDWtdwoKwkUA*ZJ4C5xK...

Download full text (10.1 KiB)

On one of my machines running 9.04 i did upgrade to 9.10 and then to
10.04 and faced the same problems like in the past on other machines.

I did my discribed manual fixes then for MSN and ICQ and afterwards both
chats were fine again.

So maybe it just was not forseen to fix it in the upgrade process.
But this is very important for my understanding.

A lot of people still need or want to upgrade form older versions to
10.04 L T S !!! long time supported should be fixed in any case is
my oppinion.

kind regards

Am Donnerstag, den 10.03.2011, 13:56 +0000 schrieb Coalwater:
> @josef
> 10.10 is maverick, natty is 11.04
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/663670
>
> Title:
> empathy doesn't connect to msn - blocked connection
>
> Status in telepathy-butterfly:
> Fix Released
> Status in “papyon” package in Ubuntu:
> Fix Released
> Status in “telepathy-butterfly” package in Ubuntu:
> Incomplete
> Status in “papyon” source package in Lucid:
> Fix Released
> Status in “telepathy-butterfly” source package in Lucid:
> New
> Status in “papyon” source package in Maverick:
> Fix Released
> Status in “telepathy-butterfly” source package in Maverick:
> New
> Status in “papyon” source package in Karmic:
> Won't Fix
> Status in “telepathy-butterfly” source package in Karmic:
> New
>
> Bug description:
> Binary package hint: empathy
>
> I'm trying to find a bug that is related to this one, but none of the
> options I found matches. When opening Empathy, and trying to connect
> to my MSN accounts (I have two), Empathy keeps trying to connect, but
> nothing happens. There is no error message (so this is not the classic
> "Network error" bug that is solved by killing telepathy-butterfly),
> but the connection is not finalized. Checking the debug window, these
> are the last messages for butterfly:
>
> >>> POST /abservice/abservice.asmx HTTP/1.0
> Content-Length: 1519
> Proxy-Connection: Keep-Alive
> SOAPAction: http://www.msn.com/webservices/AddressBook/ABFindAll
> Host: contacts.msn.com:80
> Accept: text/*
> User-Agent: gnet/0.1 (Linux i686)
> Connection: Keep-Alive
> Cache-Control: no-cache
> Content-Type: text/xml; charset=utf-8
> Accept-Encoding: gzip
>
> <?xml version='1.0' encoding='utf-8'?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><ABApplicationHeader xmlns="http://www.msn.com/webservices/AddressBook"><ApplicationId xmlns="http://www.msn.com/webservices/AddressBook">996CDE1E-AA53-4477-B943-2BE802EA6166</ApplicationId><IsMigration xmlns="http://www.msn.com/webservices/AddressBook">false</IsMigration><PartnerScenario xmlns="http://www.msn.com/webservices/AddressBook">Initial</PartnerScenario></ABApplicationHeader><ABAuthHeader xmlns="http://www.msn.com/webservices/AddressBook"><ManagedGroupRequest xmlns="http://www.msn.com/webservices/AddressBook">false</ManagedGroupRequest><TicketToken xmlns="http://www.msn.com/webservices/AddressBook">t=9xCdFY6ARAad22feO...

Omer Akram (om26er) wrote :

the issue was in papyon which is fixed in all supported ubuntu versions except for 9.10 because no one tested the proposed version for a few months.

Changed in telepathy-butterfly (Ubuntu):
status: Incomplete → Invalid
Changed in telepathy-butterfly (Ubuntu Lucid):
status: New → Invalid
Changed in telepathy-butterfly (Ubuntu Maverick):
status: New → Invalid
Changed in telepathy-butterfly (Ubuntu Karmic):
status: New → Invalid
Download full text (11.2 KiB)

As i can not find initial correct problem description causing the
problems of connection for msn AND icq i make copy here:

(the same problems i dealed with when updating a machine from 9.04 to
9.10 and to 10.04 LTS afterwards)

here were the workarounds to solve problems "network error" at
connection try:

* In a terminal, run the following command:
   mc-tool update haze/icq/_3<your uin>0 bool:use-ssl=false

   - The extra '3' and '0' are deliberate!

   - For instance, if your ICQ username is '12345', run: mc-tool update
haze/icq/_3123450 bool:use-ssl=false

update on 28th feb 2011:

it seems that update and solution not to have way found to ubuntu
repositoryy. i made update from 9.04 to 9.10 and then to 10.04 LTS
facing same problems like in the past LONG TIME AGO !!!

neither the file is updated like described:
/usr/lib/pymodules/python2.6/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.py

nor a solution for the ssl problem for icq was done
againg both workaround fixed connetion problems

who takes care that solutions also get in repository also for update
way?

Am Freitag, den 11.03.2011, 10:11 +0000 schrieb Omer Akram:
> the issue was in papyon which is fixed in all supported ubuntu versions
> except for 9.10 because no one tested the proposed version for a few
> months.
>
> ** Changed in: telepathy-butterfly (Ubuntu)
> Status: Incomplete => Invalid
>
> ** Changed in: telepathy-butterfly (Ubuntu Lucid)
> Status: New => Invalid
>
> ** Changed in: telepathy-butterfly (Ubuntu Maverick)
> Status: New => Invalid
>
> ** Changed in: telepathy-butterfly (Ubuntu Karmic)
> Status: New => Invalid
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/663670
>
> Title:
> empathy doesn't connect to msn - blocked connection
>
> Status in telepathy-butterfly:
> Fix Released
> Status in “papyon” package in Ubuntu:
> Fix Released
> Status in “telepathy-butterfly” package in Ubuntu:
> Invalid
> Status in “papyon” source package in Lucid:
> Fix Released
> Status in “telepathy-butterfly” source package in Lucid:
> Invalid
> Status in “papyon” source package in Maverick:
> Fix Released
> Status in “telepathy-butterfly” source package in Maverick:
> Invalid
> Status in “papyon” source package in Karmic:
> Won't Fix
> Status in “telepathy-butterfly” source package in Karmic:
> Invalid
>
> Bug description:
> Binary package hint: empathy
>
> I'm trying to find a bug that is related to this one, but none of the
> options I found matches. When opening Empathy, and trying to connect
> to my MSN accounts (I have two), Empathy keeps trying to connect, but
> nothing happens. There is no error message (so this is not the classic
> "Network error" bug that is solved by killing telepathy-butterfly),
> but the connection is not finalized. Checking the debug window, these
> are the last messages for butterfly:
>
> >>> POST /abservice/abservice.asmx HTTP/1.0
> Content-Length: 1519
> Proxy-Connection: Keep-Alive
> SOAPAction: http://www.msn.com/webservices/AddressBook/ABFindAll
> Host: con...

moijafcor (moijafcor) wrote :

I am afraid I am having the "Network Error" message while trying to connect to MSN since upgrading to Lucid from Karmic yesterday.

None of the tricks suggested on this thread works for me.

I would be pleased to provide any details on this bug in order to squeeze it!

Where to start?

moijafcor (moijafcor) wrote :

Follow up to my previous comment (#113).

"None of the tricks" didn't worked because (please don't ask me why) I had one of my Ubuntu workstations logged in Windows Live SkyDrive with the same credentials as the one Empathy tried using to connect to MSN: logged out from SkyDrive and connection successfully established via Empathy + bespoken tricks.

I am trying this on Natty beta and have also tried all the tricks above to no avail. I am logged onto the same account on my work PC with the same credentials, but it used to throw that user off in order to log me on on a fresh session, but this no longer happens. The error says "Network Error" or "No reason specified". Hugely useful - it should tell you "You are already logged on in another session. Please log off before retrying." or something like that.

phonixor (phonixor) wrote :

still have this problem after final release :(

Bidski (bidski) wrote :

I am getting this problem. It started a couple of days ago for me. Kakarots patch does not work for me. After applying kakarots patch I get a network error problem.

A link to a copy of my mission-control log file is attached (after kakarots patch wass applied).
A link to a copy of my butterfly log is also attached (before kakarots path was applied).
A link to a copy of my RequestMultipleSecurityTokens.py file is also attached (with the original unedited line commented out).

I am running:
Ubuntu 10.04
Empathy 2.30.3

EXTERNAL LINKS:
http://www.mediafire.com/?ugdr3ua9igoyvd3 - RequestMultipleSecurityTokens.py
http://www.mediafire.com/?vqtvpd9nmkev8tp - mission-control log
http://www.mediafire.com/?m9nc31glolsgrl3 - butterfly log

Bidski (bidski) wrote :

I just went into Synaptic Package Manager and had a look in there to see what version of python-papyon I had.

Turns out that I had 0.5.1-0ubuntu1~ppa10.04+1 installed (latest version for my distro?). I decided to uninstall that version and install 0.4.8-0ubuntu2 which I acquired from https://launchpad.net/ubuntu/lucid/+package/python-papyon -> https://launchpad.net/ubuntu/lucid/amd64/python-papyon/0.4.8-0ubuntu2. This fixed the problem for me.

However, I decided to reinstall 0.5.1-0ubuntu1~ppa10.04+1 just to confirm that the problem was in that version, but everything is still working. This may have been because I had accidentally deleted my MSN account before I reverted back to the older version of python-papyon and as a result of testing version 0.4.8-0ubuntu2 I had to re-create my MSN account.

Furthermore, in my distro, the line in RequestMultipleSecurityTokens.py that Kakarot changed no longer needs to be changed. The full file for version 0.5.1-0ubuntu1~ppa10.04+1 is attached.

Just in case you missed it. This is fixed for me now.

graingert (tagrain) wrote :

This looks like a dupe of #509721

This bug affects me too on Oneiric:

Ubuntu 11.10
Empathy 3.2.0.1
python-papyon 0.5.5-1ubuntu3.1
telepathy-butterfly 0.5.15-2.1

I also cannot connect using emesene. Empathy does connect when using msn-pecan, though

I also noticed they don't connect to my main account, but do connect to my other accounts (which aren't @hotmail.com)

Workaround:

uninstalling telepathy-butterfly forces empathy to use telepathy-haze, which uses libpurple and works just fine!

Displaying first 40 and last 40 comments. View all 121 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.