Messages are lost without warning if a msn contact changed to invisible

Bug #584380 reported by Shaform on 2010-05-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
papyon
Fix Released
Medium
papyon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: empathy

When you chat with an online contact in msn, (he is using Windows Live Messenger)
if he changed to invisible, all messages you sent afterwards are lost without error notice.
You have to close the chatting window and reopen a new one to chat with him again.

And while the following problems did not occur when I tested them with my two accounts, they happened when I chat with my friends.

1.Chat with an invisible contact in msn while you are online, if you change to invisible, then your messages would be lost without warning (I don't know whether reopening the window would solve this problem.)

2.Chat with an online contact while you are invisible, if she change to invisible, then her messages would be lost without warning. (She is using Windows Live Messenger)
---
Architecture: i386
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
NonfreeKernelModules: wl
Package: empathy 2.30.1-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: ubuntu-une lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Shaform (shaform) wrote :

This happens in Ubuntu 10.04 Netbook version.

apport information

tags: added: apport-collected
description: updated

I cleared the logs first in empathy debug window. then on the window machine changed status to invisible. and what I can see in butterfly logs it thinks he disconnected. the logs later shows a reconnection that happened when *I sent a message from windows messenger* while staying offline. When he sets status to offline my message wont be sent unless he first starts the conversation.

Created an attachment (id=36252)
butterfly logs

Omer Akram (om26er) wrote :

Thanks for the bug report. I was able to recreate this bug so I sent it upstream.

affects: empathy (Ubuntu) → papyon (Ubuntu)
Changed in papyon (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

is papyon the right component for this bug?

Fixed in papyon 0.5.1 and telepathy-butterfly 0.5.14

Changed in papyon:
importance: Unknown → Medium
status: Unknown → Fix Released
Omer Akram (om26er) wrote :

the issue is fixed in papyon 0.5.1 and telepathy-butterfly 0.5.14

Changed in papyon (Ubuntu):
status: Triaged → Fix Released
Changed in papyon:
importance: Medium → Unknown
Changed in papyon:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.