telepathy-butterfly crashed with ValueError in parse()

Bug #343233 reported by Benjamin Fogel on 2009-03-15
284
This bug affects 52 people
Affects Status Importance Assigned to Milestone
pymsn
Fix Released
Medium
papyon (Ubuntu)
Medium
Canonical Desktop Team

Bug Description

Binary package hint: telepathy-butterfly

Stepped away from the PC for a bit and found this when I got back.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: telepathy-butterfly 0.3.3-1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with ValueError in parse()
Uname: Linux 2.6.28-9-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare video

Related branches

Benjamin Fogel (benjaminfogel) wrote :
visibility: private → public

this report has been filed here:

https://bugs.edge.launchpad.net/ubuntu/+source/pymsn/+bug/343233

"Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/pymsn/msnp2p/session_manager.py", line 52, in <lambda>
    lambda tr, blob: self._on_blob_received(blob))
  File "/usr/lib/python2.6/dist-packages/pymsn/msnp2p/session_manager.py", line 97, in _on_blob_received
    session = self._blob_to_session(blob)
  File "/usr/lib/python2.6/dist-packages/pymsn/msnp2p/session_manager.py", line 69, in _blob_to_session
    message = SLPMessage.build(slp_data)
  File "/usr/lib/python2.6/dist-packages/pymsn/msnp2p/SLP.py", line 117, in build
    slp_message.parse(content)
  File "/usr/lib/python2.6/dist-packages/pymsn/msnp2p/SLP.py", line 90, in parse
    self.body = SLPMessageBody.build(content_type, raw_body)
  File "/usr/lib/python2.6/dist-packages/pymsn/msnp2p/SLP.py", line 226, in build
    body.parse(content)
  File "/usr/lib/python2.6/dist-packages/pymsn/msnp2p/SLP.py", line 209, in parse
    HTTPMessage.parse(self, data)
  File "/usr/lib/python2.6/dist-packages/pymsn/gnet/message/HTTP.py", line 91, in parse
    name, value = line.split(":", 1)
ValueError: need more than 1 value to unpack"

Thanks,

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugs.freedesktop.org/show_bug.cgi?id=22553

affects: telepathy-butterfly (Ubuntu) → pymsn (Ubuntu)
Changed in pymsn (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in pymsn:
status: Unknown → Confirmed
Rob Beard (rob-esdelle) wrote :

Just occurred for me on Ubuntu 9.10 (final release) running on the LiveCD environment from a USB stick. It appeared after logging into Empathy with my MSN account details and selected show offline buddies.

Josip Bakić (josip-bakic) wrote :

Happens to me on Ubuntu 9.10. Really annoying.

Serge van Ginderachter (svg) wrote :

Happens me all the time when I have Telepathy running
Karmic on AMD64

tags: added: bugpattern-needed

Also happening in Lucid 10.04

tags: added: bugpattern-written
removed: bugpattern-needed

It happens after updating my image MSN image account on Empathy 2.29.91.2 on Lucid

u-foka (ufooka) wrote :

It seems that I always get many apport reports from telepathy-butterfly after I unlock my system, while I use it it wokrs fine, but If I lock it for only some secs (Ctrl+Alt+L) and then unlock it, apport appears immediately (only once for that small amount of time).

I don't know if it's relevant or not, but anyway: I use flurry as my screensaver.

this is still an issue with papyon, reassigning there, new stacktrace:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/session_manager.py", line 53, in <lambda>
    lambda tr, blob: self._on_blob_received(blob))
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/session_manager.py", line 112, in _on_blob_received
    session = self._blob_to_session(blob)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/session_manager.py", line 96, in _blob_to_session
    message = SLPMessage.build(slp_data)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 120, in build
    slp_message.parse(content)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 93, in parse
    self.body = SLPMessageBody.build(content_type, raw_body)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 229, in build
    body.parse(content)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 212, in parse
    HTTPMessage.parse(self, data)
  File "/usr/lib/pymodules/python2.6/papyon/gnet/message/HTTP.py", line 70, in parse
    name, value = line.split(":", 1)
ValueError: need more than 1 value to unpack

Pedro Villavicencio (pedro) wrote :

This is still an issue on Lucid I've got this twice today, newer backtrace:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/session_manager.py", line 53, in <lambda>
    lambda tr, blob: self._on_blob_received(blob))
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/session_manager.py", line 112, in _on_blob_received
    session = self._blob_to_session(blob)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/session_manager.py", line 96, in _blob_to_session
    message = SLPMessage.build(slp_data)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 120, in build
    slp_message.parse(content)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 93, in parse
    self.body = SLPMessageBody.build(content_type, raw_body)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 229, in build
    body.parse(content)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/SLP.py", line 212, in parse
    HTTPMessage.parse(self, data)
  File "/usr/lib/pymodules/python2.6/papyon/gnet/message/HTTP.py", line 70, in parse
    name, value = line.split(":", 1)
ValueError: need more than 1 value to unpack

I'm also reassigning to papyon since pymsn is no longer used, doing the same with the upstream report.

affects: pymsn (Ubuntu) → papyon (Ubuntu)
Changed in papyon (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
MDPP (mdppatrick) wrote :

This has occured several times on my computer.

Specs:
AMD Athlon 64 3200+
Ubuntu 10.04 LTS (obviously)
telepathy-butterfly 0.5.6-1

I have fully installed 10.04 onto my computer.

Extra info: nothing seems to have effected (predicting that telepathy-butterfly had restarted on me), however, I have seen instances where I couldn't open new chats.

Sebastien Bacher (seb128) wrote :

Could somebody having the issue get the butterfly debug log you can get in the empathy debug dialog or at least the lines before the issue? check for private informations before sending the log though

Billie Thompson (billiecodes) wrote :

I'm seeing this bug every time I disconnect from a network, for example if I pull out the ethernet cable, or move out of wireless range.

Sebastien Bacher (seb128) wrote :

could you get the request log informations?

Hy!

I now got the requested debug log...

The screen started to fade out, and the apport window appeared
immediately (twice)...
So I grabbed the log, cut the end that seems interesting, but I keep the
entire session's log so tell me if I should send more!

On 03/25/2010 01:00 AM, Sebastien Bacher wrote:
> Could somebody having the issue get the butterfly debug log you can get
> in the empathy debug dialog or at least the lines before the issue?
> check for private informations before sending the log though
>
>

@u-foka Hi, thanks for the log it's helpful. Can you please tell us what client your contact <email address hidden> is using? that would help us reproduce the issue.

u-foka (ufooka) wrote :

Hy!

fillter is a linux boy too, so I plan to ask him since I read the log :)
But since then I found another contact that causes tis, who using pidgin
on windows xp... Her computer even managed by my, so I will check and
tell you the exact version number, and we can meet on IRC and do some
testing around the problem if U want to!

On 04/01/2010 06:49 PM, Olivier Le Thanh Duong wrote:
> @u-foka Hi, thanks for the log it's helpful. Can you please tell us what
> client your contact <email address hidden> is using? that would help us
> reproduce the issue.
>
>

u-foka (ufooka) wrote :

Well, i tryed to reproduce the problem with the pidgin machine without
success :(
But I got fillter online (as soon he logged in, the error appeared :D),
he using kopete 0.80.2 on kde 4.3.5, opensuse 112, now I'l try to dump
the network traffic when the error occurs, tell me if you need that!

On 04/01/2010 06:49 PM, Olivier Le Thanh Duong wrote:
> @u-foka Hi, thanks for the log it's helpful. Can you please tell us what
> client your contact <email address hidden> is using? that would help us
> reproduce the issue.
>
>

@u-foka thanks, additionals logs won't be necessary, I think I found the issue and fixed it. A package should be made soon so you can test it. Or if you know your way around you can try the fix directly at http://git.collabora.co.uk/?p=user/olethanh/papyon.git;a=shortlog;h=refs/heads/fix_22553 (btw the issue seems to be caused when a contact request your avatar if you have trouble reproducing it now)

Sebastien Bacher (seb128) wrote :

Thank Olivier, I've uploaded that to lucid let's see if it gets approved for beta2 or after it now

Changed in papyon (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package papyon - 0.4.5-1ubuntu4

---------------
papyon (0.4.5-1ubuntu4) lucid; urgency=low

  * debian/patches/90_git_clean_trailing_x00.patch:
    - clean trailing x00 and fix a telepathy-butterfly crash issue,
      thanks Olivier Le Thanh Duong (lp: #343233)
 -- Sebastien Bacher <email address hidden> Thu, 01 Apr 2010 22:58:04 +0200

Changed in papyon (Ubuntu):
status: Fix Committed → Fix Released

*** Bug 24121 has been marked as a duplicate of this bug. ***

this branch should fixes the problem

(In reply to comment #3)
> this branch should fixes the problem

Good catch. Get merging!

Reviewed, mergeable. thanks

Changed in pymsn:
importance: Unknown → Medium
status: Confirmed → Fix Released
Changed in pymsn:
importance: Medium → Unknown
Changed in pymsn:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.