Ubuntu

[te]Bugs in Telugu,Kannda rendering-regression on 11.04 beta1

Reported by arjuna rao chavala on 2011-04-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pango
Fix Released
Critical
pango1.0 (Ubuntu)
High
Unassigned

Bug Description

Bugs that are fixed in the previous releases have regressed in 11.04 beta 1. The upstream bugs were not attended by the maintainer, as there is work in progress for a new harfbuzz-ng version under development. But the target for indic support is not clear. It would be helpful for Telugu and Kannada community, if the bug fixes previously done are included for 11.04

Details of previous bugs for which fixes were released in previous version.
https://bugs.launchpad.net/ubuntu/+source/ttf-indic-fonts/+bug/219949
https://bugs.launchpad.net/ubuntu/+source/pango1.0/+bug/619914

Additional information
$lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

apt-cache policy pango1.0
libpango1.0-0:
  Installed: 1.28.3-4ubuntu7
  Candidate: 1.28.3-4ubuntu7
  Version table:
 *** 1.28.3-4ubuntu7 0
        500 http://in.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
libpango1.0-doc:
  Installed: (none)
  Candidate: 1.28.3-4ubuntu7
  Version table:
     1.28.3-4ubuntu7 0
        500 http://in.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
libpango1.0-dev:
  Installed: (none)
  Candidate: 1.28.3-4ubuntu7
  Version table:
     1.28.3-4ubuntu7 0
        500 http://in.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
pango1.0-multiarch-modver-1.6.0:
  Installed: (none)
  Candidate: (none)
  Version table:
libpango1.0-0-dbg:
  Installed: (none)
  Candidate: 1.28.3-4ubuntu7
  Version table:
     1.28.3-4ubuntu7 0
        500 http://in.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Changed in pango1.0 (Ubuntu):
status: New → Confirmed
arjuna rao chavala (arjunaraoc) wrote :

Patch to fix the same is enclosed. Kindly include the patch into 11.04 beta2 so that several Telugu and Kannada users will benefit. It is even more important for them, as these two languages are debuting with boot level localisation in 11.04

arjuna rao chavala (arjunaraoc) wrote :

The i386 version of updated packages are available for download for a limited period at
https://docs.google.com/leaf?id=0B9VHTVzubonwZDU5ODliNTMtYTc1YS00MGMzLWJlYWItNjVkZWI1YmRiMTE1&hl=en

tags: added: patch
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you give details on what version broke it? There was no distro patch for that issue and nothing in the upstream git log seems like likely to create that issue

Changed in pango1.0 (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
arjuna rao chavala (arjunaraoc) wrote :

Looks like I may have misunderstood the status "Fix released" against the bugs. The bugs were submitted after 8.04 and 10.04 versions. The patches were developed and submitted upstream as well as in launchpad. Upstream maintainer did not commit the patches, as there is no focus on maintaining the old version. But there is no clarity on when the new version for indic will be ready. I might have been under the impression that Ubuntu released the patched files , when I saw the status as "Fix released".
I request you to integrated the patches into ubuntu build package now.

Robert Ancell (robert-ancell) wrote :

Based on the debdiff linking upstream bug:
https://bugzilla.gnome.org/show_bug.cgi?id=565599

Robert Ancell (robert-ancell) wrote :

Digging further around, this seems to be the correct location of the upstream bug

Robert Ancell (robert-ancell) wrote :

The changes to pango should in quilt format, I've extracted the patch from the bug and am attaching here.
Review of the patch:
- It is a large and complex change
- There are a number of unnecessary changes, e.g. whitespace or comments that seem obsolete. This will make the patch an ongoing problem to apply
- Upstream has closed the bug as fixed and not allowed the patch to be applied to trunk. I'm not sure what the reason for this is.

For the above reasons I can't tell how correct this patch is, and the change seems to carry a lot of risk and has an ongoing maintenance issue.

Arjuna, for this patch to be accepted I would want to see someone experienced in Pango to review it and say it is safe/correct, and the patch be as small as possible so it only contains the required changes.

Changed in pango:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.