libpam-modules, multiarch, trouble installing

Bug #885361 reported by seeker5528 on 2011-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pam (Ubuntu)
Undecided
Unassigned

Bug Description

On a multiarch system i386 native, amd64 foreign, I previously installed libpam-modules:amd64, but now when attempting to update I get a complaint about a file:

root@lubuntu:/home/ccs/DebDownload# dpkg -i libpam-modules_1.1.3-5ubuntu2_*
Selecting previously unselected package libpam-modules:amd64.
(Reading database ... 145574 files and directories currently installed.)
Preparing to replace libpam-modules:amd64 1.1.3-5ubuntu2 (using libpam-modules_1.1.3-5ubuntu2_amd64.deb) ...
Unpacking replacement libpam-modules:amd64 ...
Unpacking libpam-modules (from libpam-modules_1.1.3-5ubuntu2_i386.deb) ...
dpkg: error processing libpam-modules_1.1.3-5ubuntu2_i386.deb (--install):
 './usr/share/man/man8/pam_shells.8.gz' is different from the same file on the system
Setting up libpam-modules:amd64 (1.1.3-5ubuntu2) ...
Processing triggers for man-db ...
Errors were encountered while processing:
 libpam-modules_1.1.3-5ubuntu2_i386.deb

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libpam-modules (not installed)
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
ApportVersion: 1.24-0ubuntu1
Architecture: i386
Date: Wed Nov 2 11:11:15 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pam
UpgradeStatus: Upgraded to precise on 2011-05-04 (181 days ago)

seeker5528 (seeker5528) wrote :

I was able to downgrade the relevant packages:

libpam-modules_1.1.3-5ubuntu1_amd64.deb libpam-modules_1.1.3-5ubuntu1_i386.deb libpam-modules-bin_1.1.3-5ubuntu1_amd64.deb

They installed without the error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers