asks debconf question during upgrade

Bug #141309 reported by Michael Vogt on 2007-09-20
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pam (Ubuntu)
Medium
Kees Cook

Bug Description

The package asks a debconf question about services to be restarted. This question should not be asked during a upgrade but it should do something sensible by default.

Related branches

Kees Cook (kees) wrote :

We can lower the priority to medium when running an upgrade. Service restart failures will still be reported at "critical", though (since we shouldn't have any).

Changed in pam:
assignee: nobody → keescook
importance: Undecided → Medium
status: New → Triaged
Kees Cook (kees) on 2007-09-25
Changed in pam:
status: Triaged → Fix Released
Kees Cook (kees) wrote :

pam (0.99.7.1-4ubuntu4) gutsy; urgency=low

  * debian/libpam0g.postinst: call "reload" for all display managers
    (LP: #139065).
  * debian/libpam0g.postinst: only ask questions during update-manager when
    there are non-default services running (LP: #141309).

 -- Kees Cook <email address hidden> Mon, 24 Sep 2007 15:01:29 -0700

Kees Cook (kees) wrote :

(Please note: this is _not_ a duplicate of 139065 -- they are separate issues.)

Jorge Juan (jjchico) wrote :

I see. The two issues are strongly related anyway: 1) pam should not ask, but do something by default. 2) the default should be to call "reload" instead of "restart".

I am marking #139372 a duplicate of this bug. Can you check this?

Thanks for your effort.

jorge.

Steve Langasek (vorlon) wrote :

pam (0.99.7.1-5ubuntu1) gutsy; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - debian/control, debian/local/common-session{,md5sums}: use
      libpam-foreground for session management.
    - debian/rules: install unix_chkpwd setgid shadow instead of setuid root.
      The nis package handles overriding this as necessary.
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's not
      present there or in /etc/security/pam_env.conf.
    - debian/patches-applied/ubuntu-fix_standard_types: Use standard u_int8_t
      type rather than __u8.
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits. Bound
      RLIMIT_NICE from below as well as from above. Fix off-by-one error when
      converting RLIMIT_NICE to the range of values used by the kernel.
      (Originally patch 101; converted to quilt.)
    - debian/patches-applied/ubuntu-user_defined_environment: Look at
      ~/.pam_environment too, with the same format as
      /etc/security/pam_env.conf. (Originally patch 100; converted to quilt.)
    - debian/patches-applied/ubuntu-regression_fix_securetty: securetty's
      earlier behavior would correctly prompt for password on bad usernames
      (LP: #139075).
    - Build using db4.5 instead of db4.6.
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running (LP: #141309).
  * debian/libpam0g.postinst: don't display a debconf warning about display
    managers that need restarting when update-manager is running, instead
    signal to update-notifier if a reboot is required.

 -- Steve Langasek <email address hidden> Fri, 28 Sep 2007 23:45:24 -0700

Haggai Eran (haggai-eran) wrote :

This happened to me today when upgrading from Natty to Oneiric.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers