pam upgrade restarts kdm without warning

Bug #139065 reported by Alf Lervåg on 2007-09-12
2
Affects Status Importance Assigned to Milestone
pam (Ubuntu)
Medium
Kees Cook

Bug Description

Binary package hint: libpam0g

When I upgraded my Gutsy Tribe 5 today, libpam0g notified me that the following services needed a restart for the changes to take effect. Among the listet were cupsys, kdm, at, etc. I noticed that kdm was in the list, but as the choice was kdm and since it wasn't obvious to me that I should edit this list manually, I pressed the <Next> button. Immediately, kdm was restarted. This, of course, caused the upgrade to be aborted, as well as losing all my work.

Since the button was labeled <Next>, I expected another dialogue. If the button was labeled <Restart> I would've hesitated to click it since I know what happends if you restart kdm. However, less experienced users would have no idea what just happened.

ProblemType: Bug
Architecture: i386
Date: Wed Sep 12 09:12:37 2007
DistroRelease: Ubuntu 7.10
NonfreeKernelModules: fglrx
Uname: Linux azalyn 2.6.22-11-generic #1 SMP Fri Sep 7 05:07:05 GMT 2007 i686 GNU/Linux

Related branches

Saurus (saurus) wrote :

I just confirm it...
I cannot upgrade my kubuntu :-(

Alf Lervåg (alf-lervag) wrote :

Workaround: remove kdm from the list before pressing next. This should let the upgrade process continue.

Saurus (saurus) on 2007-09-13
Changed in pam:
status: New → Confirmed
Saurus (saurus) wrote :

According to Alf Lervåg, remove kdm from the list before pressing next, but only with "Adept"... See the Attachment

Jonathan Riddell (jr) on 2007-09-24
Changed in pam:
importance: Undecided → High
Kees Cook (kees) wrote :

We can fix this by calling "reload" for kdm as is done for gdm.

Changed in pam:
assignee: nobody → keescook
importance: High → Medium
status: Confirmed → Triaged

Still, the upgrade should not be stopped to ask the user. Lowering the
priority of the question in debconf may be an option here.

jorge.

2007/9/24, Kees Cook <email address hidden>:
> We can fix this by calling "reload" for kdm as is done for gdm.
>
> ** Changed in: pam (Ubuntu)
> Importance: High => Medium
> Assignee: (unassigned) => Kees Cook (keescook)
> Status: Confirmed => Triaged
>
> --
> pam upgrade restarts kdm without warning
> https://bugs.launchpad.net/bugs/139065
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Jorge Juan

Kees Cook (kees) on 2007-09-25
Changed in pam:
status: Triaged → Fix Released
Kees Cook (kees) wrote :

pam (0.99.7.1-4ubuntu4) gutsy; urgency=low

  * debian/libpam0g.postinst: call "reload" for all display managers
    (LP: #139065).
  * debian/libpam0g.postinst: only ask questions during update-manager when
    there are non-default services running (LP: #141309).

 -- Kees Cook <email address hidden> Mon, 24 Sep 2007 15:01:29 -0700

Steve Langasek (vorlon) wrote :

Calling "reload" for kdm is not a complete fix, because kdm does not re-exec itself in response to a reload command; this papers over the problem of kdm unexpectedly restarting during upgrade, but leaves unaddressed the root reason for the restart - that after upgrading the PAM modules, users will no longer be able to log in via kdm until it's restarted.

Suggested patch (merge from Debian unstable) to follow.

Changed in pam:
status: Fix Released → Confirmed
Steve Langasek (vorlon) wrote :
Steve Langasek (vorlon) wrote :

same debdiff with fixed upload target

Steve Langasek (vorlon) wrote :

Fix uploaded, sponsored by Kees, but I forgot to include the bug number in the changelog:

 pam (0.99.7.1-5ubuntu1) gutsy; urgency=low

   * Resynchronise with Debian. Remaining changes:
     - debian/control, debian/local/common-session{,md5sums}: use
       libpam-foreground for session management.
     - debian/rules: install unix_chkpwd setgid shadow instead of setuid root.
       The nis package handles overriding this as necessary.
     - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's not
       present there or in /etc/security/pam_env.conf.
     - debian/patches-applied/ubuntu-fix_standard_types: Use standard u_int8_t
       type rather than __u8.
     - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
       initialise RLIMIT_NICE rather than relying on the kernel limits. Bound
       RLIMIT_NICE from below as well as from above. Fix off-by-one error when
       converting RLIMIT_NICE to the range of values used by the kernel.
       (Originally patch 101; converted to quilt.)
     - debian/patches-applied/ubuntu-user_defined_environment: Look at
       ~/.pam_environment too, with the same format as
       /etc/security/pam_env.conf. (Originally patch 100; converted to quilt.)
     - debian/patches-applied/ubuntu-regression_fix_securetty: securetty's
       earlier behavior would correctly prompt for password on bad usernames
       (LP: #139075).
     - Build using db4.5 instead of db4.6.
     - debian/libpam0g.postinst: only ask questions during update-manager when
       there are non-default services running (LP: #141309).
   * debian/libpam0g.postinst: don't display a debconf warning about display
     managers that need restarting when update-manager is running, instead
     signal to update-notifier if a reboot is required.

Changed in pam:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers