please bring back padevchooser

Bug #851695 reported by Michael Basse on 2011-09-16
142
This bug affects 32 people
Affects Status Importance Assigned to Milestone
padevchooser (Debian)
Fix Released
Unknown
padevchooser (Ubuntu)
Undecided
Unassigned

Bug Description

The package "padevchooser" is not available in Ubuntu 11.10 but in all other releases

see http://packages.ubuntu.com/search?keywords=padevchooser&searchon=names&suite=all&section=all

Its a great tool for streaming audio to another pulseaudio-server. It should be put in the repos of 11.10.

or is there a special reason why it has been removed?

https://launchpad.net/ubuntu/oneiric/+source/padevchooser/0.9.3-2ubuntu4

Removal requested on 2011-05-30.
Deleted on 2011-05-30 by Martin Pitt

unmaintained upstream, replaced by pavucontrol

so i will close this bug as invalid

Changed in padevchooser (Ubuntu):
status: New → Invalid
Fulike (fulike) wrote :

Pavucontrol can streaming to other computer with gui?

Pavucontrol can stream audio from a pc using pulseaudio to another pc using pulseaudio

Ubuntu before 11.10 is using padevchooser. 11.10 is using pavucontrol

Fulike (fulike) wrote :

But how? I can't see the function, where can I adjust another IP, because I would like to stream my computer to another.

Tigra (tigra-nlp) wrote :

Pavucontrol's interface does not allow to stream to another computer, so pavucontrol is not a replacement for padevchooser.
Marking this bug as "invalid" was invalid :)

Changed in padevchooser (Ubuntu):
status: Invalid → New

you are right. Never tested it after i found the changelog mentioned in https://bugs.launchpad.net/ubuntu/+source/padevchooser/+bug/851695/comments/1

So is there a way to add "padevchooser" into the stable-release of 11.10? or is it only possible for an unstable release?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in padevchooser (Ubuntu):
status: New → Confirmed
Andy M (andrew-anvil) wrote :

Is this coming back in. I find it very useful on Fedora for configuring sound flows.

Rolf Leggewie (r0lf) on 2011-11-08
summary: - padevchooser is missing in Ubuntu 11.10
+ please bring back padevchooser
Rolf Leggewie (r0lf) wrote :

I see zero chance of this package coming back. The package has been dead for years. Please use a PPA instead if you really want it. I think you're better off asking for the functionality you miss to be added to the proposed replacement.

Closing as wontfix.

Changed in padevchooser (Ubuntu):
status: Confirmed → Won't Fix
Rolf Leggewie (r0lf) wrote :

I'm not affected by this bug at all but I've opened a ticket in pavucontrol for you guys

https://bugs.launchpad.net/ubuntu/+source/pavucontrol/+bug/887456/+affectsmetoo to cast your vote ;-)

Rolf Leggewie (r0lf) wrote :

It turns out, the missing functionality has been a long-standing issue and possibly merely a UI problem (see comment #2 from bug 526196)

https://bugs.launchpad.net/ubuntu/+source/pavucontrol/+bug/526196/+affectsmetoo

I used padevchooser before upgrade to 11.10. I need it to use speakers of my home computer from my other home computer over network. I need a simple GUI to select the server.

Comments do not say anything about how to enable the functionality I need. See comments #4 and #5.

Here is a workaround.
I added this line at the bottom of /etc/profile
export PULSE_SERVER=10.20.30.40
10.20.30.40 is IP address of server.

It is not GUI but it works for me.

Changed in padevchooser (Debian):
status: Unknown → Fix Released
epe (eric-poscher) wrote :

It is also a regression in functionality if you have several sound devices. Previously, with padevchooser it was possible to move a sound stream (e.g. the output from skype to the analog output while music from banshee is playing via the HDMI output connected to the speakers.)

AdlerHorst (adlerhorst) wrote :

as a rplacement i use https://launchpad.net/~christoph-gysin/+archive/pasystray at moment. It works really god for me.

l3iggs (l3iggs-c) wrote :

I don't understand the reasoning behind closing this bug as won't fix. I'm not sure in what sense padevchooser has been "dead for years" or why that warrants closing the bug.

All I know is that padevchooser had functionality that I used on a daily basis (the ability to choose another sound server with a GUI) and now it's gone and there is no replacement.

One of the greatest features of pulseaudio sound system is the way it decouples the sound servers and sinks. That functionality should be exposed in an easy to use way.

I have the same opinion like l3iggs

Ladislav Urošević (urosldp) wrote :

I don't understand the reasoning behind closing this bug as won't fix. I'm not sure in what sense padevchooser has been "dead for years" or why that warrants closing the bug.

Hehe, no new fancy and totaly confusing UI for ages.

pataquets (pataquets) wrote :

I've updated to Precise and the ability to switch from local speakers to network attached ones is lost. It's a real pain, since I switched devices continiously. I'm in the very same situation and opinion of l3iggs.
+1 against closing the bug. IMO, padevchooser or some alternative should be packaged to prevent losing functionality.
Without any (GUI) alternative, it's a clear functionality regression.
Please, reopen.

god (humper) wrote :

It seems like Debian actually release fx for this.
Ubuntu should follow - creating bug for some other tool is in no way solution to serious user-visible regression.

Matthew Stoltenberg (d3matt) wrote :

if anyone is still interested in this app, I created a clone of the upstream repo that builds with pulse-1.1. They removed libpulse-browse in upstream. I haven't tested this build on Ubuntu as I don't use it very often.

https://github.com/d3matt/padevchooser.git

Rob Whyte (fudge) wrote :

Does pavucontrol also allow sending various streams to different output devices as padev did?

pvagner (peter-v) wrote :

I miss ability to move sources to the other output devices like many others.
Most likelly I am going to compile fork proposed in comment 20. I would instead prefer if it would be available for everybody so special expertise is no required to install it.

robled (robled) wrote :

Has this been resolved in Quantal? I'm running 12.10 and I've noticed that the standard "Sound Settings" applet has network Pulseaudio outputs available. I'm attaching a screenshot of this UI.

Marcus (m-beyer5) wrote :

@23

ntolerance, could you please share your configuration? I am using quantal and have a remote pulseaudio server, published over avahi, but the sound settings applet only shows local devices, same with pavucontrol.
Hints would be appreciated.

robled (robled) wrote :

Hey Marcus,

I had this working, but it seems broken now. I recall using the Arch wiki to set this up:

https://wiki.archlinux.org/index.php/PulseAudio/Examples#PulseAudio_over_network

Of course I had the same ~/.pulse-cookie file on the server and client. I always stay away from the "don't require authenticaton" business.

At one time I had 12.04 running on the server and client. The client is now running 12.10 (server still at 12.04). This may have broken my configuration, but I'm not entirely sure.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.