[Maverick] kpackagekit won't honor apt proxy setings

Bug #633008 reported by Swâmi Petaramesh on 2010-09-08
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: kpackagekit

kpackagekit will ignore http proxy settings set either in /etc/apt config or in /etc/PackageKit/PackageKit.conf , thus it is unusable along with an apt-cacher or the like.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: kpackagekit 0.6.0+svn1167871-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Wed Sep 8 10:56:17 2010
EcryptfsInUse: Yes
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100902.1)
ProcEnviron:
 LANGUAGE=
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: kpackagekit

Daniel Nicoletti (dantti) wrote :

Does it work if you set the proxy settings in KDE?
I've tested with KDE proxy settings and it works quite well.

@Daniel: Idon't know if kpackagekit would honor or not a generic HTTP proxy setting, but it isn't the point: I don't have any generic HTTP proxy and don't want to setup any such thing. I have a specific apt-cacher that apt-get, aptitude and kpackagekit *MUST* use (because of Internet bandwidth issues) but that can't be used i.e. by a browser, so I cannot define a "proxy setting in KDE".

Kind regards.

bigbrovar (bigbrovar) wrote :

@Daniel the issue here is not about generic http proxy. it concern specific apt proxy called apt-cacher. which is a server that intercepts apt requests and downloads them to a cache so that anyone within the lan who needs such packages would not need to download it from the internet. All I have to do is add the proxy detail to /etc/apt/apt.conf.d/01proxy synaptic package manager also supports it under settings/preference/networking kpackagekit does not have support for it at all and its a very big deal breaker for many within large organisations who use Kubuntu.

Daniel Nicoletti (dantti) wrote :

KPackageKit is actually able to use apt-cacher BUT the config _must_ go into kde proxy settings or /etc/PackageKit/PackageKit.conf.

Not the best solution for sure, but I have fixed this issue now it just need a new PackageKit package.

Daniel Nicoletti (dantti) wrote :

BTW
Instead of having that /etc/apt/apt.conf.d/ file, with this content
Acquire::http::Proxy "http://localhost:3142";

The work around is to set the kde proxy or PackageKit proxy to:

http://localhost:3142

bigbrovar (bigbrovar) wrote :

I added the proxy settings to etc/PackageKit/PackageKit.conf and kpackagekit still ignores it when trying to download packages. here is my /etc/PackageKit/PackageKit.conf tell me if I am doing anything wrong

Daniel Nicoletti (dantti) wrote :

can you kill packagekitd and try again? It's the only way to re-read that info

Matthias Klumpp (ximion) wrote :

Looks like this is fixed upstream (d1a434a)
Patch might need to be included in the Ubuntu package.

Changed in kpackagekit (Ubuntu):
status: New → Confirmed
tags: added: pk-aptcc-backend
affects: kpackagekit (Ubuntu) → packagekit (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.6.8-0ubuntu4

---------------
packagekit (0.6.8-0ubuntu4) natty; urgency=low

  * Add 07_apt_proxy.patch from upstream
    Fixes LP: #633008
    "kpackagekit won't honor apt proxy setings"
  * Add 06_aptcc_crash.patch from upstream
    Fixes http://bugs.kde.org/253930
    KPackageKit crashed after clicking on "Check for new updates"
 -- Jonathan Riddell <email address hidden> Thu, 11 Nov 2010 16:10:06 +0000

Changed in packagekit (Ubuntu Natty):
status: Confirmed → Fix Released
Jonathan Riddell (jr) wrote :
Jonathan Riddell (jr) wrote :

Uploaded to maverick-proposed with patches for this bug and http://bugs.kde.org/253930

Upstream commits:
http://gitorious.org/packagekit/packagekit/commit/05ad4000c1110d49d1530db9a0589dd02147744b and http://gitorious.org/packagekit/packagekit/commit/41b89ee7febac04fa241acf59097cfa8d7835087

TEST CASE: set apt proxy, old version will not download from it, new version will

TEST CASE for second patch: needs broken mirror to recreate crash

bigbrovar (bigbrovar) wrote :

Does this mean that those of us on Maverick can get this fix by enabling Maverick-proposed repository. also which particular package contains this fix because I just enabled maverick proposed on my laptop and I did not see any kpackagekit related update

Accepted packagekit into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in packagekit (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Jonathan Riddell (jr) on 2010-11-15
tags: added: kubuntu
Jonathan Riddell (jr) on 2010-11-22
Changed in packagekit (Ubuntu Maverick):
milestone: none → maverick-updates
Daniel Nicoletti (dantti) wrote :

I've tested the package on maverick-proposed and it works with apt-cacher.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.6.8-0ubuntu3.1

---------------
packagekit (0.6.8-0ubuntu3.1) maverick-proposed; urgency=low

  * Add 07_apt_proxy.patch from upstream
    Fixes LP: #633008
    "kpackagekit won't honor apt proxy setings"
  * Add 06_aptcc_crash.patch from upstream
    Fixes http://bugs.kde.org/253930
    KPackageKit crashed after clicking on "Check for new updates"
 -- Jonathan Riddell <email address hidden> Thu, 11 Nov 2010 16:10:06 +0000

Changed in packagekit (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers