packagekit in maverick causes error in apt operations

Bug #613412 reported by Alexander Sack on 2010-08-04
154
This bug affects 41 people
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: packagekit

i upgraded in maverick today and suddenly i got these errors at the end of all apt operations (e.g. apt-get update etc.)

Hit http://archive.ubuntu.com maverick-updates/restricted i386 Packages
Error org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Reading package lists... Done

removing packagkit and the apt backend for it, fixed it.

Related branches

Alexander Sack (asac) wrote :

I am not sure if it really hurt. i think some operations failed with non zero exit code. Tentatively marking as release critical.

Changed in packagekit (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in packagekit (Ubuntu Maverick):
milestone: none → ubuntu-10.10-beta
Jonathan Riddell (jr) wrote :

What version of packagekit do you have installed? What packagekit backends do you have installed?

Does the problem go away when you remove this file? /etc/apt/apt.conf.d/20packagekit

papukaija (papukaija) on 2010-08-04
tags: added: maverick
fejes (anthony-fejes) wrote :

deleting /etc/apt/apt.conf.d/20packagekit solved the problem for me.

Deleting that file solved it for me as well - Thx Jonathan!

My packagekit-backend-apt is v0.6.6+20100703a-0ubuntu2

Daniel Nicoletti (dantti) wrote :

by the message it's some problem with the python apt backend
Error org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Was PackageKit working with it?
All messages in 20packagekit were going to > /dev/null do you think I need to change to 2>&1 /dev/null ?

deleting /etc/apt/apt.conf.d/20packagekit solved the problem for me.

DaleEMoore (daleemoore) wrote :

Thanks folks!

sudo rm /etc/apt/apt.conf.d/20packagekit

No more error.

I think the deletion of 20packagekit was just a test Jonathan wanted the original poster to perform in order to confirm where the problem lies, and is not an outright fix.

Upgrading packagekit yesterday showed that the file is still part of the package (and allowing it to put it back showed the same problem still exists).

--------------------------

Setting up packagekit (0.6.6+20100703a-0ubuntu3) ...

Configuration file `/etc/apt/apt.conf.d/20packagekit'
 ==> Deleted (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
 The default action is to keep your current version.
-------------------------

Daniel Nicoletti (dantti) wrote :

Yes, deleting the file is not a FIX for the problem.
That file is needed in order to keep the UI up to date.
Does using PackageKit with the apt backend returns this error?

Felix Geyer (debfx) wrote :

If you still have this problem, please post the output of the following commands:
dpkg -l | grep packagekit
grep DefaultBackend /etc/PackageKit/PackageKit.conf

Felix Yan (felixonmars) wrote :

Still have the error:
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Error org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

Here are the outputs

# dpkg -l | grep packagekit
ii kpackagekit 0.6.0-0ubuntu3 KDE package management tool using PackageKit
rc libpackagekit-glib2-12 0.5.7-0ubuntu2 Advanced library for accessing PackageKit using GLib
ii libpackagekit-glib2-14 0.6.6+20100703a-0ubuntu3 Advanced library for accessing PackageKit using GLib
rc libpackagekit-qt-12 0.5.7-0ubuntu2 Library for accessing PackageKit using Qt.
ii libpackagekit-qt-14 0.6.6+20100703a-0ubuntu3 Library for accessing PackageKit using Qt.
ii packagekit 0.6.6+20100703a-0ubuntu3 provides a software installation daemon
ii packagekit-backend-apt 0.6.6+20100703a-0ubuntu3 APT backend for packagekit
ii python-packagekit 0.6.6+20100703a-0ubuntu3 PackageKit Python bindings

# grep DefaultBackend /etc/PackageKit/PackageKit.conf
DefaultBackend=aptcc

dino99 (9d9) wrote :

got this error while updating package

has been reported against policykit on Redhat: https://bugzilla.redhat.com/show_bug.cgi?id=445816

freedesktop says:
The specified method is not implemented on this object (but the object and the interface names are valid)
http://freedesktop.org/wiki/Software/DBusBindingErrors

Daniel Nicoletti (dantti) wrote :

Hmm I think I spoted the problem:

# grep DefaultBackend /etc/PackageKit/PackageKit.conf
DefaultBackend=aptcc

In the new PackageKit the default backend is aptcc, and seems that most of you don't
have it, so this error appears, if you install the aptcc backend this error goes away?

Felix Geyer (debfx) wrote :

Yes, when upgrading from lucid to maverick packagekit-backend-aptcc isn't installed as
packagekit depends packagekit-backend-aptcc or packagekit-backend-apt or packagekit-backend-smart.

The linked merge request should fix this.

Felix Yan (felixonmars) wrote :

Thanks! During the packagekit-backend-aptcc's installation the X crashed, but after restarting the apt has no problem when updating or upgrading :)

dino99 (9d9) wrote :

packagekit-backend-apt is installed on my end, so packagekit-backend-aptcc is not installed, which seem normal as the comment about that package says:

" This package provides an alternative backend which is writtin in C++ to
target systems with low memory."

as my system use 4 Go ram, it should not be considered as a low memory system (i386)

Daniel Nicoletti (dantti) wrote :

dino99,
This is not about your system having 1TB of ram or 128MB,
it's about the aptcc backend being the default in maverick
but the PackageKit.conf file is not being automaticaliy
updated.
We just need to create a few scripts and probably
use debconf to make the selection easier.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.6.7-0ubuntu1

---------------
packagekit (0.6.7-0ubuntu1) maverick; urgency=low

  * New upstream release.
  * Drop 20packagekit_error.diff, applied upstream.
  * Make packagekit depend on packagekit-backend-aptcc without alternative
    dependencies as the default config requires it. (LP: #613412)
    - Move the apt and smart backends to Suggests.
  * Add python and python-packagekit to the packagekit-backend-aptcc
    dependencies as get-distro-upgrade.py requires them. (LP: #614168)
 -- Felix Geyer <email address hidden> Sun, 08 Aug 2010 12:46:44 +0200

Changed in packagekit (Ubuntu Maverick):
status: Confirmed → Fix Released
Bob Vincent (pillarsdotnet) wrote :
Download full text (3.9 KiB)

I'm experiencing the same problem in Oneiric.

Deleting /etc/apt/apt.conf.d/20packagekit made the error message go away.

I did have packagekit-backend-aptcc installed.

I'm going to reinstall packagekit and see if that fixes things...

(reinstalling via "apt-get install --reinstall")

Hmm.. It didn't re-create the /etc/apt/apt.conf.d/20packagekit file.

(apt-get purge packagekit; apt-get install packagekit)

Now it's back. Gonna install packagekit-backend-smart as suggested:

sudo apt-get install packagekit-backend-smart
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  python-smartpm smartpm-core
The following NEW packages will be installed:
  packagekit-backend-smart python-smartpm smartpm-core
0 upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
Need to get 357 kB of archives.
After this operation, 3,121 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-smartpm i386 1.4-1ubuntu1 [331 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe smartpm-core i386 1.4-1ubuntu1 [4,760 B]
Get:3 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe packagekit-backend-smart i386 0.6.15-1build1 [20.7 kB]
Fetched 357 kB in 2s (159 kB/s)
Selecting previously deselected package python-smartpm.
(Reading database ... 580070 files and directories currently installed.)
Unpacking python-smartpm (from .../python-smartpm_1.4-1ubuntu1_i386.deb) ...
Selecting previously deselected package smartpm-core.
Unpacking smartpm-core (from .../smartpm-core_1.4-1ubuntu1_i386.deb) ...
Selecting previously deselected package packagekit-backend-smart.
Unpacking packagekit-backend-smart (from .../packagekit-backend-smart_0.6.15-1build1_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for packagekit ...
Setting up python-smartpm (1.4-1ubuntu1) ...
Setting up smartpm-core (1.4-1ubuntu1) ...
Setting up packagekit-backend-smart (0.6.15-1build1) ...
Error org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 127

(sigh) Now the error is back.

Restarting dbus to see if that fixes the problem...

(sudo stop dbus; sudo start dbus) (close various KDE crash notifications)

(apt-get purge amor ; apt-get install amor)

Still seeing this error:

Error org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 127

dpkg -l | grep packagekit
rc libpackagekit-glib2-12 0.5.7-0ubuntu2 Advanced library for accessing PackageKit using GLib
ii libpackagekit-glib2-14 0.6.15-1build1 Library for accessing PackageKit using GLib
rc libpackagekit-qt-12 0.5.7-0ubuntu2 Library for accessing PackageKit using Qt.
rc libpackagekit-qt-14 0.6.8-0ubuntu3.2 Library for accessing PackageKit using Qt.
ii packagekit ...

Read more...

Bob Vincent (pillarsdotnet) wrote :

For now I'm going to work around the problem by removing packagekit.

Matthias Klumpp (ximion) wrote :

What does
$ > grep DefaultBackend /etc/PackageKit/PackageKit.conf
give you? The default backend should be APTcc, I'm going to remove the APT backend in the next release (0.7.x series).

Bob Vincent (pillarsdotnet) wrote :

Cut-and-pasted from #19 above (perhaps you didn't click on the "Read more" link?):

$ grep DefaultBackend /etc/PackageKit/PackageKit.conf
DefaultBackend=aptcc

Now that I've purged PackageKit from my system, my problem is solved. I always do my updates via dselect, anyway.

Perhaps my problem is that my config line says "aptcc" where it should say "APTcc" ? I dunno. I deleted the config file entirely before I re-installed, so if there is a case error, it is caused by the install script.

Bob Vincent (pillarsdotnet) wrote :

Also note that the bug header is wrong; it says fixed released in Maverick, whereas the problem still exists in Oneric. This makes the bug report hard to find (Won't show up in "my bugs" list on my launchpad profile -- had to explicitly search for it in "Advanced search").

IMHO the bug status should be re-opened.

PawelZ (pzubrzak) wrote :

Happened to me on Ubuntu 15.04 MATE during Gnome desktop environment installation

Setting up gnome-maps (3.14.1.2-1) ...
Setting up ubuntu-gnome-desktop (0.38) ...
Processing triggers for libc-bin (2.21-0ubuntu4) ...
Processing triggers for systemd (219-7ubuntu6) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for initramfs-tools (0.103ubuntu15) ...
update-initramfs: Generating /boot/initrd.img-3.19.0-22-generic
Error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

Norbert (nrbrtx) wrote :

Got this error on 12.04 lTS, installed packagekit package with 'sudo apt-get install packagekit' and problem gone.

Eugene Jones (eugenerjones) wrote :

Same here, I was experiencing this problem (on 16.04 xenial) each time I ran 'sudo apt update' or any apt commands.

Fixed by installing 'packagekit'. Not even sure what that does, but it must have done something because the error is gone now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.