invalid values for distro upgrades

Bug #611760 reported by Harald Sitter on 2010-07-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Harald Sitter

Bug Description

Binary package hint: packagekit

Because of trying to access wrong gobject properties in both the backend AND pkcon invalid values on name/summary and state of available distro upgrades are returned. This affects pkcon as well as KPackageKit.

This essentially means that every Kubuntu user will eventually run into KPackageKit reporting an available distribution and offers "Upgrade to". Quite literal only "Upgrade to" since the name is nil nothing will show up which is completely confusing.

Reproduce the issue:
1) Apply the attached patch metarelease.patch with: sudo patch -p0 < metarelease.patch
2) Edit /etc/update-manager/release-upgrades to Prompt=devel
3) Ensure that /usr/lib/update-manager/check-new-release yiels appropriate output
4) KPackageKit's update UI and pkcon get-distro-upgrades yield invalid values but detect the presence of a distro upgrade

Check the fix:
1-3 as above
4) as above but this time with appropriate output

The change set at hand does not have any regression potential since the affected gobject properties do not exist at all and in the "broken" version glib correctly reports this as warning (which can be observed in pkcon).

Thanks go to Daniel Nicoletti for helping with tracking down the issue.

Harald Sitter (apachelogger) wrote :
Harald Sitter (apachelogger) wrote :
description: updated
Changed in packagekit (Ubuntu Lucid):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → Medium
status: New → In Progress
John Dong (jdong) wrote :

ACK from SRU team

Martin Pitt (pitti) wrote :

Please fix in maverick ASAP, so that this can progress to -updates.

Changed in packagekit (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed

Accepted packagekit into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Harald Sitter (apachelogger) wrote :

Whoops... that is long fixed in maverick (ever since pk 0.6 entered, in fact from what I heared the issue in 0.5 only appeared because of backports from 0.6 ;))

Officially confirm: fixed in maverick.

Changed in packagekit (Ubuntu):
status: New → Fix Released
Jonathan Riddell (jr) wrote :

I can confirm the 0.5.7-0ubuntu2.1 package fixes the problem, running the pk-upgrade-distro script successfully starts the upgrader (having already changed DistUpgradeFetcherKDE.py to use devel release updates, which won't be needed after maverick release of course).

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.5.7-0ubuntu2.1

---------------
packagekit (0.5.7-0ubuntu2.1) lucid-proposed; urgency=low

  * Add fix_distro_upgrade_check.diff to fix checking for updates to actually
    return proper values when an upgrade is available. (LP: #611760)
 -- Harald Sitter <email address hidden> Fri, 30 Jul 2010 17:29:42 +0200

Changed in packagekit (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers