[lucid] mozilla-packagekit cannot be installed with firefox 3.5

Bug #606910 reported by Anton Piatek on 2010-07-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Canonical Platform QA Team
packagekit (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Chris Coulson

Bug Description

Binary package hint: mozilla-packagekit

mozilla-packagekit is set as "Breaks: firefox-3.0" but has a Depends including firefox 3.5 but will not install happily with firefox 3.5

$sudo aptitude install mozilla-packagekit
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initialising package states... Done
Writing extended state information... Done
The following packages are BROKEN:
  mozilla-packagekit
The following NEW packages will be installed:
  firefox-3.0{a}
0 packages upgraded, 2 newly installed, 0 to remove and 7 not upgraded.
Need to get 102kB of archives. After unpacking 319kB will be used.
The following packages have unmet dependencies:
  mozilla-packagekit: Breaks: firefox-3.0 but 3.6.6+nobinonly-0ubuntu0.10.04.1 is to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
base-layer
firefox
firefox-3.5
firefox-branding
full-layer
ibm-cck
ibm-global-print
printing-layer

Keep the following packages at their current version:
firefox-3.0 [Not Installed]

Leave the following dependencies unresolved:
ubufox recommends firefox | abrowser | firefox-3.5 | abrowser-3.5 | firefox-3.0
Score is -1747

I tried rebuilding without the Breaks setting and it seems to work ok, though I do not understand when Breaks should be used (I also do now know what part of it affects firefox as I saw no issues)

This is visible in lucid and karmic, but probably goes back a few releases as popcon shows 0 installs of the package so I doubt it is used by many users

Anton Piatek (anton-piatek) wrote :

Looking through the changelog, this plugin is not compatible with firefox 3.0 because of the level of xulrunner.

Am I correct in thinking that it should be "Conflicts: firefox-3.0" as it has the wrong level of xulrunner, as opposed to "Breaks" which implies that firefox-3.0 must be deconfigured first

From the Ubuntu Policy document:
When one binary package declares that it breaks another, dpkg will refuse to allow the package which declares Breaks be installed unless the broken package is deconfigured first, and it will refuse to allow the broken package to be reconfigured.

Should this simply conflict with firefox-3.0 and only recommend other browsers?

Jerone Young (jerone) wrote :

Is there are particular reason you need to install firefox-3.0?

We currently do not support installing two version of firefox simultaneously on a system.

Jerone Young (jerone) wrote :

Also is this with Ubuntu 10.04?

Anton Piatek (anton-piatek) wrote :

Not at all - in fact I do NOT want 3.0, but 3.5
However this does not seem to work as 3.5 provides 3.0 and the packagekit plugin breaks 3.0 and it wants to remove it

I think the issue is simply that the package should conflict with 3.0 instead, as making this change in a local copy of the package allows it to install fine and without the above attempts to remove 3.5

Anton Piatek (anton-piatek) wrote :

The above was on lucid

On maverick it appears to work find as the "firefox" package (no 3.0 or 3.5, just firefox which is 3.6) does not provide "firefox-3.0" and so there are no problems at install time

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.6.6+20100703a-0ubuntu3

---------------
packagekit (0.6.6+20100703a-0ubuntu3) maverick; urgency=low

  * debian/control:
    - browser plugin only works with firefox > 3.0 (LP: #606910)
  * lintian stuff:
    - old-fsf-address-in-copyright-file
    - syntax-error-in-debian-changelog
 -- Cosme Dominguez Diaz <email address hidden> Mon, 19 Jul 2010 21:45:05 +0000

Changed in packagekit (Ubuntu):
status: New → Fix Released
Anton Piatek (anton-piatek) wrote :

Is this fix going to be backported to Lucid?

Jerone Young (jerone) on 2010-08-30
Changed in packagekit (Ubuntu):
status: Fix Released → Confirmed
summary: - mozilla-packagekit cannot be installed with firefox 3.5
+ [lucid] mozilla-packagekit cannot be installed with firefox 3.5
Kent Baxley (kentb) wrote :

For engineering,

This issue has been fixed in Maverick, but, the customer would also like to have this ported to Lucid. They still deploy Lucid pretty widely.

The issue here is that mozilla-packagekit declares a breaks on
firefox-3.0, which is a transitional package in Lucid to migrate Hardy
upgraders to the new package. In addition to this, the Lucid firefox
package declares a Provides on firefox-3.0, to ease the transition for
other things in the archive depending on firefox-3.0.

Because the Breaks is unversioned, mozilla-packagekit won't install
until firefox and firefox-3.0 (if it is installed) have been
deconfigured. We should fix this by declaring a versioned Breaks
instead, which seems fairly non-invasive.

Kent Baxley (kentb) on 2010-11-15
Changed in oem-priority:
importance: Undecided → High
Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
Changed in packagekit (Ubuntu Lucid):
milestone: none → ubuntu-10.04.2
Changed in packagekit (Ubuntu Lucid):
assignee: nobody → Chris Coulson (chrisccoulson)
Martin Pitt (pitti) wrote :

Closing main task, reportedly fixed in maverick.

Changed in packagekit (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Looks like http://bazaar.launchpad.net/~packagekit/packagekit/ubuntu-maverick/revision/223 is the fix for this? Looks fine to backport to lucid.

Kent Baxley (kentb) wrote :

Martin,

Yes. Unless someone has anything different to add, that's the fix that IBM would like to see ported to Lucid.

Chris Coulson (chrisccoulson) wrote :

Here is a debdiff for Lucid

Anton Piatek (anton-piatek) wrote :

That diff looks like it should fix the issue

Accepted packagekit into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in packagekit (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Anton Piatek (anton-piatek) wrote :

Fix works as expected, thanks!

tags: removed: verification-needed
Martin Pitt (pitti) on 2010-11-22
tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.5.7-0ubuntu2.2

---------------
packagekit (0.5.7-0ubuntu2.2) lucid-proposed; urgency=low

  * Fix LP: #606910 - in mozilla-packagekit, don't declare Breaks on
    firefox-3.0, as this is provided by firefox now (to ease transition),
    and prevents mozilla-packagekit from being installed along firefox
    - update debian/control
 -- Chris Coulson <email address hidden> Fri, 19 Nov 2010 16:21:45 +0000

Changed in packagekit (Ubuntu Lucid):
status: Fix Committed → Fix Released
Kent Baxley (kentb) on 2010-11-29
Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers