Doesn't support actions to handle a broken cache

Bug #496290 reported by gabi w on 2009-12-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
Wishlist
Unassigned

Bug Description

There should be a transaction to fix a broken cache (equally to apt-get install -f)

Binary package hint: firefox-3.5

When I press the button "Install Selected" the following text is shown:" E:Ich konnte keine Datei für Paket adobe-flashplugin finden. Das könnte heißen, dass Sie dieses Paket von Hand korrigieren müssen". When I want to worke with the software manager I get the this messig "Es ist ein unerwarteter Fehler aufgetreten bitte melden Sie das Problem mit der Fehlerbeschreibung. Details: Error Type: Error Value: E:The package adobe-flashplugin needs to be reinstalled, but I can't find an archive for it. File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 1952, in main() File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 1949, in main run(args, options.single) File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 1911, in run backend.dispatcher(args) File : /usr/lib/python2.6/dist-packages/packagekit/backend.py, line 636, in dispatcher self.dispatch_command(args[0], args[1:]) File : /usr/lib/python2.6/dist-packages/packagekit/backend.py, line 598, in dispatch_command self.search_group(options, searchterms) File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 515, in search_group self._check_init(progress=False) File : /usr/share/PackageKit/helpers/apt/aptBackend.py, line 1672, in _check_init self._cache.clear() File : /usr/lib/python2.6/dist-packages/apt/cache.py, line 329, in clear self._depcache.Init()

If i want to search something the following text is shown: "Der Prozess für das Protokoll nepomuksearch wurde unerwartet beendet"

Dolphin
Version 1.3
Unter KDE 4.3.2 (KDE 4.3.2)

K Desktop Environment
Version 4.3.2 (KDE 4.3.2

What can I do? Thanks for help,
gabi

ProblemType: Bug
Architecture: i386
Date: Sun Dec 13 20:33:26 2009
DistroRelease: Ubuntu 9.10
Package: firefox-3.5 3.5.5+nobinonly-0ubuntu0.9.10.1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-15-generic i686

gabi w (gajomepa) wrote :
affects: firefox-3.5 (Ubuntu) → packagekit (Ubuntu)
Sebastian Heinlein (glatzor) wrote :

Run the following command in a terminal:

sudo dpkg -P adobe-flashplugin

Sebastian Heinlein (glatzor) wrote :

It seems that the flash installation was cancelled in a bad state. PackageKit cannot handle this.

summary: - Update Notifier "For extra multimedia functionality select restrictet
- packages to be installed"
+ Doesn't support actions to handle a broken cache
Changed in packagekit (Ubuntu):
status: New → Confirmed
description: updated
Matthias Klumpp (ximion) wrote :

Upstream is working on this at time :)

Changed in packagekit (Ubuntu):
status: Confirmed → In Progress
Matthias Klumpp (ximion) on 2012-03-14
Changed in packagekit (Ubuntu):
importance: Undecided → Low
Matthias Klumpp (ximion) on 2012-03-19
Changed in packagekit (Ubuntu):
importance: Low → Wishlist
Matthias Klumpp (ximion) on 2012-04-23
Changed in packagekit (Ubuntu):
milestone: none → later
Rafael Belmonte (eaglescreen) wrote :

Fix commited to packagekit-backend-aptcc 0.7.4.

Changed in packagekit (Ubuntu):
status: In Progress → Fix Committed
Matthias Klumpp (ximion) wrote :

If you want, you can try the Debian version of PackageKit (but please wait a little until rev2 of the package which will bring some important improvements)

Matthias Klumpp (ximion) on 2012-04-29
Changed in packagekit (Ubuntu):
milestone: later → quantal-alpha-1
Launchpad Janitor (janitor) wrote :
Download full text (6.8 KiB)

This bug was fixed in the package packagekit - 0.7.4-2ubuntu1

---------------
packagekit (0.7.4-2ubuntu1) quantal; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes:
    - debian/control: Have the libraries recommend python-aptdaemon.pkcompat
      over packagekit as we don't want the latter to be installed by default.

packagekit (0.7.4-2) unstable; urgency=low

  * Fixed qt2 library soname
  * Don't install GIR into multiarch path (Closes: #670374)
  * Updated packagekit-python description

packagekit (0.7.4-1) unstable; urgency=low

  * New upstream release: 0.7.4
    This is the ultimate-aptcc release, fixing nearly all known bugs!
    PK changes relevant to Debian:
     - packagekit-glib2: Add GType's for packagekit-glib2 enumerations
        (Stef Walter)
     - packagekit-qt2: Add simulateRepairSystem and repairSystem(bool) to
        the Transaction API (Daniel Nicoletti)
     - python: Speed up get_package_list (Tomáš Trnka)
     - apt: apt.cache.Cache() now reuses the dpkg of the chroot
        (Sebastian Heinlein)
     - apt: Fix modalias search on non-multi-arch systems
        (Sebastian Heinlein)
     - apt: Replace use of depracted python-apt 0.7.x API
        (Sebastian Heinlein)
     - aptcc: Add a new class to show cache opening progress
        (Daniel Nicoletti)
     - aptcc: Add AptCacheFile to handle all pkg cache openings
        (Daniel Nicoletti)
     - aptcc: Add SimulateRepairSystem and RepairSystem methods
        (Daniel Nicoletti) (LP: #496290)
     - aptcc: Avoid crashing when error messages containing invalid utf8
        is sent (Daniel Nicoletti)
     - aptcc: Change the way we mark auto-installed packages
        (Daniel Nicoletti)
     - aptcc: Correctly emit if a repo is enabled (Matthias Klumpp)
     - aptcc: Don't emit error if repo is empty (Matthias Klumpp)
     - aptcc: Emit newly-installed local package information (Matthias Klumpp)
     - aptcc: Emit packages that are untrusted with the
        PK_INFO_ENUM_UNTRUSTED enum (Daniel Nicoletti)
     - aptcc: Emit UnfinishedTransaction when we were not able to fix the
        cache (Daniel Nicoletti)
     - aptcc: Fix a multiarch bug that failed to resolve packages
        (Daniel Nicoletti)
     - aptcc: Fix crash when a package for an invalid version
        (Daniel Nicoletti)
     - aptcc: Fix resolving of gdebi packages when they have :arch field
        (Daniel Nicoletti)
     - aptcc: Implement support for InstallFiles()
        (Matthias Klumpp) (Closes: #606131)
     - aptcc: Implement SUPPORTED support (Matthias Klumpp)
     - aptcc: Improve the autoremove code (Daniel Nicoletti)
     - aptcc: Mark dependencies of a file-installation as automatic
        (Matthias Klumpp)
     - aptcc: Move ShowBroken to AptCacheFile, and added CheckDeps from
        apt-get (Daniel Nicoletti)
     - aptcc: Refactored to use AptCacheFile (Daniel Nicoletti)
     - aptcc: Reident the code and re-enforce KDElibs coding style
        (Daniel Nicoletti)
     - aptcc: Remove a code duplication and emit proper RestartRequired
       signal (Daniel Nicoletti)
     - aptcc: Reorganise parts of AptCC to make the code more readable
        (Matthias Kl...

Read more...

Changed in packagekit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers