Gtk-Message **: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory at

Bug #389766 reported by eris23 on 2009-06-20
174
This bug affects 35 people
Affects Status Importance Assigned to Milestone
packagekit (Debian)
Fix Released
Unknown
packagekit (Ubuntu)
High
MOHAMMED ZAFRULLA
Nominated for Karmic by Darxus
Nominated for Lucid by Paul Logasa Bogen II
packagekit-gnome (Ubuntu)
Undecided
amir
Nominated for Karmic by Darxus
Nominated for Lucid by Paul Logasa Bogen II

Bug Description

Binary package hint: packagekit-gnome

on karmic some programs cause an warning or error: Failed to load module "pk-gtk-module

Example: sudo clamtk

Gtk-Message **: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory at /usr/share/perl5/ClamTk/GUI.pm line 66

A temporary fix is changing the key in gconf-editor /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module to false.

Changed in packagekit-gnome (Ubuntu):
status: New → Confirmed
James Westby (james-w) wrote :

This is actually something that needs to be fixed in packagekit.

Thanks,

James

affects: packagekit-gnome (Ubuntu) → packagekit (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.4.8-0ubuntu2

---------------
packagekit (0.4.8-0ubuntu2) karmic; urgency=low

  * Install the gtk module in the packagekit package so that it is available
    for gtk to load. (LP: #389766)
  * Fix the Vcs-Bzr URIs.
  * Fix issues found by lintian:
    - Make the package binNMUable by changing to use ${source:Version} for
      depending on python-packagekit from the python backends.
    - Drop absolute paths in debian/packagekit-backend-apt.postinst and
      debian/packagekit.postinst
    - Drop duplicated "and" in the description of package-backend-apt.
    - Fix spelling of "development" in the description of
      packagekit-backend-aptcc.
    - Fix capitalisation of "Python" in the description of python-packagekit.

 -- James Westby <email address hidden> Thu, 02 Jul 2009 18:26:35 -0400

Changed in packagekit (Ubuntu):
status: Confirmed → Fix Released
dn (nobled) wrote :

This bug is back since Monday:

packagekit (0.4.9+20090825-0ubuntu5) karmic; urgency=low

  [ Michael Vogt ]
  * debian/patches/fix_progress_crash.patch:
    - fix crash when dpkg trigger messages are send (LP: #438279)

  [ Sebastian Heinlein ]
  * debian/rules, debian/packagekit.install: Don't build and install the GTK
    module which allows to install required fonts, since it isn't support by
    any of the shipped backends.

 -- Michael Vogt <email address hidden> Mon, 05 Oct 2009 08:59:03 +0200

Changed in packagekit (Ubuntu):
status: Fix Released → Confirmed
freakalad (freakalad) wrote :

> solution: http://space.oss.org.cn/space.php?uid=3&do=blog&id=401

errrr..... ok? & for those that don't quite know how to read mandarin/chinese?

Got this error after upgrading to karmic-64

David A. Cobb (superbiskit) wrote :

Popped up 2009-12-14, following some upgrades.

Occurs without crashing the application in EPIPHANY and GALEON. *FATAL* in Firefox. Very very bad.

Alexandre Demers (oxalin) wrote :

Also appeared after upgrading today on karmic-64

helix84 (helix84) wrote :

> Occurs without crashing the application in EPIPHANY and GALEON. *FATAL* in Firefox. Very very bad.

Firefox is displaying the message but not crashing on karmic i386. Maybe some of your extensions cause that.

kFuQ (derek-kfuq) wrote :

freakalad wrote on 2009-12-09: #5
> solution: http://space.oss.org.cn/space.php?uid=3&do=blog&id=401
errrr..... ok? & for those that don't quite know how to read mandarin/chinese?
Got this error after upgrading to karmic-64

http://translate.googleusercontent.com/translate_c?hl=en&ie=UTF-8&sl=zh-CN&tl=en&u=http://space.oss.org.cn/space.php%3Fuid%3D3%26do%3Dblog%26id%3D401&prev=_t&rurl=translate.google.com&usg=ALkJrhh70FbQGID0jXgQIeSLratf2fOcEQ

I get this error all over the place after upgrading to 9.10. nautilus, firefox, epiphany.. the list goes on

kFuQ (derek-kfuq) wrote :

possible workaround.

i got the packagekit-gtk-module rpm, opened it in archive manager and then extracted the missing .so to /usr/lib/gtk-2.0/modules.

added /usr/lib/gtk-2.0 to /etc/ld.so.conf and ran ldconfig

i also uninstalled all python and gtk nautilus plugins/extensions as well and so far so good.. :-D

ftp://ftp.pbone.net/mirror/carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2009.1/i586/media/contrib/backports/packagekit-gtk-module-0.4.8-1mdv2009.1.i586.rpm

kFuQ (derek-kfuq) wrote :

~$ python
Python 2.6.4 (r264:75706, Dec 7 2009, 18:45:15)
[GCC 4.4.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtk
>>> exit()
~$

David A. Cobb (superbiskit) wrote :

Re: Comment #8

Err, yeah. I dropped back a week or two and ran an older nightly of Firefox. Evidently just a coincidence that the crash happened right after the packagekit error.

dino99 (9d9) wrote :

anymore recent fix ? still present in karmic

Matteo Settenvini (tchernobog) wrote :

Also valid in lucid, it seems.

BavarianPH (bavarianph) wrote :

ftp://ftp.pbone.net/mirror/carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2009.1/i586/media/contrib/backports/packagekit-gtk-module-0.4.8-1mdv2009.1.i586.rpm

installing packagekit-gtk-module-0.4.8-1mdv2009.1.i586.rpm

Can be converted by "alien", & turned into local deb file:

packagekit-gtk-module_0.4.8-2_i386.deb

works in both Karmic & Lucid!

The equivalent should be made available in the Ubuntu

repositories, it is the easiest way to repair this error!

BavarianPH,

Ubuntu forever!

P. S. should someone nominate this bug for release?

tags: added: patch
Brian Murray (brian-murray) wrote :

I've unflagged the package as a patch as isn't a patch to an existing package.

Changed in packagekit (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

We do not support packagekit-gnome in the desktop team, and there is no patch here for sponsoring.

Changed in packagekit (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
tags: added: ct-rev
dino99 (9d9) wrote :

this problem exist with Karmic32 but not with Jaunty64 or Lucid32

Architecture: i386
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: packagekit 0.5.5-0+ppa0
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic-pae
Uname: Linux 2.6.31-20-generic-pae i686
UserGroups: adm admin audio avahi avahi-autoipd boinc cdrom clamav couchdb crontab daemon debian-tor dialout disk fuse gdm haldaemon klog kmem libuuid lpadmin mail messagebus mlocate mysql mythtv netdev ntp operator plugdev polkituser postdrop postfix pulse root sambashare saned shadow ssh ssl-cert sudo syslog tty users utmp video voice www-data

tags: added: apport-collected
dino99 (9d9) wrote :

reinstalling packagekit 0.4.9 (karmic-proposed) solve this problem, no side effects seen at time.

Anton Anikin (anton-anikin) wrote :

same problem on the Lucid x86_64

Architecture: i386
DistroRelease: Ubuntu 9.10
Package: packagekit 0.4.9+20090825-0ubuntu6 [modified: var/lib/PackageKit/transactions.db]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev sambashare scanner video
XsessionErrors:
 (gnome-settings-daemon:2564): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2619): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2601): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Darxus (darxus) wrote :

Also seeing it in a bunch of places on this machine, and empathy is segfaulting when I try to start it.

Darxus (darxus) wrote :

Purging and reinstalling packagekit packages, then rebooting, did not help. Packages:
libpackagekit-glib11 packagekit packagekit-backend-apt packagekit-gnome python-packagekit

I'm using karmic updates, security, and backports.

Package: packagekit
Version: 0.4.9+20090825-0ubuntu6

Maybe I should try proposed.

dino99 (9d9) wrote :

since post 22 i've had to removed/purged then reinstall some packages due to different issues. Doing this , ubuntu-desktop has been uninstalled too, then i've reinstalled it.

Looking the previous comments and having to say that my system has not these problems, i've checked synaptic to control which packagekit is installed:

i see that packagekit is no more installed, looking at ubuntu-desktop i'm surprised too that packagekit is not a dependency or a recommend package.

dino99 (9d9) wrote :

forgot to say thats post 28 is about Lucid

Darxus (darxus) wrote :

Empathy's crashing bug was fixed in the version in karmic-updates: 2.28.1.1-0ubuntu1

Sebastian Heinlein (glatzor) wrote :

We should set the gconf value of me_settings_daemon/gtk-modules/pk-gtk-module to False to disable loading the not available pk gtk module

Sebastian Heinlein (glatzor) wrote :

 /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module

Victor Marin (vms368) wrote :

In LUCID, similar message does appear when trying to fill a bug using ubuntu-bug from a terminal, regarding gnome-power-preferences, as follows:

~$ ubuntu-bug gnome-power-preferences
Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: no se puede abrír el archivo de objeto compartido: No existe el fichero ó directorio

The bug I found it's that the whole SYSTEM FREEZES when I try to adjust screen brightness by dragging the slider at gnome-power-preferences in System > Preferences.

Also I can't adjust the brightness of the monitor by the brightness applet.

Possible related bugs: Bug #535097 Bug #572226

Nigel Babu (nigelbabu) on 2010-05-07
tags: removed: patch
Sebastian Heinlein (glatzor) wrote :

The schemas file is provided by packagekit-gnome

affects: gnome-settings-daemon (Ubuntu) → packagekit-gnome (Ubuntu)
Changed in packagekit-gnome (Ubuntu):
status: New → Confirmed
David Robert Lewis (afrodeity) wrote :

Confirm its back in Lucid
Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so:

Sebastian Heinlein (glatzor) wrote :

Why should it back? It was never fixed :) The problem should disappear after deinstalling packagekit-gnome.

David Robert Lewis (afrodeity) wrote :

The temporary solution to this issue is:

wget ftp://195.220.108.108/linux/fedora/updates/12/i386/PackageKit-gtk-module-0.5.7-2.fc12.i686.rpm

    * extract the file: libpk-gtk-module.so from the RPM archive,
    * then chmod 644 libpk-gtk-module.so,
    * sudo cp libpk-gtk-module.so /usr/lib/gtk-2.0/modules
    * sudo ldconfig

Got this from the Linux Mint forum. ;)

Sebastian Heinlein (glatzor) wrote :

This is a very bad advice. You could just disable the loading of the gnome-settings-daemon plugin by setting /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module to False in the gconf-editor.

The original message is only a warning message and not an error.

Furthermore the gtk-module only enables installing fonts on requests, but this is not supported by Debian/Ubuntu.

amir (amir-mehry) on 2010-08-09
Changed in packagekit (Ubuntu):
assignee: nobody → amir (amir-mehry)
Changed in packagekit-gnome (Ubuntu):
assignee: nobody → amir (amir-mehry)

Attached is a patch that will add a 'packagekit-gtk-module' package to PackageKit.

tags: added: patch
Matthias Klumpp (ximion) wrote :

Amir, the new PackageKit package in Ubuntu Natty contains the GTK-Module package. Could someone test if this issue is still present? (It's resolved for me)

Changed in packagekit-gnome (Ubuntu):
status: Confirmed → Invalid
Changed in packagekit (Ubuntu):
status: Confirmed → Fix Released
Rob Augustinus (rob-0tl) wrote :

Somehow this issue popped up for me today on Lucid with the latest updates (today) applied. The 'temporary solution' using gconf-editor works for me, but seeing this "Furthermore the gtk-module only enables installing fonts on requests, but this is not supported by Debian/Ubuntu" would suggest the solution being not so temporary after all?

Changed in packagekit (Debian):
status: Unknown → Confirmed
Matthias Klumpp (ximion) on 2011-11-24
Changed in packagekit (Debian):
status: Confirmed → Unknown
Changed in packagekit (Debian):
status: Unknown → Fix Released
Juan Simón (simonbcn) wrote :

This problem is present in Ubuntu 11.10 64 bits:
$ gnome-session-quit
Gtk-Message: Failed to load module "pk-gtk-module"

cybertesla (kmorrow98) wrote :

This problem seems to persist on Ubuntu 12.04 x86_64:

$ python
Python 2.7.3 (default, Apr 20 2012, 22:39:59)
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtk
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

Ladsy (tempo1) wrote :

Hi,

I'm on Precise Ubuntu 12.04 x86_64
Each time I launch synaptic under root.
user@machine:sudo su
root@machine:/usr/lib/gtk-2.0/modules# synaptic
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

I had this issue and finish by resolve with 2 things

>Gtk-Message: Failed to load module "canberra-gtk-module"
just solving by install : libcanberra-gtk-module

> Gtk-Message: Failed to load module "pk-gtk-module"
My dirty workaround to be quiet is to work with : packagekit-gtk-module from Natty (the most recent package who give "libpk-gtk-module.so"
- download : http://packages.ubuntu.com/natty/packagekit-gtk-module
- in the file packagekit-gtk-module_0.6.11-2ubuntu3_amd64.deb
- uncompress and find the file libpk-gtk-module.so
- create the directory : mkdir /usr/lib/gtk-2.0/modules/
- just cp libpk-gtk-module.so into /usr/lib/gtk-2.0/modules/

After that ... synaptic launch without any error message.

Remarks:
I found this on internet :
write via gconf-editor /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module to false.
On Precise, the jey doesn't exist ... and it's useless.

Now I suggest ... or the gtk2 application are all translated in gtk3 (hard) ... or Ubuntu included each time the old gtk2.0 to have a good compliancy.

Hoping, that's could help.

Matthias Klumpp (ximion) wrote :

Since there were too many people complaining about this (harmless) message which is only shown on GTK2 applications, the new PK module package available in Debian Wheezy or Ubuntu Quantal provides a GTK2 dummy module, which just does nothing.
As soon as most applications are ported, we can remove the dummy module again.
Cheers,
   Matthias

Changed in packagekit (Ubuntu):
assignee: amir (amir-mehry) → MOHAMMED ZAFRULLA (zafrulla)

Failed to load module pk-gtk-module while issuing command ./sakis3g --interactive for boradband modem installation

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.