aptDBUSBackend.py crashed with ImportError in <module>()

Bug #285137 reported by Ivan Zorin on 2008-10-17
142
This bug affects 2 people
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: packagekit-backend-apt

$ lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

$ apt-cache policy packagekit-backend-apt
packagekit-backend-apt:
  Installed: 0.3.6-0ubuntu1
  Candidate: 0.3.6-0ubuntu1
  Version table:
 *** 0.3.6-0ubuntu1 0
        500 http://gb.archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

It crashes every time right after login within loading desktop environment (I use GNOME)

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/packagekit/aptDBUSBackend.py
InterpreterPath: /usr/bin/python2.5
Package: packagekit-backend-apt 0.3.6-0ubuntu1
ProcAttrCurrent: _
ProcCmdline: python /usr/lib/packagekit/aptDBUSBackend.py
ProcEnviron:

PythonArgs: ['/usr/lib/packagekit/aptDBUSBackend.py']
SourcePackage: packagekit
Title: aptDBUSBackend.py crashed with ImportError in <module>()
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/packagekit/aptDBUSBackend.py", line 50, in <module>
     from packagekit.daemonBackend import PACKAGEKIT_DBUS_INTERFACE, PACKAGEKIT_DBUS_PATH, PackageKitBaseBackend, PackagekitProgress, pklog, threaded, serialize
 ImportError: cannot import name serialize
Uname: Linux 2.6.27-7-eeepc i686
UserGroups:

Ivan Zorin (iaz) wrote :

I've get same error many times, maybe my report should help you...

I don't know if it should be linked but since first time this bug occurs, my mouse freeze in parallel and 1 core of my CPU is fully used

Scott Kitterman (kitterman) wrote :

confirming since it happened to me too.

Changed in packagekit:
status: New → Confirmed
Tom Taylor (ttaylor49) wrote :

New confirmed

ron (roncasa) wrote :

I click on update icon and this comes up, and while typing this message, the error message came up again ...

tags: added: iso-testing
Jonathan Thomas (echidnaman) wrote :

Fixed in Ubuntu 9.10. The apt backend no longer uses the gobject python library.

Changed in packagekit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers