packagekitd crashed with SIGSEGV in __memmove_{sse2,avx}_unaligned_erms() from std::char_traits<char>::copy() from ... from show_errors (errorCode=PK_ERROR_ENUM_CANNOT_FETCH_SOURCES)

Bug #1818201 reported by errors.ubuntu.com bug bridge on 2019-03-01
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Bionic
High
Unassigned
Cosmic
High
Unassigned
Disco
High
Unassigned

Bug Description

[Impact]
packagekit (sometimes) crashes when there are errors.

https://errors.ubuntu.com/problem/1bdc3e539949aa164d276979f62ca0282a54fcbd
https://errors.ubuntu.com/problem/e9af46c2ad01a15f968379c434fe0bfbf924d034

[Test case]
Check that there are no further cases on the error tracker with the proposed version.

[Regression potential]
Given that this just changes the return type of a function only used in calls, and the code compiles, there should be no possibility for a regression. Of course, if there were, it'd be segfaults or stuff.

[Original info]
The Ubuntu Error Tracker has been receiving reports about a problem regarding packagekit. This problem was most recently seen with package version 1.1.12-1ubuntu1, the problem page at https://errors.ubuntu.com/problem/e9af46c2ad01a15f968379c434fe0bfbf924d034 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in packagekit (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in packagekit (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
description: updated
Julian Andres Klode (juliank) wrote :

SRUs uploaded for bionic and cosmic. Since we do not use packagekit in gnome-software in xenial, not fixing it there.

Also not fixing it in trusty, as it's close to EOL.

Changed in packagekit (Ubuntu Cosmic):
status: New → In Progress
Changed in packagekit (Ubuntu Bionic):
status: New → In Progress
Changed in packagekit (Ubuntu Xenial):
status: New → Won't Fix
description: updated
summary: - /usr/lib/packagekit/packagekitd:11:__memmove_avx_unaligned_erms:std::char_traits:std::__cxx11::basic_string:std::__cxx11::basic_string:std::__cxx11::basic_string
+ packagekitd crashed with SIGSEGV in
+ __memmove_{sse2,avx}_unaligned_erms() from
+ std::char_traits<char>::copy() from ... from show_errors
+ (errorCode=PK_ERROR_ENUM_CANNOT_FETCH_SOURCES)

Hello errors.ubuntu.com, or anyone else affected,

Accepted packagekit into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/packagekit/1.1.10-1ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in packagekit (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Hello errors.ubuntu.com, or anyone else affected,

Accepted packagekit into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/packagekit/1.1.9-1ubuntu2.18.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in packagekit (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Changed in packagekit (Ubuntu Xenial):
importance: Undecided → High
Changed in packagekit (Ubuntu Bionic):
importance: Undecided → High
Changed in packagekit (Ubuntu Cosmic):
importance: Undecided → High
Julian Andres Klode (juliank) wrote :

There do not seem to be any more of these crashes, and no regression in terms of new crashes appearing with that version, so it should be good to release.

tags: added: verification-done verification-done-bionic verification-done-cosmic
removed: verification-needed verification-needed-bionic verification-needed-cosmic

The verification of the Stable Release Update for packagekit has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 1.1.10-1ubuntu7.1

---------------
packagekit (1.1.10-1ubuntu7.1) cosmic; urgency=medium

  * 03_aptcc-use-correct-return-type-in-function.patch: Cherry pick upstream
    fix for show_errors crashes (LP: #1818201)

 -- Julian Andres Klode <email address hidden> Mon, 04 Mar 2019 16:29:55 +0100

Changed in packagekit (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 1.1.9-1ubuntu2.18.04.5

---------------
packagekit (1.1.9-1ubuntu2.18.04.5) bionic; urgency=medium

  * 03_aptcc-use-correct-return-type-in-function.patch: Cherry pick upstream
    fix for show_errors crashes (LP: #1818201)

 -- Julian Andres Klode <email address hidden> Mon, 04 Mar 2019 16:42:18 +0100

Changed in packagekit (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers