[zesty] doesn't offer a window to install missing gstreamer codecs

Bug #1661371 reported by Pojar Gheorghe–Ioan on 2017-02-02
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
PackageKit
Won't Fix
Medium
Session Installer
Undecided
Unassigned
gnome-software (Ubuntu)
High
Canonical Desktop Team
packagekit (Ubuntu)
Undecided
Unassigned
sessioninstaller (Ubuntu)
High
Unassigned

Bug Description

Test Case
---------
You can duplicate this with the daily build. If you install, don't select the option to install additional codecs.

If you've already installed the additional codecs, you can remove them with

sudo apt purge ubuntu-restricted-addons gstreamer1.0-fluendo-mp3 \
gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly;
sudo apt autoremove

Here's a CC-BY-ND .mp3 you can download:
http://music.esgi.co.uk/track/echoes-in-time

Use totem (or rhythmbox) to try to open the file.

Original Bug Report
--------------------
Attempting to play a mp3 file with Rhythmbox on the latest Zesty daily build

Rhythmbox opens but no playback start.
On the terminal I got this:

Rhythmbox-Message: Missing plugin: gstreamer|1.0|rhythmbox-metadata|MPEG-1 Layer 3 (MP3) decoder|decoder-audio/mpeg, mpegversion=(int)1, mpegaudioversion=(int)1, layer=(int)3
/usr/lib/python3/dist-packages/sessioninstaller/core.py:47: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gst
/usr/lib/python3/dist-packages/sessioninstaller/core.py:48: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
Falling back to package information
Rhythmbox-Message: Missing plugins installed. Updating plugin registry ...

But the wizard to install the missing codec actually fails to launch.

Please see https://bugzilla.gnome.org/show_bug.cgi?id=770620

tags: added: zesty

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1661371/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → sessioninstaller (Ubuntu)
tags: removed: bot-comment
description: updated

gstreamer broke it. thanks gstreamer!

gst_discoverer_info_get_misc doesn't work: https://bugzilla.gnome.org/show_bug.cgi?id=770643

no longer affects: sessioninstaller
no longer affects: sessioninstaller (Ubuntu)
Changed in gst-plugins-base:
importance: Unknown → Medium
status: Unknown → Fix Released
no longer affects: gst-plugins-base1.0 (Ubuntu)
no longer affects: gst-plugins-base
description: updated
no longer affects: packagekit
Changed in packagekit:
importance: Unknown → Medium
status: Unknown → Won't Fix
Matthias Klumpp (ximion) wrote :

Looks like it might be a good idea to get rid of sessioninstaller, since GNOME Software provides the PackageKit session interface properly already - but since Ubuntu doesn't use the PK backend of GS, I assume that the PK session API will also not work in Ubuntu's version of GNOME Software.
Maybe try uninstalling sessioninstaller and see if GNOME Software pops up with the right package or at least an error message.

I guess this problem might only really be fixed by switching GS to use PK or alternatively make the PK session interface work in GS by other means (or, of course, by fixing sessioninstaller, but since that thing is essentially dead I assume that this would not be a viable option).

Changed in packagekit (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Changed in sessioninstaller (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-03-15
Changed in sessioninstaller (Ubuntu):
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

I confirm that I could not duplicate this bug in Ubuntu 16.10 (Unity) or Ubuntu GNOME 16.10. (I thought sessioninstaller didn't work with Ubuntu GNOME 16.10, hmm…)

We can use GNOME Software instead of sessioninstaller, but here's what we have to do:

1. Uninstall sessioninstaller then install gstreamer1.0-packagekit.
(gstreamer1.0-packagekit is in universe but it's from the packagekit source so I don't think it will be a problem to promote it to main)

2. GNOME Software has to be built with the PackageKit backend (LP: #1643134)

I confirmed that this works for installing a mp3 codec.

description: updated
Jeremy Bicha (jbicha) on 2017-03-15
tags: added: rls-z-incoming
Changed in gnome-software (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Jeremy Bicha (jbicha) on 2017-03-22
Changed in sessioninstaller (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
Changed in sessioninstaller:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.22.7-0ubuntu2

---------------
gnome-software (3.22.7-0ubuntu2) zesty; urgency=medium

  * Explicitly disable packagekit. The packagekit dbus service that
    was being installed broke sessioninstaller's ability to install
    codecs. Thanks seb128 for identifying the root cause. (LP: #1661371)

 -- Jeremy Bicha <email address hidden> Wed, 22 Mar 2017 09:20:38 -0400

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.