Update to PackageKit 1.0

Bug #1470655 reported by Robert Ancell
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
click (Ubuntu)
High
Unassigned
packagekit (Ubuntu)
High
Unassigned

Bug Description

Update to 1.0

Related branches

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Blocks gnome-software (bug 1470656)

Changed in packagekit (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Revision history for this message
Sebastien Bacher (seb128) wrote :

That new version drops support for plugins, or that's needed for click at the moment (though mvo said he has started work to make click use the dbus api instead which would resolve that issue)

summary: - Update to 1.0
+ Update to PackageKit 1.0
Revision history for this message
Robert Ancell (robert-ancell) wrote :

The branch with the click work is lp:~mvo/click/native-dbus.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Blocking gnome-packagekit (bug 1470657)

Changed in packagekit (Ubuntu):
importance: Wishlist → High
Revision history for this message
Robert Ancell (robert-ancell) wrote :

We can probably just sync from Debian when ready. The only substantial change seems to the virtual packagekit-system-interface provides which is probably not necessary anymore.

Revision history for this message
Matthias Klumpp (ximion) wrote :

Awesome!
You can drop the virtual interface if you don't want to continue to use Aptdaemon for software which is using PackageKit interfaces (which I would of course welcome ^^).
Cheers,
    Matthias

Revision history for this message
Robert Ancell (robert-ancell) wrote :

We discussed at the Desktop team sprint that we should drop aptdaemon, so I think we can do this.

tags: added: xenial
Revision history for this message
Sebastien Bacher (seb128) wrote :

The merge from Debian was done and uploaded before being removed because the transition is not ready, the work is still done and can be reused later on when needed, see https://launchpad.net/ubuntu/+source/packagekit/1.0.10-1ubuntu1

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in click (Ubuntu):
status: New → Confirmed
Changed in packagekit (Ubuntu):
importance: High → Critical
Changed in click (Ubuntu):
importance: Undecided → Critical
tags: added: gnome-software-ubuntu
Revision history for this message
Adolfo Jayme (fitojb) wrote :

Sorry, but this does not fit the criteria for critical importance outlined in https://wiki.ubuntu.com/Bugs/Importance

Changed in packagekit (Ubuntu):
importance: Critical → High
Changed in click (Ubuntu):
importance: Critical → High
status: Confirmed → Triaged
tags: removed: gnome-software-ubuntu
Changed in packagekit (Ubuntu):
status: Triaged → Fix Released
Changed in packagekit (Ubuntu):
status: Fix Released → Fix Committed
rumseed (rumseed)
Changed in packagekit (Ubuntu):
status: Fix Committed → Fix Released
Changed in click (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson)
Changed in packagekit (Ubuntu):
status: Fix Released → Fix Committed
Changed in click (Ubuntu):
status: Fix Released → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click - 0.4.44+16.10.20160811.1-0ubuntu1

---------------
click (0.4.44+16.10.20160811.1-0ubuntu1) yakkety; urgency=medium

  [ Colin Watson ]
  * Handle new policy URL in debsig-verify 0.15. (LP: #1608281)

 -- Timo Jyrinki <email address hidden> Thu, 11 Aug 2016 10:50:58 +0000

Changed in click (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Jeremy Bicha (jbicha) wrote :
Changed in packagekit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers