I cannot reinstall a package from packagekit

Bug #1059077 reported by Stinger
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
Wishlist
Unassigned

Bug Description

I cannot reinstall a package from packagekit like I can from synaptic, I have to remove it first.

Revision history for this message
Matthias Klumpp (ximion) wrote :

I don't think this is a feature which will be implemented... It is equal to removing a package & installing it again - Why do you need this feature? GNOME has a very strict policy about adding features which aren't useful or don't have use-cases for the target audience.

Revision history for this message
Stinger (e-mindahl) wrote :

I would need this feature if I eg. have messed up a gstreamer package, this package has dependency to totem and totem has dependencies to the whole desktop environment.
So if I use your suggestion I would have to uninstall a whole lot of packages including the desktop meta-package, and if I haven't made a list of all the involved packages I wold most likely not have them installed back again by installing the gstreamer package, because their dependencies goes downwards.

That's why this feature is nice to have, and I would like to see Packagekit as feature full as Synaptic

This could be added as whishlist too.

Jeremy Bicha (jbicha)
Changed in gnome-packagekit (Ubuntu):
importance: Undecided → Wishlist
Matthias Klumpp (ximion)
summary: - I cannot re-install a package from packagekit
+ I cannot reinstall a package from packagekit
affects: gnome-packagekit (Ubuntu) → packagekit (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers