Error: Timeout was reached

Bug #1001376 reported by martin suchanek
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
packagekit (Debian)
New
Unknown
packagekit (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

almost in 90 percent cases when I run
apt-get upgrade
I have got error:
Error: Timeout was reached

but always all packages seem to be properly installed.

following did not help:
echo 'Acquire::http::Timeout "600";' > timeout

lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy apt
apt:
  Installed: 0.8.16~exp12ubuntu10
  Candidate: 0.8.16~exp12ubuntu10
  Version table:
 *** 0.8.16~exp12ubuntu10 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

expected:
no timeout error

happened:
Error: Timeout was reached

Tags: precise
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Revision history for this message
Axel Beckert (xtaran) wrote :

This is very likely caused by packagekit's APT hook talking over dbus. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=729527 for more details.

Axel Beckert (xtaran)
affects: apt (Ubuntu) → packagekit (Ubuntu)
affects: apt (Debian) → packagekit (Debian)
Axel Beckert (xtaran)
tags: added: precise
Changed in packagekit (Debian):
status: Unknown → Incomplete
Changed in packagekit (Debian):
status: Incomplete → New
Changed in packagekit (Debian):
status: New → Fix Released
Changed in packagekit (Debian):
status: Fix Released → New
Revision history for this message
Rolf Leggewie (r0lf) wrote :

Debian fixed this in January, would be nice to see a backported fix for this apparently harmless but very visible bug

Revision history for this message
Rolf Leggewie (r0lf) wrote :

Here is the backported patch as a debdiff for trusty.

I've recompiled the package locally and will let you know if this does NOT fix the issue for me.

Revision history for this message
Michael Vogt (mvo) wrote :

@Rolf: thanks for your patch. Did you succesfully tested this yet? It looks good to me and I'm happy to upload.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.8.12-1ubuntu4

---------------
packagekit (0.8.12-1ubuntu4) trusty; urgency=low

  * increase timeout for aptcc. LP: #1001376
 -- Rolf Leggewie <email address hidden> Tue, 01 Apr 2014 20:47:03 +0800

Changed in packagekit (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

This occurs much less frequently, but at least today I experienced this again. So, it looks like the upstream isn't entirely sufficient.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.