Merge pacemaker from Debian unstable for 22.04

Bug #1946885 reported by Bryce Harrington
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pacemaker (Ubuntu)
Undecided
Lucas Kanashiro

Bug Description

Upstream: 2.1.1
Debian: 2.0.5-2
Ubuntu: 2.0.5-2ubuntu3

Debian typically updates pacemaker every 3-6 months on average, but it was last updated 21.01 and looks overdue. Check back in on this monthly.

There is a new upstream version, however, so may be worth going ahead of
debian and/or updating it in Debian and syncing it.

### New Debian Changes ###

pacemaker (2.0.5-2) unstable; urgency=medium

  [ Helmut Grohne ]
  * [0e95220] Drop superfluous build dependencies
    dctrl-tools: after merging the dev packages check_header_deps was
    dropped in 2.0.1~rc2-2 (7c66cac).
    libesmtp-dev, libsnmp-dev, libsensors-dev: upstream dropped SMTP and
    SNMP support from crm_mon in Pacemaker 2 (1f73748, f24bdc6)
    (Closes: #979368)

 -- Ferenc Wágner <email address hidden> Fri, 08 Jan 2021 19:47:14 +0100

pacemaker (2.0.5-1) unstable; urgency=medium

  * [b0f97de] New upstream release (2.0.5)
  * [a7725e6] libqb 2 dropped the linker magic injecting start/stop symbols

 -- Ferenc Wágner <email address hidden> Sat, 26 Dec 2020 18:25:28 +0100

pacemaker (2.0.5~rc3-1) unstable; urgency=medium

  * [6037de8] Add CVE-2020-25654 reference to changelog
  * [8633b12] New upstream pre-release (2.0.5~rc3)
  * [280e76f] Update Standards-Version to 4.5.1 (no changes required)
  * [fa41836] New patch: Always run Inkscape under the C.UTF-8 locale

 -- Ferenc Wágner <email address hidden> Wed, 18 Nov 2020 22:45:27 +0100

pacemaker (2.0.5~rc2-1) unstable; urgency=medium

  [ Rafael David Tinoco ]
  * [0f1033e] Skip autopkgtest for unprivileged containers: (LP: #1828228)
    + d/t/control: mark pacemaker test as skippable
    + d/t/pacemaker: skip if memlock can't be set to unlimited by root

  [ Ferenc Wágner ]
  * [34f6376] pacemaker-dev should pull in libpacemaker1, too
  * [039f205] The pacemaker-dev transition completed in buster
  * [800ae5e] Clean up remnants of long finished reorganizations
  * [0f0340c] pacemaker-dev in buster replaced its old dependencies from wheezy
  * [6956006] New upstream pre-release (2.0.5~rc2) (Closes: #973254)
    Contains fix for CVE-2020-25654.
  * [6b30c82] Delete upstreamed patch, refresh the rest
  * [8e78417] Tie skipping the autopkgtest to the concrete Corosync error.
    While unlimited memory lock is a good test for privileges, it isn't
    critical for Corosync. Trigger on a specific error message instead,
    hint at a possible workaround and document the actual requirements.
  * [f184e2c] Update symbols files.
    See 4bcf7eb for the reasoning behind the two renamed symbols which
    weren't obviously internal: crm_config_error and crm_config_warning.
  * [0031784] Pacemaker and pacemaker-remote provide Conflicting functions.
    Breaks without a version was always suspicious to Lintian, and I've got
    no strong opinion on this specific case, so be it.
  * [2a33943] Replace the now-transitional build dep with libncurses-dev
  * [8662ee0] Add missing pkg-config dependencies (Closes: #963791)
  * [912a22b] New autopkgtest for pkg-config completeness
  * [5033800] Upgrade watch file to version 4 (no changes needed)

 -- Ferenc Wágner <email address hidden> Tue, 10 Nov 2020 23:02:55 +0100

pacemaker (2.0.4-2) unstable; urgency=medium

  * [a0fdbb5] The special libqb symbols aren't present on PowerPC architectures

 -- Ferenc Wágner <email address hidden> Mon, 22 Jun 2020 18:08:57 +0200

pacemaker (2.0.4-1) unstable; urgency=medium

  [ Rafael David Tinoco ]
  * [30838df] Omit pacemaker-resource-agents on Ubuntu/i386

  [ Ferenc Wágner ]
  * [bc43eed] New upstream release (2.0.4) (Closes: #959593)
  * [a4e8629] Drop upstreamed patch, refresh the rest
  * [42ee58f] Enable CIB secrets and ship the cibsecret tool
  * [13be83d] Update Standards-Version to 4.5.0 (no changes required)
  * [90d9610] New patch: libpacemaker calls into libstonithd directly
  * [61500a3] The obsolete ACL document was removed altogether.
    In upstream commit d796f1e, because it was superseded by a new chapter
    of Pacemaker Explained.
  * [dce33c1] Drop dummy packages which were already transitional in buster
  * [3f7de34] Update symbols files.
    The newly disappeared symbols weren't present in the headers shipped in
    pacemaker-dev, except for three functions in attrd.h. However, those
    weren't documented either and the header was renamed to attrd_internal.h
    to show its internal status (see upstream commit 16c7d122e).
  * [4bbb828] Update packaging list email address
  * [7c12194] New patch: Fix typo: evalute => evaluate
  * [8d9cbd4] The bullseye toolchain defaults to linking with --as-needed

 -- Ferenc Wágner <email address hidden> Sun, 21 Jun 2020 20:32:05 +0200

pacemaker (2.0.3-3) unstable; urgency=medium

  * [543574f] Omit pacemaker{, -cli-utils, -remote} on Ubuntu/i386
    (Closes: #948379)
  * [327889e] Reenable dwz, it already works with the magic sections from libqb

 -- Ferenc Wágner <email address hidden> Sun, 12 Jan 2020 13:08:03 +0100

### Old Ubuntu Delta ###

pacemaker (2.0.5-2ubuntu3) impish; urgency=medium

  * d/t/pacemaker: corosync uses uname -n to define the default node name.
    Previously the default node name was hardcoded in the config file as
    node1.

 -- Lucas Kanashiro <email address hidden> Wed, 23 Jun 2021 09:17:38 -0300

pacemaker (2.0.5-2ubuntu2) impish; urgency=medium

  * Adjust dependency relations with the {fence,resource}-agents packages. The
    following changes were applied in debian/control:
    - Make pacemaker binary recommend fence-agents-base.
    - Make pacemaker-resource-agents depend on resource-agents-base.
      Also suggest resource-agents-extra with non-curated agents.

 -- Lucas Kanashiro <email address hidden> Wed, 05 May 2021 17:04:36 -0300

pacemaker (2.0.5-2ubuntu1) hirsute; urgency=medium

  * Merge with Debian unstable. Remaining changes:
    - d/control: Demote fence-agents to Suggests, avoiding main inclusion.
    - Make crmsh the default management tool for now (LP #1862947)
    - d/rules: Forcibly switch from ftime to clock_gettime, since building
      with ftime now results in deprecation errors
    - d/rules: Fix FTBFS in ppc64el compiling with gcc10: Don't treat
      format-overflow warnings as errors
  * Dropped:
    - Skip autopkgtest for unprivileged containers: (LP #1828228)
      + d/t/control: mark pacemaker test as skippable
      + d/t/pacemaker: skip if memlock can't be set to unlimited by root
      [fixed in Debian]
    - Post 2.0.04 release fixes backported to Ubuntu (LP #1895883)
      debian/patches/ubuntu/lp1895883-*:
      + [055d7e4e] Low: libcib: Fix building if the gnutls library is not
      + [67174c53] Build: configure: Conditionalize check for $PYTHON.
      + [47c3e06b] Fix: libpacemaker: Don't allow a potential NULL in a format
      + [ea7469cb] Low: resources: don't check host-specific conditions in
      + [7056ae08] Fix: libcrmcommon: Set out->priv to NULL in free_priv.
      + [37791529] Fix: libcrmcommon: Make reset and finish work more similarly.
      + [b655c039] Fix: tools: Add the http-equiv header to crm_mon at the right
      + [0f8e4ca5] Fix: tools, libcrmcommon: Reopen the output dest on reset.
      + [24dd01c3] Fix: cts: Use a different grep in building the cts-cli
      + [36cf9284] Fix: cts: Use --node instead of --host as crm_resource
      + [5c111adf] Fix: libpe_status: Destroy hash table after use
      + [dc341923] cluster: Close corosync handles when they disconnect
      + [3a88b2b6] Refactor: tools: rename function in cibsecret to be more
      [applied by upstream]
    - Post 2.0.4 features: on-fail=demote & no-quorum-policy=demote
      (LP #1896223). Added debian/patches/ubuntu/lp1896223-*:
      + [c4429d86e] Log: scheduler: downgrade 'active on' messages to trace
      + [01c5ec67e] Low: scheduler: match initial no-quorum-policy struct value
      + [015b5c012] Doc: Pacemaker Explained: document no-quorum-policy=demote
      + [5d809e136] Test: scheduler: add regression test
      + [b1ae35938] Feature: scheduler: support 'demote' choice
      + [0b6834453] Refactor: scheduler: functionize checking quorum policy
      + [d4b9117e7] Doc: Pacemaker Explained: correct on-fail default
      + [204961e95] Doc: Pacemaker Explained: document new on-fail='demote'
      + [d29433ea5] Test: scheduler: add regression tests for on-fail='demote'
      + [874f75e0f] Feature: scheduler: new on-fail='demote' recovery policy
      + [2f1e2df1f] Feature: xml: add on-fail='demote' option to resources
      + [fd55a6660] Doc: libpacemaker: improve comments for resource state
      + [98c3b649f] Log: libpacemaker: check for re-promotes specifically
      + [ff6aebecf] Doc: libpacemaker: improve comments when logging actions
      + [f2d244bc4] Test: scheduler: test forcing a restart instead of reload
      + [a4d6a20a9] Low: libpacemaker: don't force stop when skipping reload
      + [8dceba792] Refactor: scheduler: use more appropriate types in a couple
      + [ef246ff05] Fix: scheduler: disallow on-fail=stop for stop operations
      + [f1f71b3f3] Refactor: scheduler: functionize comparing on-fail values
      [applied by upstream]
    - SECURITY UPDATE: ACL restrictions bypass
      + debian/patches/CVE-2020-25654-*.patch: restrict IPC connections.
      + CVE-2020-25654
      [applied by upstream]
    - d/{libcib27,libcrmcluster29,libcrmcommon34,libcrmservice28,
      liblrmd28,libpacemaker1,libpe-rules26,libpe-status28,libstonithd26}.symbols:
      libqb 2 dropped the linker magic injecting start/stop symbols.
      Thanks to Ferenc Wágner <email address hidden>.
      [fixed in Debian]

 -- Lucas Kanashiro <email address hidden> Tue, 19 Jan 2021 17:15:50 -0300

Changed in pacemaker (Ubuntu):
assignee: nobody → Lucas Kanashiro (lucaskanashiro)
Bryce Harrington (bryce)
description: updated
Changed in pacemaker (Ubuntu):
milestone: none → ubuntu-21.12
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers