pacemaker migration failed autopkgtests

Bug #1838024 reported by Rafael David Tinoco on 2019-07-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pacemaker (Ubuntu)
Medium
Rafael David Tinoco
Eoan
Medium
Rafael David Tinoco

Bug Description

Pacemaker is currently failing autopkgtests for Eoan. Excuses show:

pacemaker (1.1.18-2ubuntu1 to 2.0.1-4ubuntu2)
Maintainer: Ubuntu Developers
0 days old
autopkgtest for booth/1.0-162-g27f917f-2: amd64: Pass, arm64: Regression ♻ , armhf: Always failed, i386: Always failed, ppc64el: Pass, s390x: Pass
autopkgtest for crmsh/3.0.1-3ubuntu1: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
autopkgtest for pacemaker/2.0.1-4ubuntu2: amd64: Regression ♻ , arm64: Regression ♻ , armhf: Pass, i386: Regression ♻ , ppc64el: Regression ♻ , s390x: Regression ♻
autopkgtest for pcs/0.10.1-2: amd64: Ignored failure, arm64: Ignored failure, armhf: Ignored failure, i386: Ignored failure, ppc64el: Ignored failure, s390x: Ignored failure
autopkgtest for sbd/1.3.1-4: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
Depends: pacemaker corosync (not considered)
Not considered

This bug is to investigate all those issues.

Changed in pacemaker (Ubuntu Eoan):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)

Last autopkgtest that succeed shows:

autopkgtest [07:14:15]: test pacemaker: [-----------------------
+ sleep 60
+ crm_mon -1
+ hostname -s
+ fgrep -20 Online: [ autopkgtest ]
Stack: corosync
Current DC: autopkgtest (version 1.1.18-2b07d5c5a9) - partition WITHOUT quorum
Last updated: Tue Jul 16 07:15:15 2019
Last change: Tue Jul 16 07:14:32 2019 by hacluster via crmd on autopkgtest

1 node configured
0 resources configured

Online: [ autopkgtest ]

No active resources

autopkgtest [07:15:16]: test pacemaker: -----------------------]
autopkgtest [07:15:16]: test pacemaker: - - - - - - - - - - results - - - - - - - - - -
pacemaker PASS
autopkgtest [07:15:16]: @@@@@@@@@@@@@@@@@@@@ summary
pacemaker PASS

----

Before the upgrade, the test has also failed with similar (as now) output:

autopkgtest [20:08:18]: test pacemaker: [-----------------------
+ sleep 60
+ crm_mon -1
+ hostname -s
+ fgrep -20 Online: [ autopkgtest ]
autopkgtest [20:09:18]: test pacemaker: -----------------------]
autopkgtest [20:09:18]: test pacemaker: - - - - - - - - - - results - - - - - - - - - -
pacemaker FAIL non-zero exit status 1
autopkgtest [20:09:18]: @@@@@@@@@@@@@@@@@@@@ summary
pacemaker FAIL non-zero exit status 1

----

And after the upgrade, just one test and failed the same way:

autopkgtest [20:26:39]: test pacemaker: [-----------------------
+ ulimit -H -l unlimited
+ sleep 25
+ fgrep -20 Online: [ node1 ]
+ crm_mon -1
autopkgtest [20:27:05]: test pacemaker: -----------------------]
autopkgtest [20:27:05]: test pacemaker: - - - - - - - - - - results - - - - - - - - - -
pacemaker FAIL non-zero exit status 1
autopkgtest [20:27:06]: @@@@@@@@@@@@@@@@@@@@ summary
pacemaker FAIL non-zero exit status 1

----

Meaning, AT LEAST, the test is flakky and likely because of timing issues waiting for corosync or some other reason (can't reproduce locally).

I'll rewrite both, corosync and pacemaker simple tests, and give it a try in new package versions. It will have more output (to debug possible issues) and will try to wait for an event, instead of waiting for time only.

After some test clean ups we did, we could obtain:

pacemaker (1.1.18-2ubuntu1 to 2.0.1-4ubuntu2)
Maintainer: Ubuntu Developers
13 days old
autopkgtest for booth/1.0-162-g27f917f-2: amd64: Pass, arm64: Pass, armhf: Always failed, i386: Always failed, ppc64el: Pass, s390x: Pass
autopkgtest for crmsh/3.0.1-3ubuntu1: armhf: Pass, i386: Pass, s390x: Pass
autopkgtest for crmsh/4.0.0~git20190108.3d56538-3ubuntu1: amd64: Pass, arm64: Pass, ppc64el: Pass
autopkgtest for pacemaker/2.0.1-4ubuntu2: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
autopkgtest for pcs/0.10.1-2: amd64: Ignored failure, arm64: Ignored failure, armhf: Ignored failure, i386: Ignored failure, ppc64el: Ignored failure, s390x: Ignored failure
autopkgtest for sbd/1.3.1-4: amd64: Pass, arm64: Pass, armhf: Pass, ppc64el: Pass, s390x: Pass
autopkgtest for sbd/1.4.0-18-g5e3283c-1: i386: Pass
Invalidated by dependency
Depends: pacemaker corosync (not considered)
Not considered

I'll close this test as soon as all regressions from rdepends of:

https://bugs.launchpad.net/ubuntu/+source/corosync/+bug/1837064

are solved.

Pacemaker was cleanup for Eoan migrations.

Changed in pacemaker (Ubuntu Eoan):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers