Fencing is not reported to DLM

Bug #1397278 reported by EOLE team on 2014-11-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pacemaker (Ubuntu)
Medium
Unassigned
Trusty
Low
Unassigned

Bug Description

Hello,

When dlm_controld requests the fencing of a node, the node is fenced but dlm_controld is not notified of the fence result.

All the informations are reported on pacemaker mailing-list http://oss.clusterlabs.org/pipermail/pacemaker/2014-November/023082.html.

There is 3 patches available to fix this issue: http://oss.clusterlabs.org/pipermail/pacemaker/2014-November/023151.html

* David Vossel (9 months ago) 054fedf: Fix: stonith_api_time_helper now returns when the most recent fencing operation completed (origin/pr/444)
* Andrew Beekhof (9 months ago) d9921e5: Fix: Fencing: Pass the correct options when looking up the history by node name
* Andrew Beekhof (9 months ago) b0a8876: Log: Fencing: Send details of stonith_api_time() and stonith_api_kick() to syslog

Regards.

pacemaker:
  Installé : 1.1.10+git20130802-1ubuntu2.1
  Candidat : 1.1.10+git20130802-1ubuntu2.1
 Table de version :
 *** 1.1.10+git20130802-1ubuntu2.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.1.10+git20130802-1ubuntu2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pacemaker (Ubuntu):
status: New → Confirmed
Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Is there an upstream release that fixes this issue, please, and if so, which version?

To fix the packages in Trusty, please follow the steps documented at https://wiki.ubuntu.com/StableReleaseUpdates#Procedure - we have to do this carefully to ensure that unaffected existing users are not regressed. In particular, we need an explanation of how this bug affects users in terms of use case, detailed steps to reproduce the problem that someone not familiar with this package can follow, and a discussion of how regressions are most likely to manifest as a result of these patches.

Changed in pacemaker (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
EOLE team (eole-team) wrote :

Hello,

The listed commits are included since version 1.1.12 but no backports was made by upstream.

Robie Basak (racb) wrote :

Thanks. Since this is then presumed fixed in Xenial which is at 1.1.12-0ubuntu3, I'm marking this bug as Fix Released. If you would like this fix backported to 14.04 then someone needs to prepare a backport as described in https://wiki.ubuntu.com/StableReleaseUpdates#Procedure. I'll leave a task open to reflect this.

Changed in pacemaker (Ubuntu):
status: Triaged → Fix Released
Changed in pacemaker (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Low
igor (icicimov-gmail) wrote :

So more than two years later and this is still not even assigned. Is 14.04 still in LTS or not? Do you know if the work on back-porting the fixes is ever going to start?

EOLE team (eole-team) wrote :

We switched to Xenial servers.

We do not need this backport anymore.

Regards.

Robie Basak (racb) wrote :

> So more than two years later and this is still not even assigned.

With only three users affected over almost three years, this was never a priority to fix. I did welcome volunteers, and none came forward.

> Do you know if the work on back-porting the fixes is ever going to start?

Volunteers still welcome.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers