p7zip-full fails to deal correctly with filename encodings

Bug #1382106 reported by Pilot6 on 2014-10-16
274
This bug affects 65 people
Affects Status Importance Assigned to Milestone
file-roller (Debian)
New
Unknown
p7zip (Ubuntu)
High
Unassigned

Bug Description

This bug has been recently fixed in https://bugs.launchpad.net/ubuntu/+source/unzip/+bug/580961

But the problem is that when p7zip-full is installed unzip is handled by p7zip. There is no way to set File Roller to use unzip instead.
Test case is exactly same as in previous bug.

The most annoying is that playonlinux depends on p7zip-full and I have to uninstall it every time I work with archives.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: p7zip-full 9.20.1~dfsg.1-4
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Uname: Linux 3.13.0-37-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Oct 16 19:40:05 2014
InstallationDate: Installed on 2013-10-17 (364 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
SourcePackage: p7zip
UpgradeStatus: Upgraded to trusty on 2014-04-16 (182 days ago)

Pilot6 (hanipouspilot) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in p7zip (Ubuntu):
status: New → Confirmed
Pilot6 (hanipouspilot) wrote :

There may be another solution. To set file-roller to use unzip instead of p7zip for zip files.

Changed in p7zip (Ubuntu):
importance: Undecided → High
Pilot6 (hanipouspilot) on 2014-11-10
description: updated
Pilot6 (hanipouspilot) wrote :

I disabled usage of p7zip-full by file-roller. This fixes this bug. It is to hard for me at the moment to patch p7zip itself.

Pilot6 (hanipouspilot) wrote :

The patch is for file-roller_3.10.2.1

The attachment "file-roller.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Pilot6 (hanipouspilot) wrote :

This looks better.

Pilot6 (hanipouspilot) wrote :

I made a ppa with patched file-roller

ppa:hanipouspilot/file-roller

Dmitry-Kogura (dmitry-kogura) wrote :

Very actual bug.
To set file-roller to use unzip instead of p7zip for zip files is only temporary solution and only for file-roller.
p7zip used in many projects and should be corrected like unzip.

monomakh (monomakh) wrote :

thanks for ppa from post 8.

Pilot6 (hanipouspilot) wrote :

Added patched file-roller for vivid.
Here is the patch. I think it is a good idea to commit this patch to main. It will solve a lot of problems for many users.
And no regression at all. P7zip-full is not installed to Ubuntu by default, and unzip is used.
So there is no problem to keep using it, while p7zip-full is installed.
It is hard to patch p7zip itself, and it is not likely someone does it soon.

CSRedRat (csredrat) wrote :

https://bugs.launchpad.net/ubuntu/+source/unzip/+bug/580961

Hendrik Knackstedt (hennekn) on 2014-02-02
Changed in unzip (Ubuntu):
status: Triaged → Fix Released

Mathew Hodson (mathew-hodson) wrote :

There is an open file-roller bug about encoding support: Bug #495880

So removing task from here.

affects: file-roller → ubuntu-translations
no longer affects: ubuntu-translations
s3rpeNt (s3rpent) on 2016-07-12
Changed in p7zip (Ubuntu):
assignee: nobody → s3rpeNt (s3rpent)
assignee: s3rpeNt (s3rpent) → nobody
Arutyun (arutyun-akopov) wrote :

Please fix it in p7zip-full. It's a big problem.

Dmitry-Kogura (dmitry-kogura) wrote :

Will anybody anytime fix this problem?

era (era) wrote :

Someone seems to have attempted to forward this upstream but then they never responded to the feedback in the Debian ticket. Under those circumstances, this is unlikely to proceed.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=862957

Changed in file-roller (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.