package p11-kit-modules (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so', which is also in package p11-kit 0.20.2-1ubuntu2

Bug #1295240 reported by Jake McGregor on 2014-03-20
174
This bug affects 38 people
Affects Status Importance Assigned to Milestone
p11-kit (Ubuntu)
Undecided
Iain Lane

Bug Description

I was running an update check when this happened.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: p11-kit-modules (not installed)
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
AptOrdering:
 p11-kit-modules: Install
 p11-kit: Install
 p11-kit-modules: Configure
 p11-kit: Configure
Architecture: amd64
Date: Thu Mar 20 12:01:58 2014
DpkgTerminalLog:
 Preparing to unpack .../p11-kit-modules_0.20.2-2ubuntu1_amd64.deb ...
 Unpacking p11-kit-modules:amd64 (0.20.2-2ubuntu1) ...
 dpkg: error processing archive /var/cache/apt/archives/p11-kit-modules_0.20.2-2ubuntu1_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so', which is also in package p11-kit 0.20.2-1ubuntu2
DuplicateSignature: package:p11-kit-modules:(not installed):trying to overwrite '/usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so', which is also in package p11-kit 0.20.2-1ubuntu2
ErrorMessage: trying to overwrite '/usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so', which is also in package p11-kit 0.20.2-1ubuntu2
InstallationDate: Installed on 2014-01-22 (56 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130402.1)
SourcePackage: p11-kit
Title: package p11-kit-modules (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so', which is also in package p11-kit 0.20.2-1ubuntu2
UpgradeStatus: Upgraded to trusty on 2014-02-04 (44 days ago)

Jake McGregor (jake-mcgregor86) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in p11-kit (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

My bad, sorry about that.

Changed in p11-kit (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package p11-kit - 0.20.2-2ubuntu2

---------------
p11-kit (0.20.2-2ubuntu2) trusty; urgency=medium

  * Add Breaks and Replaces for p11-kit-modules file move. (LP: #1295240)
 -- Iain Lane <email address hidden> Thu, 20 Mar 2014 17:20:08 +0000

Changed in p11-kit (Ubuntu):
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1295240

tags: added: iso-testing
Vlad Paul Paval (wladypauly) wrote :

I solved this error by entering this in the command line:
sudo dpkg -i --force-overwrite /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so

bill (wemember) wrote :

Tried the the fix suggested by Vlad Paul Paval and got the following message.

ted@ted-Satellite-C660D:~$ sudo dpkg -i --force-overwrite /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so
[sudo] password for ted:

dpkg-deb: error: `/usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so' is not a debian format archive
dpkg: error processing archive /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so (--install):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so
ted@ted-Satellite-C660D:~$ ^C
ted@ted-Satellite-C660D:~$

iain (l-iain) wrote :

Same when I ran the above 'fix'

Mike Yontz (swftech) wrote :

Fixed for me after opening synaptic, clicking edit - -> "fix broken packages" (there was one broken package) then reload, mark all upgrades, apply. All updates were fine after that.

Kostiantyn Rybnikov (k-bx) wrote :

Fixed by apt-get dist-upgrade

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers