Multicast traffic is broken between VMs on different hypervisors using provider networks

Bug #1957817 reported by James Troup
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ovn (Ubuntu)
Undecided
Unassigned

Bug Description

In an OpenStack Ussuri (both Focal and Bionic) cloud we discovered that multicast traffic would fail between VMs on different hypervisors and when using provider networks. The following table reflects what we found works/didn't work:

 https://paste.ubuntu.com/p/QZZBjrTSFQ/

Based on this, I went looking at relevant changes upstream and found that this appears to have been fixed upstream, but not backported to OVN 20.03:

https://github.com/ovn-org/ovn/commit/97778ab3e422ac071faa67f9f477fd54977e9c04

I backported this patch to the version of OVN in Ussuri here:

  https://launchpad.net/~elmo/+archive/ubuntu/sf322809

These patched packages have been tested on a customer site and confirmed to fix the problem.

I've attached the patch from the PPA for convenience.

Revision history for this message
James Troup (elmo) wrote :
description: updated
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Backport of 97778ab3e422ac071faa67f9f477fd54977e9c04 to OVN 20.03.2" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
James Troup (elmo)
summary: - Multicast traffic is broken between VMs on different hypervisors
+ Multicast traffic is broken between VMs on different hypervisors using
+ provider networks
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers