incorrect multi-arch related meta information.

Bug #1262022 reported by Tomas Sandven on 2013-12-18
170
This bug affects 37 people
Affects Status Importance Assigned to Milestone
overlay-scrollbar (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned

Bug Description

== SRU Impact ==
overlay-scrollbar-gtk2:i386 is uninstallable on amd64, which blocks the installation of some packages.

== Test Case ==

On amd64:
dpkg --add-architecture i386
apt update
apt install overlay-scrollbar-gtk2:i386

Either this succeeds, or fails (this bug)

== Regression potential ==

Nil (or close enough)

== Original Bug ==

I'm on a 64-bit system trying to install "overlay-scrollbar-gtk2:i386" which depends on the "overlay-scrollbar:i386" package. "overlay-scrollbar:i386" doesn't have an install candidate because it's a "multi-arch" package. This should (or so I've been told) be reflected in the meta information of the "overlay-scrollbar" package but isn't, which is why the former package fails to install.

As a more competent person than I put it:

"The overlay-scrollbar package does not come in i386 or amd64 flavors; it comes as an "all" flavor, which installs on all archs.

It appears to be missing the Multi-Arch: allowed header so it won't satisfy an i386 package depending on it. You should file a bug report asking that the missing header be added."

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: overlay-scrollbar 0.2.16+r359+13.10.20130826-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Wed Dec 18 02:14:35 2013
InstallationDate: Installed on 2013-12-14 (3 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: overlay-scrollbar
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Tomas Sandven (codemonkey1991) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in overlay-scrollbar (Ubuntu):
status: New → Confirmed
David Vas (outsider-dave) wrote :

Also, the same thing exists with unity-gtk-module. Do we need a separate bug report for that?

Adolfo Jayme (fitojb) on 2014-04-03
Changed in overlay-scrollbar (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
slothy (slothyrulez) wrote :

Ubuntu 14.04
Same behavior

Joshua R. Poulson (jrp) wrote :

I don't have the issue with unity-gtk-module, but I am still having trouble with the scrollbar:

root@bigthink:~# apt-get download overlay-scrollbar-gtk2:i386 overlay-scrollbar-gtk3:i386
Get:1 http://archive.ubuntu.com/ubuntu/ trusty/main overlay-scrollbar-gtk2 i386 0.2.16+r359+14.04.20131129-0ubuntu1 [29.3 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty/main overlay-scrollbar-gtk3 i386 0.2.16+r359+14.04.20131129-0ubuntu1 [30.9 kB]
Fetched 60.2 kB in 0s (122 kB/s)
root@bigthink:~# sudo dpkg --ignore-depends overlay-scrollbar -i overlay-scrollbar-gtk*.deb
Selecting previously unselected package overlay-scrollbar-gtk2:i386.
(Reading database ... 419681 files and directories currently installed.)
Preparing to unpack overlay-scrollbar-gtk2_0.2.16+r359+14.04.20131129-0ubuntu1_i386.deb ...
Unpacking overlay-scrollbar-gtk2:i386 (0.2.16+r359+14.04.20131129-0ubuntu1) ...
Selecting previously unselected package overlay-scrollbar-gtk3:i386.
Preparing to unpack overlay-scrollbar-gtk3_0.2.16+r359+14.04.20131129-0ubuntu1_i386.deb ...
Unpacking overlay-scrollbar-gtk3:i386 (0.2.16+r359+14.04.20131129-0ubuntu1) ...
dpkg: dependency problems prevent configuration of overlay-scrollbar-gtk2:i386:
 overlay-scrollbar-gtk2:i386 depends on overlay-scrollbar.

dpkg: error processing package overlay-scrollbar-gtk2:i386 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of overlay-scrollbar-gtk3:i386:
 overlay-scrollbar-gtk3:i386 depends on overlay-scrollbar.

dpkg: error processing package overlay-scrollbar-gtk3:i386 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 overlay-scrollbar-gtk2:i386
 overlay-scrollbar-gtk3:i386

When this cannot be installed, you will see

   Gtk-Message: Failed to load module "overlay-scrollbar"

running 32-bit apps, such as skype.

Jonathan Reed (jdreed) wrote :

I'm also running into this on Trusty. What needs to happen to get someone to look at the bzr branches and merge request linked in this bug?

tags: added: trusty
Martin Pitt (pitti) wrote :

This package is handled by the automatic CI train machinery, so I can't just sponsor it.

stormzen (stormzen) wrote :

I seem to be completely blocked from being able to view a PDF until this is solved. Acrobat appears to do this thing where it's the only reader that can read certain PDFs ( It prints a nice message telling me so when I try to load it in Google or Evince )

But I can't open a file from acroreader until it gets its scrollbar. Further, there is no option to use Acrobat Reader from 'open with' when browsing the filesystem.

In desperation, I tried to follow this:

http://askubuntu.com/questions/392097/how-do-i-install-32-bit-libraries-when-they-keep-having-uninstallable-dependenci?newreg=f8daa9b771684ce989a504fb4216b21f

.. Even though it seemed like a "bad idea".

Screwed up my packaging system temporarily. My fault, entirely, of course.

Please fix this, or provide a work-around that preferably doesn't involve hand-altering system configuration files.

Thanks!

Sean Brisbane (s-brisbane1) wrote :

Health warning: You should not run any packages without security support such as acroread. If you still want to, these are the steps which worked for me

"acroread "will work without canberra-gtk-module, unity-gtk module, murrine theme, and the overlay scrollbar you can ignore those messages when just trying to get it to run (though, it will be nicer if these are fixed, and the steps below do fix most of these warnings)

1)
apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386
apt-get install --reinstall gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386

2) To make many 32 bit programs work, you will also need the i386 versions of name service libraries:

It depends on the system how you do this:

aptitude search libnss | grep ^i | grep -v i386

i libnss-ldap - NSS module for using LDAP as a naming serv
i A libnss-mdns - NSS module for Multicast DNS name resoluti
i A libnss-sss - Nss library for the System Security Servic
i A libnss3 - Network Security Service libraries
i A libnss3-nssdb - Network Security Security libraries - shar

I needed to make sure that the 32 bit versions of the above were installed
apt-get install libnss-ldap:i386 libnss-mdns:i386 libnss-sss:i386 libnss3:i386 libnss3-nssdb:i386

Finally:
from http://mastro77.blogspot.co.uk/2015/06/installing-adobe-reader-9-in-ubuntu-1404.html
You do not need to pull in any dependencies from precise, only acroread should be installed by this next set of steps:

3)
sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
sudo apt-get update
sudo apt-get install acroread
sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
sudo apt-get update

If other dependencies are required, to be safe, remove the precise repository and install them from the trusty repository
sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
sudo apt-get update
apt-get install [list of missing dependencies]
and go back to step 3)

Changed in overlay-scrollbar (Ubuntu):
importance: Low → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.17.1+16.04.20151117-0ubuntu2

---------------
overlay-scrollbar (0.2.17.1+16.04.20151117-0ubuntu2) zesty; urgency=medium

  * Mark overlay-scrollbar Multi-Arch: foreign. (LP: #1262022)

 -- Stefano Rivera <email address hidden> Sat, 24 Dec 2016 15:31:42 -0500

Changed in overlay-scrollbar (Ubuntu):
status: Triaged → Fix Released
Stefano Rivera (stefanor) wrote :

Uploaded to xenial and yakkety, pending SRU team approval.

description: updated

Hello Tomas, or anyone else affected,

Accepted overlay-scrollbar into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/overlay-scrollbar/0.2.17.1+16.04.20151117-0ubuntu1.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in overlay-scrollbar (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in overlay-scrollbar (Ubuntu Yakkety):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Tomas, or anyone else affected,

Accepted overlay-scrollbar into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/overlay-scrollbar/0.2.17.1+16.04.20151117-0ubuntu1.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in overlay-scrollbar (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in overlay-scrollbar (Ubuntu Xenial):
importance: Undecided → Medium
tags: added: packaging
Adrianna Pińska (confluence) wrote :

I have tested installation of the proposed overlay-scrollbar package together with both the amd64 and i386 versions of the overlay-scrollbar-gtk2 package, and was able to install both successfully.

Stefano Rivera (stefanor) wrote :

I also did quick installability tests in xenial and yakkety chroots.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for overlay-scrollbar has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.17.1+16.04.20151117-0ubuntu1.16.10.1

---------------
overlay-scrollbar (0.2.17.1+16.04.20151117-0ubuntu1.16.10.1) yakkety; urgency=medium

  * Mark overlay-scrollbar Multi-Arch: foreign. (LP: #1262022)

 -- Stefano Rivera <email address hidden> Sat, 24 Dec 2016 15:43:12 -0500

Changed in overlay-scrollbar (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.17.1+16.04.20151117-0ubuntu1.16.04.1

---------------
overlay-scrollbar (0.2.17.1+16.04.20151117-0ubuntu1.16.04.1) xenial; urgency=medium

  * Mark overlay-scrollbar Multi-Arch: foreign. (LP: #1262022)

 -- Stefano Rivera <email address hidden> Sat, 24 Dec 2016 15:43:12 -0500

Changed in overlay-scrollbar (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers