liboverlay-scrollbar hangs Wireshark

Bug #1248400 reported by olega8900 on 2013-11-06
154
This bug affects 39 people
Affects Status Importance Assigned to Milestone
overlay-scrollbar (Ubuntu)
Undecided
Unassigned
wireshark (Ubuntu)
Undecided
Unassigned

Bug Description

Wireshark hangs, emitting an infinite supply of error messages like the following:

(wireshark:12520): Gtk-CRITICAL **: gtk_range_get_adjustment: assertion 'GTK_IS_RANGE (range)' failed

(wireshark:12520): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkOrientable'

(wireshark:12520): Gtk-CRITICAL **: gtk_orientable_get_orientation: assertion 'GTK_IS_ORIENTABLE (orientable)' failed

(wireshark:12520): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkScrollbar'

(wireshark:12520): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkWidget'

(wireshark:12520): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GObject'

(wireshark:12520): GLib-GObject-CRITICAL **: g_object_get_qdata: assertion 'G_IS_OBJECT (object)' failed

(wireshark:12520): Gtk-CRITICAL **: gtk_widget_set_name: assertion 'GTK_IS_WIDGET (widget)' failed

(wireshark:12520): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GObject'

(wireshark:12520): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'G_IS_OBJECT (object)' failed

(wireshark:12520): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkRange'

----------------

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.10
DISTRIB_CODENAME=saucy
DISTRIB_DESCRIPTION="Ubuntu 13.10"

$ uname -a
Linux sjl 3.11.0-15-generic #25-Ubuntu SMP Thu Jan 30 17:25:07 UTC 2014 i686 i686 i686 GNU/Linux

$ dpkg-query -W wireshark
wireshark 1.10.2-1

$ wireshark --version
wireshark 1.10.2 (SVN Rev 51934 from /trunk-1.10)

Copyright 1998-2013 Gerald Combs <email address hidden> and contributors.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Compiled (32-bit) with GTK+ 3.8.4, with Cairo 1.12.16, with Pango 1.32.5, with
GLib 2.37.7, with libpcap, with libz 1.2.8, with POSIX capabilities (Linux),
without libnl, with SMI 0.4.8, with c-ares 1.10.0, with Lua 5.1, without Python,
with GnuTLS 2.12.23, with Gcrypt 1.5.0, with MIT Kerberos, with GeoIP, with
PortAudio V19-devel (built Oct 8 2012 16:25:16), with AirPcap.

Running on Linux 3.11.0-15-generic, with locale en_US.UTF-8, with libpcap
version 1.4.0, with libz 1.2.8, GnuTLS 2.12.23, Gcrypt 1.5.0, without AirPcap.

Built using gcc 4.8.1.

olega8900 (olega8900) on 2013-11-06
description: updated
Balint Reczey (rbalint) wrote :

This does not seem to be an official Ubuntu package of Wireshark.
Please report your problem to <email address hidden> or https://bugs.wireshark.org/bugzilla/

Changed in wireshark (Ubuntu):
status: New → Invalid
Titantux (israel-m-dj) wrote :

It is affecting me too, even when I've re-installed this software still the problem...

Titantux (israel-m-dj) wrote :

Found on this other bug report the workaround for this issue:

https://bugs.launchpad.net/ubuntu/+source/wireshark/+bug/1208583

And this is on wireshark bug page:

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8988

Within both it has the workaround, and more details about it.

-----Workaround-----
export LIBOVERLAY_SCROLLBAR=0
wireshark
---------------------------

Titantux (israel-m-dj) wrote :

With the previous workaround, did an improvement on as follow n my Ubuntu 13.10

---------------------------------------------------------------------
sudo mv /usr/bin/wireshark /usr/bin/wireshark.run
sudo echo "#/bin/bash" > /usr/bin/wireshark
sudo echo -e "export LIBOVERLAY_SCROLLBAR=0\nexec /usr/bin/wireshark.run" >> /usr/bin/wireshark
sudo chmod +x /usr/bin/wireshark
---------------------------------------------------------------------

Be aware, every time wireshark is updated you need to do this!!!

osmeest (osmeest) wrote :

Other workarounds:
- for command line calls, add an alias in .bashrc
        alias wireshark "LIBOVERLAY_SCROLLBAR=0 /usr/bin/wireshark"
- for Unity, edit /usr/share/applications/wireshark.desktop
    - change Exec line with
        Exec=env LIBOVERLAY_SCROLLBAR=0 wireshark %f
(I don't know how many upgrades this last one will survive but at least, it works for now...)

Søren Løvborg (kwi) on 2014-02-06
summary: - Wireshark crashed when i run him
+ Wireshark hangs, spewing Gtk errors

I don't know why the original reporter filed a bug against Ubuntu, when he or she is not using Ubuntu, but I've taken the liberty to re-open the bug since I can confirm the problem exists on Ubuntu 13.10, running under GNOME 3. (Wireshark starts normally, then hangs when switching to packet dump view.)

The above-mentioned LIBOVERLAY_SCROLLBAR work-around resolves the issue, so it might be related to #1208583, although I don't see an actual crash (only a hang), and it happens consistently for me. Although the "overlay-scrollbar" component appears implicated, I have not observed the problem in other applications than Wireshark.

description: updated
Changed in wireshark (Ubuntu):
status: Invalid → New
Evan Huus (eapache) wrote :

Wireshark uses some unusual GTK widgets and has never shown any of these symptoms on systems not using overlay scrollbars, so this is almost certainly a liboverlay-scrollbar bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wireshark (Ubuntu):
status: New → Confirmed

To get a solution that survies upgrades; copy the wireshark.desktop into your "user profile".

cp /usr/share/applications/wireshark.desktop ~/.local/share/applications/

+ change the Exec line to

Exec=env LIBOVERLAY_SCROLLBAR=0 wireshark %f

NoOp (glgxg) wrote :

Confirmed on 14.04 as well:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04 LTS"

$ wireshark --version
wireshark 1.10.6 (v1.10.6 from master-1.10)

Copyright 1998-2014 Gerald Combs <email address hidden> and contributors.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Compiled (64-bit) with GTK+ 3.10.7, with Cairo 1.13.1, with Pango 1.36.1, with
GLib 2.39.91, with libpcap, with libz 1.2.8, with POSIX capabilities (Linux),
without libnl, with SMI 0.4.8, with c-ares 1.10.0, with Lua 5.2, without Python,
with GnuTLS 2.12.23, with Gcrypt 1.5.3, with MIT Kerberos, with GeoIP, with
PortAudio V19-devel (built Feb 25 2014 21:09:53), with AirPcap.

Running on Linux 3.13.0-30-generic, with locale en_US.UTF-8, with libpcap
version 1.5.3, with libz 1.2.8, GnuTLS 2.12.23, Gcrypt 1.5.3, without AirPcap.
Pentium(R) Dual-Core CPU T4300 @ 2.10GHz

Built using gcc 4.8.2.

$ apt-cache policy wireshark
wireshark:
  Installed: 1.10.6-1
  Candidate: 1.10.6-1
  Version table:
 *** 1.10.6-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

(wireshark:5785): Gtk-CRITICAL **: gtk_orientable_get_orientation: assertion 'GTK_IS_ORIENTABLE (orientable)' failed

(wireshark:5785): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkScrollbar'

(wireshark:5785): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkWidget'

(wireshark:5785): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GObject'

Patryk (pmalek) wrote :

A work around provided by Thomas N (konstigt) works but this has to be somehow fixed to work without this.

NoOp (glgxg) wrote :

Doesn't work for me. I even tried adding to 'TryExec':

Icon=wireshark
# TryExec=wireshark
TryExec=env LIBOVERLAY_SCROLLBAR=0 wireshark
# Exec=wireshark %f
Exec=env LIBOVERLAY_SCROLLBAR=0 wireshark %f
Terminal=false

However, I have found that if I start with 'gksu wireshark' I no longer get the errors. I suspect the issue is permission related.
I have answered 'yes' to dpkg-reconfigure wireshark-common. And am a member of the wireshark group.

NoOp (glgxg) wrote :

This works, for me in the wireshark.desktop file:

Exec=/bin/sh -c "export LIBOVERLAY_SCROLLBAR=0\nexec && /usr/bin/wireshark"

No longer need to run 'gksu wireshark'.

max ulidtko (ulidtko) on 2014-08-15
summary: - Wireshark hangs, spewing Gtk errors
+ liboverlay_scrollbar hangs Wireshark
summary: - liboverlay_scrollbar hangs Wireshark
+ liboverlay-scrollbar hangs Wireshark
affects: wireshark (Ubuntu) → overlay-scrollbar (Ubuntu)
max ulidtko (ulidtko) wrote :

Not wireshark's bug, see workaround (export LIBOVERLAY_SCROLLBAR=0) and https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8988

Changed in wireshark (Ubuntu):
status: New → Invalid
max ulidtko (ulidtko) wrote :

Another related overlay-scrollbar bug (Wireshark crash) which has the same workaround: https://bugs.launchpad.net/overlay-scrollbar/+bug/1208583

Jan Rathmann (kaiserclaudius) wrote :

Still a problem in Trusty.

Paul Gear (paulgear) wrote :

This is still a problem in utopic as well. The workaround cuts down on the number of errors produced, and seems to prevent segfaulting in my limited testing, but Wireshark is still rather sluggish, so there could be other issues as well.

Roman Daszczyszak (romandas) wrote :

Comfirmed (again) on 14.04. The workaround seems to work for me for my regular user account. If I run wireshark as root (and you shouldn't; I just did it to test) the error does not seem to occur for me.

Confirmed also present in 15.04. Wireshark crashes when opening a file, but works fine when setting LIBOVERLAY_SCROLLBAR=0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.