Ubuntu

Removing overlay-scrollbar causes lots of noise

Reported by Stuart Bishop on 2013-02-27
196
This bug affects 44 people
Affects Status Importance Assigned to Milestone
overlay-scrollbar (Ubuntu)
Undecided
Unassigned

Bug Description

The overlay-scrollbar package can be removed to disable the modified scrollbar, reverting to classic scrollbars. If this is done, nearly every GTK application will emit the following error when started:

    Gtk-Message: Failed to load module "overlay-scrollbar"

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: overlay-scrollbar (not installed)
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Wed Feb 27 17:44:39 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-02-26 (1 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130225)
MarkForUpload: True
SourcePackage: overlay-scrollbar
UpgradeStatus: No upgrade log present (probably fresh install)

Stuart Bishop (stub) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in overlay-scrollbar (Ubuntu):
status: New → Confirmed
Szypa (p-szypowicz) wrote :

This Affects me also on Ubuntu 12.10
Kernel: 3.5.0-25-generic

aleandro (aleandrodasilva) wrote :

I have got this message trying to install RSSowl. Installation cannot go further. Ubuntu 13.04 beta kernel 3.8.0-13-generic

Uni (yubo) wrote :

I installed gnome-shell and uninstalled this overlay-scrollbar:
sudo apt-get remove overlay-scrollbar

Since, I have this error when running gedit (and other apps).

Also affects me on "3.5.0-27-generic #46-Ubuntu SMP", very annoying the overlay bars play badly with a lot of apps as they overlay the side and prevent increasing the horizontal size of a window when a visual element that has a slider abuts the right hand side of the window hence to make it work properly the designer needs to leave space so defeats the idea.

Matt Hurd (matthurd) wrote :

Also 12.10 on 3.5.0-27-generic #46-Ubuntu SMP Mon Mar 25 19:58:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Printer install failing. Trying with hplip latest from sourceforge fails with:

RE-STARTING HP_SYSTRAY
----------------------

HP Linux Imaging and Printing System (ver. 3.13.4)
System Tray Status Service ver. 2.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Gtk-Message: Failed to load module "overlay-scrollbar"
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK

Uni (yubo) wrote :

Here is a gdm/session.log a litle after booting.

Lots of this << Failed to load module "overlay-scrollbar" >>

Confirmed also with acroread 9.5.4 under Ubuntu 13.04 x64

Constantine (iamvfx) wrote :

Same here. As Uni, I installed gnome shell and removed overlay-scrollbar, now message happens all the time. Ubuntu 13.04 x64

Stuart Bishop (stub) wrote :

The workaround in 13.04 is to install the overlay-scrollbar package, but to run the following command from the command line to disable the unwanted behavior (for the current user):

gsettings set com.canonical.desktop.interface scrollbar-mode normal

I'm leaving this bug open as I have no idea how to disable it globally on the system, affecting guest logins for instance.

Tuomas Lähteenmäki (lahtis) wrote :

i have a similar problem. Latest Steam not run client. -> Gtk-Message: Failed to load module "overlay-scrollbar"

using Ubuntu 12.10 64 bit.

Megakill (k-6) wrote :

Same problem with Steam client. 13.04 64bit

boom1x (alexey-k85) on 2013-09-16
Changed in overlay-scrollbar (Ubuntu):
assignee: nobody → boom1x (alexey-k85)
assignee: boom1x (alexey-k85) → nobody
boom1x (alexey-k85) wrote :

After last update of basic componts, steam writes it me too:

Running Steam on ubuntu 13.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1379035603_client)
Installing breakpad exception handler for appid(steam)/version(1379035603_client)
Installing breakpad exception handler for appid(steam)/version(1379035603_client)
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 7629 with name 0eBlobRegistryMutex_A9250FB26F6CC54F098F975BFB47D7B7
removing stale semaphore last operated on by process 7629 with name 0eBlobRegistrySignal_A9250FB26F6CC54F098F975BFB47D7B7
removing stale semaphore last operated on by process 7629 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 7629 with name 0eSteamEngineLock
Gtk-Message: Failed to load module "overlay-scrollbar" /// HERE !!!!!!!!!!!!
Installing breakpad exception handler for appid(steam)/version(1379035603_client)
[0916/200729:WARNING:proxy_service.cc(958)] PAC support disabled because there is no system implementation

anisios (anisios) wrote :

I had the same problem with Steam after last update Gtk-Message: Failed to load module "overlay-scrollbar".
 I did search and found this hint: clear steam cache previous installation by on terminal

rm -Rf ~/.steam/steam/appcache

and install again by steam .deb from steam website.

I hope help to solve the Steam problem by "overlay-scrollbar"

Megakill (k-6) wrote :

That worked. Thank you!

Michael Dedek (mikedragon) wrote :

Hi! I had this problem. I've fixed it by removing (or moving)
~> sudo mv /etc/X11/Xsession.d/81overlay-scrollbar .
It may be under a different name, but ending with overlay-scrollbar
Now I can launch any GTK apps without producing redundant output.

Xavi Carol (xcarol) wrote :

It affects me on Ubuntu 13.10

Elemer (elemer82) wrote :

It is still in Ubuntu 14.04 64bit if I try to run skype from terminal for example.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers