GtkScrolledWindow is mapped but visible child GtkScrollbar is not mapped

Bug #1086494 reported by Pojar Gheorghe–Ioan on 2012-12-04
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
GTK+
Unknown
Medium
overlay-scrollbar
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned
overlay-scrollbar (Ubuntu)
Low
Lars Karlitski

Bug Description

Ubuntu 13.04 (Raring Ringtail) Unity:

I don't now if this is GtkScrolledWindow or overlay scrollbars bug.

I got these warning in Totem Movie Player.

Test case:

Open totem -> Fill with items playlist panel from right of player until scrollbar show-up -> scroll to bottom of panel -> import more playlist items from playlist file, and this warning come out:

(totem:4060): Gtk-WARNING **: GtkScrolledWindow 0xb81ef2b0 is mapped but visible child GtkScrollbar 0xb82bc2a8 is not mapped

This bug appears to Rhythmbox Music Player if import playlist items from file:

(rhythmbox:4149): Gtk-WARNING **: RBPropertyView 0x9ee8000 is mapped but visible child GtkScrollbar 0xa08fe90 is not mapped

description: updated
description: updated
Changed in overlay-scrollbar (Ubuntu):
status: New → Confirmed
affects: overlay-scrollbar (Ubuntu) → totem (Ubuntu)
affects: totem (Ubuntu) → overlay-scrollbar (Ubuntu)
no longer affects: totem
no longer affects: rhythmbox
no longer affects: totem
no longer affects: overlay-scrollbar
Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Changed in totem (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what version of Ubuntu do you use and what desktop environment?

Changed in ubuntu:
status: New → Confirmed
affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Low
status: New → Incomplete
affects: ubuntu → gtk+3.0 (Ubuntu)

Ubuntu 13.04 (Raring Ringtail) Unity

description: updated
description: updated

might be involved GtkFileChooserDialog which is open when import playlist file.
This bug does not exist in precise.

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in gtk+3.0 (Ubuntu):
status: Incomplete → Triaged
Changed in gtk:
status: New → Invalid
no longer affects: gtk
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
tags: added: raring
iMac (imac-netstatz) wrote :

I see this with evolution and overlay scrollbars disabled.

I disabled overlay scrollbars with:

$gsettings set com.canonical.desktop.interface scrollbar-mode normal

(evolution:13228): Gtk-WARNING **: GtkScrolledWindow 0x7f8fa3f4faa0 is mapped but visible child GtkScrollbar 0x7f8fa409c540 is not mapped

My versions from current Ubuntu 12.10 (with proposed, updates sources enabled)
ii evolution 3.6.2-0ubuntu0.1
ii libgtk-3-0:amd64 3.6.0-0ubuntu3.2

I tested totem and rhythmbox with overlay scrollbars removed (not only disabled) and this warning message is gone. Seems to be bug from gtk in combination with overlay scrollbars.
Therefore mark the bug for totem and rhythmbox invalid.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid
Changed in totem (Ubuntu):
status: Confirmed → Invalid
Adolfo Jayme (fitojb) on 2013-04-29
no longer affects: rhythmbox (Ubuntu)
no longer affects: totem (Ubuntu)
description: updated
Sebastien Bacher (seb128) wrote :
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Invalid
Changed in overlay-scrollbar:
status: New → In Progress
Changed in overlay-scrollbar (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gtk:
status: New → Unknown

I get this after launching GEdit on Ubuntu 13.10 64-bit.
Note: I've installed gir1.2-gtksource-3.0

Amos (a-storkey) wrote :

I too get this (multiple times) after launching Gedit on Ubunto 13.10 64 bit.

Sebastien Bacher (seb128) wrote :

overlay-scrollbar (0.2.16+r359+14.04.20131129-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * Create native windows for the scrollbar overlay and tail As of gtk
    3.10, non-native windows are clipped to their widget's allocation.
    The hijacked scrollbar is given a 0-width or height when horizontal)
    allocation to make it disappear. Using native windows makes sure
    that the overlay and tail are drawn regardless.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 381

Changed in overlay-scrollbar (Ubuntu):
status: Triaged → Fix Released
NoOp (glgxg) wrote :

This bug does not appear to be fixed:

$ apt-cache policy overlay-scrollbar
overlay-scrollbar:
  Installed: 0.2.16+r359+14.04.20131129-0ubuntu1
  Candidate: 0.2.16+r359+14.04.20131129-0ubuntu1
  Version table:
 *** 0.2.16+r359+14.04.20131129-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

(evolution:6492): Gtk-WARNING **: GtkScrolledWindow 0x7f26d000da40 is mapped but visible child GtkScrollbar 0x7f273e4be7f0 is not mapped

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.