Out-of-Order does not load in Saucy

Bug #1251613 reported by Volodya
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
out-of-order (Ubuntu)
Undecided
Unassigned

Bug Description

After i have upgraded to Sausy (by reinstalling the system, not by upgrade process) Out-of-Order does not start any longer. The error is as follows:

$ out-of-order
SLUDGE v2.2.0 fatal error!
Initialisation error! Something went wrong before we even got started!

Error building "scale" shader program!

Revision history for this message
Volodya (volodya) wrote :

Running with debug output:

$ out-of-order -d 1
/usr/games/out-of-order: 2: test: x-d: unexpected operator
*** Engine compiled May 24 2012 at 15:22:20.
Video mode 600 450 set successfully.
Compiling vertex shader...

Compiling fragment shader...

Shaders compiled.
Shader program linked.
SLUDGE v2.2.0 fatal error!
Initialisation error! Something went wrong before we even got started!

Error building "scale" shader program!

Revision history for this message
Tobias Hansen (tobias-han) wrote :

Hi,

what is your graphics card and driver? SLUDGE does not work on graphics cards which do not support OpenGL 2.0.

Revision history for this message
Volodya (volodya) wrote :

It's a netbook computer. Packard Bell Dot S, i'm unsure about their graphics card, but it's one of those buillt in ones.

Not an old machine at all, if it is considered 'old' already, something is wrong.

Revision history for this message
Volodya (volodya) wrote :

This is what i get under Graphics in System details: Intel® IGD x86/MMX/SSE2

Revision history for this message
Tobias Hansen (tobias-han) wrote :

That's still not the graphics card. Please post the output of

lspci -nnk | grep -i "VGA\|3D\|Display" -A2

Revision history for this message
Tobias Hansen (tobias-han) wrote :

You can see here that some IGD don't have OpenGL 2.0 support depending on which Atom processor you have:
http://www.intel.com/content/dam/www/public/us/en/documents/fact-sheets/features-v10-4.pdf

Replace 'old' with 'crappy' above. Don't want to offend you but you can't call that a proper graphics card on which you can expect all games to work.

Revision history for this message
Volodya (volodya) wrote :
Revision history for this message
Volodya (volodya) wrote :

> on which you can expect all games to work

Of course, but the game worked, and then stopped. And it's not really a game that is graphically intensive enough to warrant computer upgrade. I somehow doubt that 3D graphics were added to this game since 2012.

Revision history for this message
Tobias Hansen (tobias-han) wrote :

SLUDGE 2.1 without OpenGL 2 works with graphical glitches like you described in the other bug report. SLUDGE 2.2 relies even more on shaders so we decided it does not make sense to let the engine start at all when no OpenGL 2 is around.

Revision history for this message
Volodya (volodya) wrote : Re: [Bug 1251613] Re: Out-of-Order does not load after upgrading to Sausy

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 11/21/2013 03:37 AM, BigMc wrote:
> SLUDGE 2.1 without OpenGL 2 works with graphical glitches like you
> described in the other bug report. SLUDGE 2.2 relies even more on shaders
> so we decided it does not make sense to let the engine start at all when no
> OpenGL 2 is around.

Ok, thanks for your answer. I will downgrade to SLUDGE 2.1.

- --
http://freedom.libsyn.com/ Echo of Freedom, Radical Podcast

 "None of us are free until all of us are free." ~ Mihail Bakunin
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQEcBAEBAgAGBQJSjY60AAoJENW9VI+wmYasFG4H/1kzr/egyIU4A+P5UuVv62vK
QZdlI9RUAIciFQI4lZMtqgj/IKZA4eeGBmZcA4SUH7QgmdJzp+f5HTmUJl71e97r
NqE6SiiEMd8NLXX2WQhk22cfHHiU2WFs7ur+EWeebjMDmDmAXnZoLPTfcJ/PBN2T
1XSkRYwNJNagZTxTqfPUGCxUFpKQHkgNXGbnAZPkUnWos41U9JukCRDNbUFdvJqa
TA/b/WDoZIOG+zRe0mHwHnkWS0rQuZGnlfAsoNlgUuMDJkeGov/R5vXGyuQEYC1h
ankdlbd/LayGOC3sv2aogpVDGKx/RfP9x6W+1CvjtelAQrVW5OV8j+KGoQVEHhg=
=Mf6o
-----END PGP SIGNATURE-----

Ken Sharp (kennybobs)
tags: added: saucy
summary: - Out-of-Order does not load after upgrading to Sausy
+ Out-of-Order does not load in Saucy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers