pakcage libossp-uuid16 1.6.2-1 failed to install/upgrade: trying to overwrite '/usr/lib/libossp-uuid++.so.16.0.22', which is also in package libossp-uuid15 0:1.6.2-0ubuntu1

Bug #538284 reported by Philip Muškovac on 2010-03-12
46
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ossp-uuid (Ubuntu)
Medium
Colin Watson
Lucid
Medium
Colin Watson
postgresql-8.4 (Ubuntu)
High
Martin Pitt
Lucid
High
Martin Pitt

Bug Description

(Reading database ... 630283 files and directories currently installed.)
Unpacking libossp-uuid16 (from .../libossp-uuid16_1.6.2-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libossp-uuid16_1.6.2-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libossp-uuid++.so.16.0.22', which is also in package libossp-uuid15 0:1.6.2-0ubuntu1
Errors were encountered while processing:
 /var/cache/apt/archives/libossp-uuid16_1.6.2-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of libossp-uuid-perl:
 libossp-uuid-perl depends on libossp-uuid16; however:
  Package libossp-uuid16 is not installed.
dpkg: error processing libossp-uuid-perl (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libossp-uuid-perl

Philip Muškovac (yofel) on 2010-03-12
tags: added: lucid
ThomasLee82 (kamiyasha) wrote :

Also ran into that same problem. Uninstalled libossp-uuid15, and cannot get either libossp-uuid15 or libossp-uuid16 to install. Attempting to do 'apt-get -f install' does not resolve this issue.

Marco Nenciarini (mnencia) wrote :

As a temporary workaround you can run

dpkg -i --force-overwrite /var/cache/apt/archives/libossp-uuid16_1.6.2-1_amd64.deb

The correct fix is to add

Replaces: libossp-uuid15 (>= 1.6.0~)

to libossp-uuid16's section of control file. This is because #362982

Changed in ossp-uuid (Ubuntu):
status: New → Confirmed
Philip Muškovac (yofel) wrote :

Thanks Marco.

Changed in ossp-uuid (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Colin Watson (cjwatson) wrote :

Thanks! I've uploaded a package with this change, which subject to release manager approval will hopefully get into beta-1.

The need for this in the first place was clearly an Ubuntu mistake, and so we could simply drop this change after Lucid. We'll need to rebuild postgresql-contrib-8.4 to make sure that we can get rid of the broken libossp-uuid15 from the archive, though.

Changed in ossp-uuid (Ubuntu Lucid):
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-10.04-beta-1
Martin Pitt (pitti) wrote :

To solve that properly, we also need a no-change upload of postgresql-8.4, which currently still depends on 15.

Changed in postgresql-8.4 (Ubuntu Lucid):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-1
status: New → In Progress
Martin Pitt (pitti) on 2010-03-13
Changed in postgresql-8.4 (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ossp-uuid - 1.6.2-1ubuntu1

---------------
ossp-uuid (1.6.2-1ubuntu1) lucid; urgency=low

  * Replace libossp-uuid15 (>= 1.6.0~), due to LP #362982 (LP: #538284).
 -- Colin Watson <email address hidden> Sat, 13 Mar 2010 11:45:49 +0000

Changed in ossp-uuid (Ubuntu Lucid):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.4 - 8.4.2-2build1

---------------
postgresql-8.4 (8.4.2-2build1) lucid; urgency=low

  * Rebuild against libossp-uuid16. (Closes: #570108, LP: #538284)
 -- Martin Pitt <email address hidden> Sat, 13 Mar 2010 12:57:58 +0100

Changed in postgresql-8.4 (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers