libossp-uuid15 contains library libossp-uuid16.so

Bug #362982 reported by Victor Gijsbers on 2009-04-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ossp-uuid (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libossp-uuid15

I do not know whether this is a real bug or not, but I'll report in in any case, since I know at least one program (not in the ubuntu repository) that stopped working due to this change.

In intrepid, the package libossp-uuid15 installs the library /usr/lib/libossp-uuid.so.15 (and its companion files).

In jaunty, the package libossp-uuid15 installs the library /usr/lib/libossp-uuid.so.16 (and its companion files).

This means that programs that depend on libossp-uuid15 and call on libossp-uuid.so.15 will stop working. Also, it seems very strange to me that the package name still has "15" in it, while the actual library is updated to "16"?

Changed in ossp-uuid (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers