Ubuntu

package oss4-dkms 4.2-build2002-2 failed to install/upgrade: oss4 kernel module failed to build

Reported by Ulf Hagström on 2010-02-10
384
This bug affects 82 people
Affects Status Importance Assigned to Milestone
oss4 (Ubuntu)
Undecided
Unassigned

Bug Description

Problem installing..

ProblemType: Package
Architecture: i386
DKMSBuildLog:
 DKMS make.log for oss4-4.2-build2002 for kernel 2.6.32-12-generic (i686)
 ons 10 feb 2010 01.27.22 CET
Date: Wed Feb 10 01:27:38 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: oss4 kernel module failed to build
InstallationMedia: Xubuntu 9.10 "Karmic Koala" - Release i386 (20091028.3)
NonfreeKernelModules: wl
Package: oss4-dkms 4.2-build2002-2
PackageArchitecture: all
PackageVersion: 4.2-build2002-2
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: oss4
Title: package oss4-dkms 4.2-build2002-2 failed to install/upgrade: oss4 kernel module failed to build
Uname: Linux 2.6.32-12-generic i686

Related branches

Ulf Hagström (toocer) wrote :
tags: added: oss4
Jason Scurtu (solard3ity) wrote :

It dont Build because some paths are not Ubuntu compatible, they are more Debian orientated..
I dont know how to use quilt for making patches, but I managed to get OSS4 working by editing two files..
In the /debian/dkms I edited the dkms.conf.template file on line 100 to this:

MAKE[0]="cp /usr/src/linux-headers-`uname -r`/include/linux/limits.h ${dkms_tree}/${PACKAGE_NAME}/${PACKAGE_VERSION}/build/core && \

Also in /debian/m-a/ I edited the rules file on line 51 to this:

cp /usr/src/linux-headers-`uname -r`/include/linux/limits.h $(PWD)/core

after that it compiles and works, but I think we should also change the default paths that debian uses, like /var to the OSS4 defaults like /usr/lib/oss4 otherwise flashplugin-nonfree-extrasound wont work out of the box..

I uploaded the changed files, please if someone would make the propper pachtes .......

Changed in oss4 (Ubuntu):
status: New → Confirmed

using the headers from linux-headers-(kernel_version), hopefully the right way. quilt/cdbs switches to a src directory so i'm not sure how or if quilt can be used for a debian/ patch. i'll attach this debdiff anyway which works but someone might want to take an additional look at this

oss4 (4.2-build2002-2ubuntu1) lucid; urgency=low

  * debian/dkms/dkms.conf.template:
    debian/m-a/rules:
    - give correct path to limits.h for dkms. Thanks to Jason Scurfu
      (LP: #519577)

Test Build: https://launchpad.net/~sevenmachines/+archive/release+1

levien (levien) wrote :

Good work, the patched package from the PPA seems to install without problems now on my system (Lucid Lynx amd64). It works for the most part, however it did indeed seemed to cause the Flash-plugin to hang on sound output (as was already mentioned by Jason). This would probably need to be fixed for the package to be really usable...

Adam Guthrie (therigu) wrote :

oss4-dkms from ppa://sevenmachines/releases+1 installs successfully for me

Michał Gołębiowski (mgol) wrote :

Where is this oss4-dkms package in proposed PPA repo? I added it and still nothing there:

$ apt-cache policy oss4-dkms
oss4-dkms:
  Installed: (none)
  Candidate: 4.2-build2002-2
  Version table:
     4.2-build2002-2 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/universe Packages

Michał Gołębiowski (mgol) wrote :

I'm sorry, now I see it. I don't know what happened, I'm convinced I did upgrade before checking...

Javier P.L. (chilicuil) wrote :

I've looked at the source and it looks like the /var/lib/oss4 path and the OSSVARDIR var were introduced in the debian/patches/cmd.patch and debian/patches/os_cmd.patch patches. Also extra files were edited:

$ find |xargs grep var

./debian/patches/cmd.patch:+#define DEFAULT_OSSLIBDIR "/var/lib/oss4"
./debian/patches/cmd.patch:+/var/lib/oss4/legacy_devices
./debian/patches/cmd.patch:+ if (stat ("/var/lib/oss4", &st) != -1) /* Use /var/lib/oss4/mixer.save */
./debian/patches/cmd.patch:+ strcpy (name, "/var/lib/oss4/mixer.save");
./debian/patches/cmd.patch:+ strcpy (ossetcdir, "/var/lib/oss4");
./debian/patches/cmd.patch:+settings into /var/lib/oss4/mixer.save or $OSSVARDIR/mixer.save file.
./debian/patches/cmd.patch:+OSSVARDIR is decided by reading /etc/oss.conf, and defaults to /var/lib/oss4.
./debian/patches/cmd.patch:+/var/lib/oss4/mixer.save
./debian/patches/cmd.patch:+/var/lib/oss4/dspdevs.map
./debian/patches/cmd.patch:+/var/lib/oss4/applist.conf
./debian/control: This package contains various utilities for configuring
./debian/oss4-base.init:OSSVARDIR=/var/lib/oss4
./debian/m-a/rules:# load generic variable handling
./debian/m-a/rules:# following variables:
./debian/oss.conf:OSSVARDIR=/var/lib/oss4
./debian/oss4-base.dirs:var/lib/oss

Fixing the path /var/lib/oss4 to its original value, /usr/lib/oss4 as pointed out by Jason could make the trick, I've tried to change it by myself but unfortunately I couldn't rebuild the package after making the changes. Maybe someone who has previous experience with quilt/cdbs could fix it.

I am a newbie so I need extra explanation. I am not sure what to do with the files shown here. Oh, and there is no /debian dir on my system. I am using ubuntu 10.04 LTS.

My sound card is not being detected.

shua (shualloret) wrote :

Temporary fix until someone fixes the package: if you just make a symbolic link to folder /usr/src/linux-headers-(whatever number you have; make sure it's the one without -generic) inside /lib/modules/(whatever number)-generic/ and name it 'source' it will install, and you'll get your sound back, and you can remove it once your done.

It may seem obvious to some people, but I was googling around for an hour before I just decided to do that.

david bacon (tocino) wrote :

can anybody tell me in language i can understand how to fix this god-damn problem. Ubuntu becomes worse than useless at these times...

levien (levien) wrote :

Currently the best way around this is not to use the oss4-dkms package from the repository, but to install OSS4 using one of the other methods (ie. install the prebuilt package from the opensound.com website or compile and install it yourself). I've put some instructions on my site: http://levien.zonnetjes.net/?q=oss4

-L.

Changed in oss4 (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
status: Confirmed → In Progress
Stefano Rivera (stefanor) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I've uploaded a corrected package the latest development version of Ubuntu - Maverick Meerkat.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in oss4 (Ubuntu):
assignee: Stefano Rivera (stefanor) → nobody
status: In Progress → Fix Committed
Stefano Rivera (stefanor) wrote :

Due to my mistake, bug wasn't automatically closed.

Changed in oss4 (Ubuntu):
status: Fix Committed → Fix Released
Changed in oss4 (Ubuntu):
status: Fix Released → Invalid
Michał Gołębiowski (mgol) wrote :

Invalid? You're kidding, right?

Changed in oss4 (Ubuntu):
status: Invalid → Fix Released

Can't fix the problem, sorry.

Jason Scurtu (solard3ity) wrote :

For all that wanted Lucid packages! Here is the Fix!!
You can now install them threw my PPA @ https://launchpad.net/~solard3ity/+archive/oss4/

levien (levien) wrote :

Nice work, Jason! However, on amd64 the problems with the Flash-plugin still persist. Is there a reason why the libflashsupport-oss4 package was only built for i386?

Aaron Bouzek (nakarti) wrote :

ln -s /usr/src/linux-headers-2.6.32-24 /lib/modules/2.6.32-24-generic/source
apt-get -f install

Of course you also need build-essential for it to work.
Seemed to work for me, for the guy who asked for an 'I'm a dummy, gimme the command' answer.

Aaron Bouzek (nakarti) wrote :

Which sound fails after suspending. But Pulse is such a pile of garbage too!

levien (levien) wrote :

I've just tested Jason's packages on an i386 system as well. On amd64 there is no libflashsupport-oss4 package, and the Flash-plugin just hangs on sound-output. On i386 I installed the libflashsupport-oss4 package, and the Flash-plugin does not hang, but there is no sound from Flash. I tried the solutions suggested in http://ubuntuforums.org/showthread.php?t=873749 without avail. I haven't tried compiling my own version of libflashsupport yet...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers