oss-compat uninstallable: depends on non-existent package kmod

Bug #992991 reported by Marius Lund on 2012-05-02
134
This bug affects 29 people
Affects Status Importance Assigned to Milestone
oss-compat (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

apt-get install oss-compat
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 oss-compat : Depends: kmod but it is not installable
E: Unable to correct problems, you have held broken packages.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: oss-compat 1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Wed May 2 04:07:10 2012
Dependencies:

EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120421)
PackageArchitecture: all
SourcePackage: oss-compat
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Marius Lund (trench-r) wrote :
Jean-Baptiste Lallement (jibel) wrote :

This was caused by the following change in quantal
oss-compat (2) unstable; urgency=low
[...]
  * Do not depend on module-init-tools
    * On linux it's transitional for kmod anyway

summary: - broken packages in quantal
+ oss-compat uninstallable: depends on non-existent package kmod
Changed in oss-compat (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: unmet-deps
tags: added: unmetdeps
removed: unmet-deps
Anton Anikin (anton-anikin) wrote :

same problem for me

GonzaloPanizo (gonzalo-panizo) wrote :

Me too! What can we do?

philinux (philcb) wrote :

I just uninstalled it. No errors. It's not really useful anyway.

https://bugs.launchpad.net/ubuntu/+source/oss-compat/+bug/983707

Yotam Benshalom (benshalom) wrote :

It did help in running some legacy applications. I hope this gets fixed.

Micah Gersten (micahg) on 2012-09-06
Changed in oss-compat (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Stephen Kitt (steve-sk2) wrote :

The attached patch fixes this for Quantal. I won't be able to get it through Debian given the Wheezy freeze; could someone build (and upload) a fixed package for Quantal? I'll sync up once everything unfreezes...

Thanks!

The attachment "Patch adding an alternative dependency on module-init-tools" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oss-compat - 2ubuntu1

---------------
oss-compat (2ubuntu1) quantal; urgency=low

  * Add an alternative dependency on module-init-tools (LP: #992991).
    Thanks to Stephen Kitt.
 -- Ilya Barygin <email address hidden> Fri, 14 Sep 2012 21:05:01 +0400

Changed in oss-compat (Ubuntu Quantal):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments