[QEMU] When loading partman step, GNOME Shell vanishes, no more decoration and installer UI frozen

Bug #1796037 reported by Didier Roche on 2018-10-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
osinfo-db (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

After investigation, the issue is that we only get 1Gb allocated in GNOME Boxes for new ubuntu installations, which is starving and getting OOM.
The requirements has been bumped with pre-seeded snaps in ubuntu 16.04, 18.04 and 18.10 and 2Gb is needed to end the installation process.

We weren't impacted previously as shipping an old osinfo-db version,
hich didn't have the distribution specific requirements, and thus,
allbacked to GNOME Boxes default which is 2Gb.

Bumping the requirement was discussed and acked on #ubuntu-desktop IRC channel: https://irclogs.ubuntu.com/2018/10/08/%23ubuntu-desktop.html#t09:51

Upstream PR: https://gitlab.com/didrocks/osinfo-db/merge_requests/1

------

Following "Install (entire disk) in Ubuntu Desktop amd64 in Cosmic Daily" test case, on 20181003.1 desktop live image.

Using Qemu (host is an up to date cosmic) and starting in ubiquity-only mode:
- when clicking on continue on the <…> step, the UI is freezing for a minute, then GNOME Shell vanishes, no more decoration to ubiquity windows, black background (reproduced twice). See attached picture.
- I was still able to proceed thus, but on the "who are you" page, no more control, the cursor is changing on text element to show the text cursor, but no caret.
- no crash found in /var/crash, but the GNOME Shell process is marked as defunct.

Can anyone reproduce it? I was able to reliably reproduce it on 3 consecutive boots here.

Note: there is also the fact that if I set focus to another window than qemu and going back to the qemu window, no way to type/click in ubiquity or live session. This may have an impact above on the cursor issue. Nevertheless, I have took great care to not change focus in the above use case.

Didier Roche (didrocks) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1796037

tags: added: iso-testing
Iain Lane (laney) wrote :

I just tried this and my VM froze completely, so seems something bad indeed.

Is this an OOM situation? Can you share the journal / dmesg and /var/log/installer/debug?

Jean-Baptiste Lallement (jibel) wrote :

how much memory did you allocate to the VM?

Iain Lane (laney) wrote :

This seems to be a "low resource" problem relating to snapd, assuming I'm seeing the same thing as didrocks. If I "systemctl mask snapd.seeded.service snapd.socket snapd.service" from e.g. a rescue shell, the installation proceeds normally.

That's with 1G of ram. If I use 4G then it works fine with snapd enabled.

Is this known (jibel?)?

Iain Lane (laney) wrote :

I was suspecting snapd because I saw "loop0", "unsquashfs" and "snapd" spiking in top just before the VM went away, btw.

Jean-Baptiste Lallement (jibel) wrote :

Yes, this is known, Ubuntu Desktop requires at least 1.5G of memory to be installed in a VM. There used to be a resource checking page in the installer that has been removed a while ago.

Iain Lane (laney) wrote :

nod - didrocks, is this your problem too?

Didier Roche (didrocks) wrote :

Ah, interesting. I just checked cosmic GNOME Boxes configuration for an ubuntu iso, and indeed, it configures 1GB of RAM. I think it used to configure more? Maybe something we should change in GNOME Boxes upstream so that people testing ubuntu aren't imapcted by it?

I don't know how Iain saw loop0/unsquahfs/snapd spiking in top as my VM is exhausting its memory so quickly that I can't even do a vt switch.

However, I confirming that masking the snapd related services works.
I suggest there are 2 things to do:
* Having ubiquity warning if memory is under the memory spec (as the page was removed, I think it would dbe something for the new installer)
* Fixing GNOME Boxes default configuration for ubuntu to use 1.5/2GB (?) by default.

Iain Lane (laney) wrote :

I installed openssh-server from a systemd.rescue.target (systemd.unit=rescue.target boot parameter), so that I could SSH in before it dies and watch top/dmesg/etc

Didier Roche (didrocks) on 2018-10-08
affects: ubiquity (Ubuntu) → osinfo-db (Ubuntu)
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package osinfo-db - 0.20180929-1ubuntu1

---------------
osinfo-db (0.20180929-1ubuntu1) cosmic; urgency=medium

  * debian/patches/git_dccf78b83578d368fd0241cbcfc8f5c2742012fb.patch:
    (cherry-picked upstream)
    ubuntu: Bump minimal ram requirement to 2GiB. (LP: #1796037)

 -- Didier Roche <email address hidden> Thu, 11 Oct 2018 10:08:06 +0200

Changed in osinfo-db (Ubuntu):
status: New → Fix Released

FYI - I think we also need to SRU this back to Bionic.
I didn't want to dup these things as they are not 100% the same, but FYI bug 1770206 would make me consider picking the version you pushed to Cosmic into Bionic.

Didier Roche (didrocks) wrote :

There isn't a bionic.xml file in bionic (I think the release has been cut a little bit earlier), and so, any unknown vm -> 2GB of RAM, which is why we didn't see the issue there.
However, there is no hurt in having this backported if anyone has time to do it :)

Hello Didier, or anyone else affected,

Accepted osinfo-db into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/osinfo-db/0.20180929-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in osinfo-db (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

16.4 and >=18.04 changed from
<ram>2147483648</ram>
to
<ram>2147483648</ram>
as intended.

Checked on 0.20180929-1ubuntu0.1 from proposed.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package osinfo-db - 0.20180929-1ubuntu0.1

---------------
osinfo-db (0.20180929-1ubuntu0.1) bionic; urgency=medium

  * SRU the more recent version to Bionic to have the newer
    release definitions available, most importantly Ubuntu
    18.04 itself as users would expect that (LP: #1770206).

osinfo-db (0.20180929-1ubuntu1) cosmic; urgency=medium

  * debian/patches/git_dccf78b83578d368fd0241cbcfc8f5c2742012fb.patch:
    (cherry-picked upstream)
    ubuntu: Bump minimal ram requirement to 2GiB. (LP: #1796037)

osinfo-db (0.20180929-1) unstable; urgency=medium

  * [478429c] New upstream version 0.20180929
    (Closes: #908973)

osinfo-db (0.20180917-1) unstable; urgency=medium

  * [13ecc03] New upstream version 0.20180917
    (Closes: #908983)
  * [4f9f362] d/control: Bump standards version to 4.2.1
  * [862e376] d/rules: Honor DEB_BUILD_OPTIONS=nocheck
  * [bf69c25] d/copyright: Avoid duplicate license section
  * [63f7c72] Switch to debhelper compat level 11
  * [c0f0f40] Don't install extra license file to /u/s/osinfo

osinfo-db (0.20180628-1) unstable; urgency=medium

  [ Guido Günther ]
  * [25145bf] Point VCS-* URLs to salsa
  * [1bcb0b3] gbp: use commit hashes in changelog
  * [fd17d3c] New upstream version 0.20180628
    (Closes: #902538)

  [ Helmut Grohne ]
  * [34d4878] Mark osinfo-db Multi-Arch: foreign (Closes: #893429)

 -- Christian Ehrhardt <email address hidden> Fri, 16 Nov 2018 07:24:05 +0100

Changed in osinfo-db (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for osinfo-db has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers