update-grub does not create btrfs menuentry in grub.cfg

Bug #887836 reported by martin suc on 2011-11-09
72
This bug affects 20 people
Affects Status Importance Assigned to Milestone
os-prober
New
Unknown
os-prober (Ubuntu)
High
Unassigned

Bug Description

Hi,

I have noticed that update-grub have never been generating menuentry in grub.cfg for btrfs ubuntu oneiric 64bit instance. This happens when I run update-grub on another ubuntu instance , does not matter if ext4 or btrfs.
(I have to manually change 40_custom for new installed kernels )
Could you confirm if it is bug or I messed up something ?

thank you,
regards,
Martin
---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
NonfreeKernelModules: fglrx
Package: os-prober 1.49ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-17.30~pre201203010400-generic 3.0.22
Tags: oneiric
Uname: Linux 3.0.0-17-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (141 days ago)
UserGroups: adm admin audio backup cdrom clamav dialout disk games kvm libuuid lpadmin plugdev proxy pulse pulse-access sambashare syslog users utmp vboxusers video www-data

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in os-prober (Ubuntu):
status: New → Confirmed
Alexander Fougner (fougner) wrote :

Hi Martin, could you please run the following in a terminal?
apport-collect 887836

Also, I'm running update-grub in oneiric and it doesn't recognize my btrfs partition with 12.04 dev on it.

apport information

tags: added: apport-collected oneiric
description: updated
martin suc (martin-suc) wrote :

Hi,

Would it be possible to post some info about it ?
if you use gpt partition ?
structure of OS instance which is NOT going to include in grub.conf by update-grub:
bios_grub /dev/??? and partition type ?
boot /dev/??? and partition type ?
root / /dev/??? and partition type (btrfrs or ext4) ?

thank you,
regards,
Martin

Gary M (garym) wrote :

Please set this status back to "Confirmed" after martin's questions in comment #4 have been answered.

Changed in os-prober (Ubuntu):
status: Confirmed → Incomplete
bitinerant (bitinerant) wrote :

I believe this bug explains why I can't boot from sda1. I installed a 'normal' Ubuntu 12.04 with Btrfs on sda1 and it worked fine. I let the installer create the partition table; GParted says it is 'msdos'. I then installed a crypt-luks Ubuntu 12.04 with /boot on sda2 (Ext2), encrypted swap on sda3, and root on sda4 (Btrfs). The 'update-grub' command finds my encrypted installation and it works fine, but it never finds the original sda1 Btrfs partition and I haven't been able to boot from it since I installed the second Ubuntu.

Output of 'fdisk -l' and 'update-grub' is attached. Martin, is there anything else you'd like to know about an effected system? Is there a work-around?

martin suc (martin-suc) wrote :

Hi, I did not find work-around.

Launchpad Janitor (janitor) wrote :

[Expired for os-prober (Ubuntu) because there has been no activity for 60 days.]

Changed in os-prober (Ubuntu):
status: Incomplete → Expired
martin suc (martin-suc) wrote :

Hm, this problem is still in even after many new grub packages have been released/installed within and after quantal distribution.
Does anybody know some grub tweaking to do it ?

Changed in os-prober (Ubuntu):
status: Expired → Confirmed
Tamas Papp (tompos) wrote :

Atill exists on Raring.

martin suc (martin-suc) wrote :

indeed, raring has the same problem even new version of grub has been installed.
notice:
update-grub is generating menuentry for raid0 btrfs .

martin suc (martin-suc) wrote :

Well , It is 2015 year (ubuntu 15.04 , 15.10). btrfs version 4.1.2 and update-grub still does not detecting btrfs partition.

tags: added: vivid wily
Changed in os-prober (Ubuntu):
importance: Undecided → High
no longer affects: os-prober

Please:

1. Report this bug to <https://www.debian.org/Bugs/>.
2. Paste the new report link here.
3. Set this bug status back to "confirmed".

Thank you.

Changed in os-prober (Ubuntu):
status: Confirmed → Incomplete
tags: added: asked-to-upstream

Probably already covered by this Debian bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=688336

Changed in os-prober:
status: New → Confirmed

@ José Luis Bolos

Thank you 😉

Changed in os-prober:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in os-prober (Ubuntu):
status: Incomplete → Triaged
Changed in os-prober:
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.