Moving filesystems around leaves prober dazed and confused

Bug #459503 reported by John Gill on 2009-10-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
os-prober (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: os-prober

For reasons best known to myself I created a new partition for my Ubuntu 9.04 install and copied the files over.

I then ran 'sudo upgrade-grub' and it appeared to run fine.

I then had to fix up fstab, to enter the new UUID of my new partition.

A reboot nearly worked.

The problem I ran into is that the probing is finding two UUID's for the OS I moved: the new id, which it uses in the search stanza and the old, pre-move id which it uses in the linux stanza.

If I manually edit /etc/grub/grub.conf (yes, I know I'm not supposed to do this) to put the new ID then I can boot without problems.

See below for the sort of output I get in /etc/grub/grub.cfg:

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Ubuntu 9.04, kernel 2.6.28-16-generic (on /dev/sda5)" {
        insmod ext2
        set root=(hd0,5)
        search --no-floppy --fs-uuid --set b4c78e55-75b6-48b8-b956-798be6d2c586
        linux /boot/vmlinuz-2.6.28-16-generic root=UUID=81f04dcd-4933-475b-b0f2-ec23352da1ff ro quiet splash
        initrd /boot/initrd.img-2.6.28-16-generic
}

I'm at a bit of a loss where it is getting the old UUID from.

ProblemType: Bug
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: os-prober None [modified: /var/lib/dpkg/info/os-prober.list]
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: os-prober
Uname: Linux 2.6.28-16-generic i686
UnreportableReason: This is not a genuine Ubuntu package

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers