Ubuntu

Windows not detected if /windows is called something else

Reported by Paul Dufresne on 2005-10-03
6
Affects Status Importance Assigned to Milestone
os-prober (Ubuntu)
Medium
Unassigned
Declined for Maverick by Sebastien Bacher

Bug Description

I installed Kubuntu 5.10-preview-i386 on a new EXT3
2.2 GB partition, leaving Windows98 SE (FAT32) 2.5 GB
partition there. At the end of the installation, the grub menu
have only entries for Kubuntu and memtest.
With sudo cfdisk, I see my FAT32 partition is still there.

Paul Dufresne (paulduf) wrote :

Some more infos:

paul@ArcturusK:~$ cat /proc/partitions
major minor #blocks name

   3 0 6297480 hda
   3 1 2562336 hda1
   3 2 1 hda2
   3 5 2144646 hda5
   3 6 192748 hda6
 253 0 2562336 dm-0
 253 1 2144646 dm-1
 253 2 192748 dm-2
paul@ArcturusK:~$

 cfdisk 2.12p

                           Unité de disque: /dev/hda
                      Taille: 6448619520 octets, 6448 Mo
              Têtes: 255 Secteurs par piste: 63 Cylindres: 784

    Nom Fanions Part Type Type SF [�iq.]
Taille (Mo
)------------------------------------------------------------------------------
    hda1 Amorce Primaire W95 FAT32
2623,87
    hda5 Logique Linux ext3 [/]
2196,15
    hda6 Logique Linux swap / Solaris
197,41
                            Pri/Log Espace libre
1431,20

paul@ArcturusK:~$ sudo mount /dev/hda1 /mnt
paul@ArcturusK:~$ ls /mnt
autoexec.001 command.com msdos.--- scandisk.log videorom.bin
AutoExec.bat config.sys msdos.sys setuplog.old virtpart.dat
avg7db_f.dat detlog.txt netlog.txt setuplog.txt windows
avg7qt.dat frunlog.txt polows setupxlg.txt WUTemp
bootlog.prv io.sys Program Files suhdlog.dat
bootlog.txt Mes documents recycled system.1st

There was a strange bug at the end of editing manually the partition
about a file like stufftv~1.log files having some size, but having
only su much clusters, I decided to continue anyway.

Paul Dufresne (paulduf) wrote :

Oh, also, when I last closed Windows, it was hang on Windows closing
screen, so I did disconnect and reconnected the computer. So, sure
enough, the FAT32 partition was not cleanly unmounted.
But I would expect it to be added to the menu anyway.

Anyway, I am not so sure of what I should expect now.
I tried this:
paul@ArcturusK:~$ sudo mv /boot/grub/menu.lst /boot/grub/menu.lst.old
paul@ArcturusK:~$ sudo update-grub
Searching for GRUB installation directory ... found: /boot/grub .
Testing for an existing GRUB menu.list file...

Could not find /boot/grub/menu.lst file. Would you
like /boot/grub/menu.lst generated for you? (y/N) y
Searching for splash image... none found, skipping...
Found kernel: /boot/vmlinuz-2.6.12-8-386
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

paul@ArcturusK:~$

Is update-grub supposed to see a Windows partition and automagically
add an option to boot it?

Colin Watson (cjwatson) wrote :

os-prober might not have been able to mount the Windows partition in order to
figure out what was inside it. Could you please attach /var/log/installer/syslog
so that I can investigate that possibility? Thanks.

Paul Dufresne (paulduf) wrote :

Created an attachment (id=4300)
/var/log/installer/syslog to help find the bug

Colin Watson (cjwatson) wrote :

OK, all looks fine so far. Could you tell me if /windows/win.com exists on your
Windows partition?

Paul Dufresne (paulduf) wrote :

(In reply to comment #5)
> OK, all looks fine so far. Could you tell me if /windows/win.com
> exists on your Windows partition?

:-) No, it does not exist because I choosed to call my windows
directory "polows" during Windows installation to make it slightly harder
for virus and trojans to modify my windows programs.

===
paul@ArcturusK:/spoon/system/source$ sudo mount /dev/hda1 /mnt
Password:
...
paul@ArcturusK:/spoon/system/source$ ls /mnt/polows/win*.com
/mnt/polows/win.com
===

Looks like we found the problem. But does it really
need to go so far to add an entry to boot Windows in grub?
I was expecting that finding a FAT32 partition could be enough.

Dennis Kaarsemaker (dennis) wrote :

Not all fat32 partitions have a windows install on them...

Dennis Kaarsemaker (dennis) wrote :

Rejecting according to comments (no windows/win.com exists, and polows cannot be guessed)

Changed in os-prober:
status: Needs Info → Rejected
Colin Watson (cjwatson) wrote :

Dennis, could you please check with me before rejecting my bugs? There's clearly another way to detect this, as Windows manages to boot, and it presumably doesn't guess "polows"; we just don't know exactly how to detect this yet.

Changed in os-prober:
status: Rejected → Confirmed

Windows 98 places several files in c:\ with which you can detect
windows. I'll poke at my mother in laws laptop to find out more.

Colin Watson (cjwatson) on 2007-04-19
Changed in os-prober:
assignee: kamion → nobody
Adam Niedling (krychek) wrote :

5.10 is not supported anymore. Is this still an issue or can this bug be closed?

Colin Watson (cjwatson) wrote :

Bugs do not become invalid just because the release in which they were originally found goes out of support. os-prober is still in current versions of Ubuntu and still has this bug.

Changed in os-prober:
status: Confirmed → Triaged
Felix Zielcke (fzielcke) wrote :

IIRC the windows path for the 9x/ME versions was stored in some c:\*.sys plain text file.
I think it was named io.sys.
This bug report is now very old, but does someone still have access to some 9x/ME system?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.