Ubuntu

ubiquity does not detect Windows 8(UEFI)

Reported by Nobuto MURATA on 2012-11-15
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
os-prober (Debian)
Fix Released
Unknown
os-prober (Ubuntu)
Undecided
Unassigned

Bug Description

Ubiquity does not detect Windows 8.
It shows the message:
 "This computer currently has no detected operating systems."

Windows 8 was installed with secure boot on.

$ sudo parted /dev/sda print
Model: ATA HITACHI HTS54503 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 316MB 315MB ntfs Basic data partition hidden, diag
 2 316MB 420MB 105MB fat32 EFI system partition boot
 3 420MB 555MB 134MB Microsoft reserved partition msftres
 4 555MB 320GB 320GB ntfs Basic data partition

$ sudo os-prober
<no output>

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.16
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CasperVersion: 1.328
Date: Thu Nov 15 07:16:55 2012
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi.signed file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Nobuto MURATA (nobuto) wrote :
Richard Ayres (rayres) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

This particular bug has already been reported, originally against Ubuntu 11.10, and is a duplicate of bug #978028, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report.

Nobuto MURATA (nobuto) wrote :

I have un-duplicated from Bug #978028 because:

Bug #978028 has been marked as Fix Released with os-prober 1.51ubuntu2.
https://bugs.launchpad.net/ubuntu/+source/os-prober/+bug/978028/comments/4

But I had the newer version os-prober 1.56ubuntu1.
https://launchpadlibrarian.net/123074471/Dependencies.txt

Nobuto MURATA (nobuto) wrote :

terminal output with set -x in /usr/lib/os-probes/mounted/20microsoft.

Note:
/dev/sda5:Ubuntu 12.10 (12.10):Ubuntu:linux is installed after facing this issue with manual partitioning.

affects: ubiquity (Ubuntu) → os-prober (Ubuntu)
Nobuto MURATA (nobuto) wrote :

Here is the list of files in the efi partition.
efi partition is mounted by:
 $ sudo mount -o ro /dev/sda2 /mnt

Richard Ayres (rayres) wrote :

After discussion, this is a feature request, not a new bug, duplicate or regression. Please see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=687921 for further information.

This report will be marked as a wishlist item in due course. Thanks.

Nobuto MURATA (nobuto) wrote :

@Richard,

Thank you for the information.

After searching around, this is related to:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=687921 (from you)
http://lists.debian.org/debian-boot/2012/10/msg00185.html (proposed patch for this issue)
Bug #807801 (might be a downstream bug of debian 687921)

For the record, the easiest workaround to me was launching ubiquity with WINOSDATA=true (any non-empty value).
 $ WINOSDATA=true ubiquity
That will detect my /dev/sda4 as Windows 8 (data) and enable the option "Install Ubuntu alongside Windows 8 (data)".

$ sudo WINOSDATA=true os-prober
/dev/sda4:Windows 8 (data):Windows:chain

summary: - ubiquity does not detect Windows 8
+ ubiquity does not detect Windows 8(UEFI)
Changed in os-prober (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in os-prober (Ubuntu):
status: New → Confirmed
Changed in os-prober (Debian):
status: New → Fix Released
sumith (autosumith) on 2013-09-16
Changed in os-prober (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.