Fedora17 and ArchLinux dont appear in GRUB menu

Bug #1038093 reported by YannUbuntu on 2012-08-17
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
os-prober (Debian)
Fix Released
Unknown
os-prober (Ubuntu)
Undecided
Dimitri John Ledkov
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

The os-prober of Ubuntu 12.04 and 12.10 does not detect Fedora17/ArchLinux when Fedora17/ArchLinux's partition is unmounted (which is frequent). Consequence: Fedora17/ArchLinux does not appear in Ubuntu's GRUB menu.

This bug did not exist with the os-prober of 11.10, so it is a regression of os-prober.

The os-prober of 12.04 correctly detects Fedora16 but not Fedora17.

WORKAROUND: mount the Fedora17/ArchLinux partition before doing update-grub in Ubuntu.

Bug confirmed by several French users with Fedora17 and Ubuntu12.04 /12.10 (http://forum.ubuntu-fr.org/viewtopic.php?pid=9695571#p9695571 and http://forums.fedora-fr.org/viewtopic.php?id=57393 ).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in os-prober (Ubuntu):
status: New → Confirmed
Changed in os-prober (Debian):
status: Unknown → New

Apparently:
- 12.04's os-prober detects Fedora16 but not Fedora17
- 11.04's os-prober detects Fedora17

So the bug seems to be a regression of os-prober.

summary: - Fedora does not appear in Ubuntu's GRUB menu
+ Fedora17 does not appear in 12.04's GRUB menu
fantab (fantab) wrote :

I dual-boot Ubuntu and Arch both 64bit. I use Ubuntu-GRUB to boot into either Systems. Since Arch is a rolling distro it is always there and I clean install whenever there is new Ubuntu to install. Update-Grub always finds Arch, no issues until I installed BODHI along with other two.

During Bodhi installation I got the prompt that I need to UNMOUNT the partitions. Now none of my partitions were mounted, as far as I can tell. I ignored the Warning and continued with Bodhi installation.

After the install I went back to Ubuntu to update grub... and guess what? The Grub Update did not find Arch install. It found Bodhi alright. Then later I had to MOUNT Arch partition and run update-grub, only then did the GRUB found Arch Install.

I am not a technichal guy so I have described my issue with GRUB as a layman. If launchpad needs any data from my Desktop I am willing to help.

I hope this gives some pointers towards resolving the Grub issue.

YannUbuntu (yannubuntu) wrote :

@all: according to another ubuntu-fr member (http://forum.ubuntu-fr.org/viewtopic.php?pid=10586931#p10586931):
- the bug is not present with 12.04 liveCD, it is a regression which appeared from 12.04 updates (I don't know if before or after 12.04.1)
- the bug concerns Fedora17 and OpenSuse 12.1

@JBS: please
(1) boot on a 12.04 (not 12.04.1) liveCD , choose "Try Ubuntu", open a terminal, type "sudo os-prober", and indicate if Arch appears.
(2) Then mount Arch partition, retype "sudo os-prober" and tell if Arch appears.
(3) Then redo (1) and (2) with a 12.04.1 liveCD and tell the results please.

fantab (fantab) wrote :

I don't have 12.04.1 LiveCD... But following is from 12.04_amd64 LiveCD.

(1) Without ARCH partition mounted:
ubuntu@ubuntu:~$ sudo os-prober
/dev/sda1:Ubuntu quantal (development branch) (12.10):Ubuntu:linux

(2) With ARCH partition mounted:
ubuntu@ubuntu:~$ sudo os-prober
/dev/sda1:Ubuntu quantal (development branch) (12.10):Ubuntu:linux
/dev/sda3::Arch:linux

The problem also persists with 12.10_amd64 Beta1

YannUbuntu (yannubuntu) on 2012-09-17
summary: - Fedora17 does not appear in 12.04's GRUB menu
+ Fedora17 and ArchLinux dont appear in 12.04's GRUB menu
summary: - Fedora17 and ArchLinux dont appear in 12.04's GRUB menu
+ [regression] Fedora17 and ArchLinux dont appear in GRUB menu
description: updated
tags: added: precise quantal

Confirmed in 12.10 beta1.

Linux 3.5.0-13-generic #14-Ubuntu SMP Wed Aug 29 16:48:44 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

fantab (fantab) wrote :

Updated to 3.5.0-15-generic

Arch is still not being detected without being mounted.

YannUbuntu (yannubuntu) wrote :
YannUbuntu (yannubuntu) wrote :

Bug is still present in Quantal: the os-prober of Ubuntu 12.10 does not detect Fedora17 when Fedora17 is not mounted.

description: updated
description: updated
Changed in os-prober (Debian):
status: New → Fix Committed
Changed in os-prober (Debian):
status: Fix Committed → Fix Released

I don't know in what sense the "Fix [is] Released".

I just updated my 12.04 and 12.10 systems and, after the updates, they still exhibited the bug.

Please explain.

YannUbuntu (yannubuntu) wrote :

@hugh-mimosa: please look at the top of this page, the bug is fixed in the generic (Debian) 'os-prober', but is not included yet in Ubuntu.

Changed in os-prober (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Dmitrijs Ledkovs (xnox)
Dimitri John Ledkov (xnox) wrote :

Please note, there needs to be a ubiquity upload _after_ os-prober bug is fixed to include the updated os-prober on the desktop installer CDs.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package os-prober - 1.57ubuntu1

---------------
os-prober (1.57ubuntu1) raring; urgency=low

  * Resynchronise with Debian (LP: #1038093). Remaining changes:
    - Mount btrfs subvolume @ when present to access a btrfs formatted
      rootfs.
    - When called with WINOSDATA, return the list of Windows partitions
      containing the system instead of only listing these containing the
      bootrecord.

os-prober (1.57) unstable; urgency=low

  [ Christian Perrier ]
  * Deal with grub-probe exiting with non zero status on some
    devices, which in turns can stuck update-grub
    Closes: #680084

  [ Joey Hess ]
  * Fix detection of Fedora and other distros that moved /lib into /usr
    and left behind a symlink. Grub's filesystem code does not support
    symlinks. Closes: #685159 Thanks Andreas Bombe for the patch.
 -- Dmitrijs Ledkovs <email address hidden> Tue, 05 Feb 2013 11:25:43 +0100

Changed in os-prober (Ubuntu):
status: In Progress → Fix Released
Changed in os-prober (Ubuntu Precise):
status: New → Confirmed
Changed in os-prober (Ubuntu Quantal):
status: New → Confirmed
Changed in os-prober (Ubuntu Precise):
importance: Undecided → Medium
Changed in os-prober (Ubuntu Quantal):
importance: Undecided → Medium
Jeffrey Walton (noloader) wrote :

Nine months later, and this is still an open issue :(

Could anyone point out how to remove Ubunut's OS Prober and flavor of GRUB? I recently re-installer Fedora 18, and I don't want to los it again. I also need to ensure earlier versions of Ubuntu (for example 11.10) don't fiddle with things either (I still have to support 11.10 in the field for others, so I need it for testing).

Everything I've found online is related to removing GRUB entirely in favor of Windows. This is not my situation - I need Fedora's Prober and Grub because it works with all OSes.

Thanks in advance for help on the Ubuntu Prober/GRUB removal.

@Jefrey Walton
I agree: it is amazing that this is not fixed. Especially when the status is "Fix Released".

But there is an easy manual work-around: before running update-grub, mount the non-Ubuntu Linux boot partitions. Then os-prober finds them!

Jeffrey Walton (noloader) wrote :

@D. Hugh Redelmeier (hugh-mimosa)
Yeah, I can get the OS Prober to recognize the Fedora volumes by first mounting. However, the GRUB menu will not display them as an option during boot.

I've tried the following, and they do not produce expected results (i.e., no menu entry for Fedora during boot):

    # First mount Fedora volume
    $ sudo update-grub

and

    $ sudo grub-mkconfig
    $ sudo grub-install -o /dev/sda

I'm working from memory because I don't want to boot into Ubuntu right now. I've tried the commands above on Ubuntu with grub and grub2 (don't recall which grub works for which command).

Apparently I'm too dumb to figure out how to fix things in Fedora given the exiting documentation. There's nothing special about me, so I imagine there are other folks experiencing the same pain.

All of this could be avoided if (1) Ubuntu fixed the problem; (2) GRUB allowed me to boot to a device (i.e., simply specify /dev/sda6); or (3) or Fedora provided a boot repair disk. As far as I know, we have none of them.

I've literally wasted hours on this. I'm ready to cut my losses and simply let Fedora manage GRUB and booting.

Jeffrey Walton (noloader) wrote :

This might also be useful for the Debian and Ubuntu folks: http://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#Kernel_updates. It discusses the changes made at Fedora 17 and how to specify a boot image.
Unfortunately, I lack the necessary prerequisite knowledge to use it to fix these systems.

Dimitri John Ledkov (xnox) wrote :

This bug is fix release in Raring Ringtail, the SRU to quantal & precise did not happen yet.
To stop using OS_PROBER during Grub generation, one can specify:
GRUB_DISABLE_OS_PROBER=true
in /etc/default/grub
After that one would need to add fedora/arch boot stanzas to:
/etc/grub.d/40_custom
be careful not to delete comments from that file, but append to it.

Regards,

Dmitrijs.

summary: - [regression] Fedora17 and ArchLinux dont appear in GRUB menu
+ Fedora17 and ArchLinux dont appear in GRUB menu
fantab (fantab) wrote :

I am using ubuntu 13.04 and I can confirm that this issue is fixed in 1304.

Earlier I had to mount my ARCH partition before updating grub. But sine past one week os-prober detects arch without its partition being mounted.

Still broken in 12.04 LTS. Surely it is time to support Long Term Support.

Jeffrey Walton (noloader) wrote :

> Still broken in 12.04 LTS. Surely it is time to support Long Term Support.
Its kind of ironic isn't it? The humor was not lost on me either.

LTS seems to have some problems. Even security software remains broken (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=634930).

Andreas Moog (ampelbein) wrote :

Dmitrijs, are you still working on backporting the fix to 12.04 and 12.10?

Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in os-prober (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.