os-prober fails to detect a linux installation, no option in grub2 boot menu

Bug #1026774 reported by keepitsimpleengr on 2012-07-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
os-prober (Ubuntu)
Undecided
Unassigned

Bug Description

This has worked previously.

root@64bitWS:~# os-prober
/dev/sdb1:Windows NT/2000/XP (loader):Windows:chain
/dev/sdc1:Ubuntu 10.04.4 LTS (10.04):Ubuntu:linux
/dev/sdd1:Windows Vista (loader):Windows1:chain

misses /dev/sda2 arch linux

boot-info at http://paste.ubuntu.com/1099113/ and at http://paste.ubuntu.com/1100049/

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: os-prober 1.51ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Thu Jul 19 12:32:04 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: os-prober
UpgradeStatus: Upgraded to precise on 2012-06-15 (34 days ago)

I ran os-prober in boot-repair on 10.4 LTS (1.38/Lucid) on the same computer, and it properly identified all linux system installed on the computer.

 Boot-info at ttp://paste.ubuntu.com/1101977/

Since grub2 in 10.04 LTS cannot use UUIDs, and my hardware BIOS mixes up hard-drive order from boot to boot, I found a workaround by installing grub2 in the third Linux system, Archlinux.

Notes on hardware: The disk that the undetected Linux distribution is on is connected to the system using a SATA-PCI interface card.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in os-prober (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers