orchestra squid config should not deny apt packages

Bug #927750 reported by Scott Moser on 2012-02-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
orchestra (Ubuntu)
Undecided
Andres Rodriguez

Bug Description

current orchestra squid configuration has:
 | acl PACKAGES url_regex \/Packages(|\.bz2|\.gz)$
 | cache deny PACKAGES
 | acl SOURCES url_regex \/Sources(|\.bz2|\.gz)$
 | cache deny SOURCES
 | acl RELEASE url_regex \/Release(|\.gpg)$
 | cache deny RELEASE

That means that those files are *never* cached, meaning each client request guarantees a non-local network operation.

Currently, amd64 'apt-get update' would report:
  Fetched 22.2 MB in 35s (618 kB/s)
So, thats 22MB that will never be cached.

The suggested fix is to use 'refresh_pattern' instead of deny, with a basic diff then looking something like:

--- squid.conf.old 2012-02-06 17:27:15.630780844 +0000
+++ squid.conf 2012-02-06 17:27:23.990783380 +0000
@@ -38,16 +38,12 @@
 icp_port 0
 hierarchy_stoplist cgi-bin ?
 access_log /var/log/squid3/access.log squid
+refresh_pattern \/(Packages|Sources)(|\.bz2|\.gz)$ 0 0% 0
+refresh_pattern \/Release(|\.gpg)$ 0 0% 0
 refresh_pattern ^ftp: 1440 20% 10080
 refresh_pattern ^gopher: 1440 0% 1440
 refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
 refresh_pattern . 0 20% 4320
-acl PACKAGES url_regex \/Packages(|\.bz2|\.gz)$
-cache deny PACKAGES
-acl SOURCES url_regex \/Sources(|\.bz2|\.gz)$
-cache deny SOURCES
-acl RELEASE url_regex \/Release(|\.gpg)$
-cache deny RELEASE
 hosts_file /etc/hosts
 coredump_dir /var/spool/squid3
 maximum_object_size 750 MB

for reference, conversation on this topic was in IRC at http://irclogs.ubuntu.com/2012/02/06/%23ubuntu-server.html#t16:57

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in orchestra (Ubuntu):
status: New → Confirmed
Changed in orchestra (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Andres Rodriguez (andreserl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package orchestra - 2.28-0ubuntu1

---------------
orchestra (2.28-0ubuntu1) precise; urgency=low

  [ Marc Cluet ]
  * debian/control:
    - Remove monitoring package
    - Remove explicit byobu declaration

  [ Andres Rodriguez ]
  * Create 'default' system for enlistment (LP: #898840)
  * Do not deny apt Packages. Thanks to Scott Moser (LP: #927750)
  * debian/ubuntu-orchestra-provisioning-server.postrm: Remove not only on
    'purge' but in 'remove' to not break apache. (LP: #929368)
 -- Andres Rodriguez <email address hidden> Fri, 10 Feb 2012 11:37:00 -0500

Changed in orchestra (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers