gnome-settings-daemon crashed with SIGSEGV in exit()

Bug #788710 reported by Eliah Kagan on 2011-05-26
662
This bug affects 118 people
Affects Status Importance Assigned to Milestone
orbit2 (Ubuntu)
High
Rodrigo Moya
Oneiric
High
Rodrigo Moya

Bug Description

Binary package hint: gnome-settings-daemon

I booted from the Oneiric i386 20110526.1 daily-live CD and manually selected "Try Ubuntu without installing" in the non-graphical boot menu. The "Oh no! Something has gone wrong" screen came up. But that's not the bug I'm reporting right now.

When I clicked Log Out, I saw an Apport window which appeared to be for reporting this bug. But that window was automatically closed then the logout operation completed. I then logged back in, selecting an Ubuntu Classic (no effects) session, and another Apport window came up for this crash. I used that to report this bug. I don't have any other details, except that the crash seems to recur periodically; while composing this, it has occurred again.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.0.2-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.39-3.9-generic 2.6.39
Uname: Linux 2.6.39-3-generic i686
Architecture: i386
Date: Thu May 26 16:12:05 2011
Disassembly: => 0x32aca70: Cannot access memory at address 0x32aca70
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110526.1)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x32aca70: Cannot access memory at address 0x32aca70
 PC (0x032aca70) not located in a known VMA region (needed executable region)!
SegvReason: executing unknown VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? ()
 ?? () from /lib/i386-linux-gnu/libc.so.6
 exit () from /lib/i386-linux-gnu/libc.so.6
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 _start ()
Title: gnome-settings-daemon crashed with SIGSEGV in exit()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-power-manager:3524): Gtk-WARNING **: Failed to load type module: (null)
 (gnome-power-manager:3524): Gtk-WARNING **: Failed to load type module: (null)
 (gnome-power-manager:3524): Gtk-WARNING **: Failed to load type module: (null)
 (gnome-control-center:3703): Gtk-WARNING **: Failed to load type module: (null)
 (gnome-control-center:3703): Gtk-WARNING **: Failed to load type module: (null)

visibility: private → public

I am able to reproduce this bug on a different machine with the Oneiric amd64 20110526.1 daily-live CD.

tags: added: amd64

Also, on that amd64 machine, the crash occurs repeatedly as well, and it occurs in a Unity session as well as in a classic session. (The i386 test machine on which I reported this originally doesn't support Unity, so I wasn't able to test that.)

Jean-Baptiste Lallement (jibel) wrote :

confirmed by duplicate.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
tags: added: iso-testing
sam tygier (samtygier) wrote :

probably worth mentioning Bug #788714 here, as the 2 crashes seem to occur together.

To clarify https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/788710/comments/3, I was able to produce this in a 3d unity session, as well as in a unity-2d session. (And now with the Oneiric i386 Alpha 1 CD, I've seen it in 3d unity on a separate i386 machine as well.)

Dmitry Shachnev (mitya57) wrote :

This bug was reported more than week ago, but the stack trace is not available yet. Is there something wrong with Apport Retracing service?
Also, I confirm that it occurs together with bug 788714.

this bug occured for me on a fully installe dversion of 11.10 (rather than a live CD)

Unity 3d straight after logging in

Dmitry Shachnev (mitya57) wrote :

 Bug 788714 is fixed, is anybody still getting this?

gnome-settings-daemon 3.0.2-1ubuntu2 was released on 7 June 2011, the same day as gnome-user-share 3.0.0-2ubuntu1 (which fixed bug 788714). Since then, I have not gotten the crash in this bug, but I have gotten a crash on logout which reminds me of it. I've reported this as bug 795392; there are more details there.

Thanks for following up. I'm closing this report due to your last comment.
Don't hesitate to submit any new bug.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Hans Joachim Desserud (hjd) wrote :

I'm fairly sure I experienced this with gnome-settings-daemon 3.0.2-1ubuntu2 on a daily build from today. The stack trace looks identical. See bug 795596 more details.

Dmitry Shachnev (mitya57) wrote :

@Hans:
Yes, the trace is identical, so marked as a duplicate. I experienced this crash too yesterday, but I'm not sure I had all the latest updates.
Someone, please revert the status to Confirmed.

Changed back to Confirmed based on information from Hans Joachim Desserud (duplicate bug bug 795596).

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Confirmed

With gnome-settings-daemon 3.0.2-1ubuntu3 (and possibly earlier versions, I haven't tried), this bug appears to be reliably producible by launching a second concurrent instance of gnome-settings-daemon (i.e., running it when it's already running). I have gotten this to happen on two separate, similarly configured Oneiric i386 systems in unity-2d sessions by running "gnome-settings-daemon" in Terminal windows. While gnome-settings-daemon needn't support multiple instances, a second instance of gnome-settings-daemon should gracefully exit--it should not segfault (and in any case, there may well be other situations where this crash occurs).

On one of the Oneiric i386 systems, I was able to produce a better stack trace. I have reported that crash as duplicate bug 796497.

Are others able to reliably reproduce this crash the same way? If so, we can edit the bug's description to include it as an easy way to make the crash happen.

ek@Nyaa:~$ gnome-settings-daemon

** (gnome-settings-daemon:1932): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:1932): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

** (gnome-settings-daemon:1932): WARNING **: Name taken or bus went away - shutting down
Segmentation fault (core dumped)

Rodrigo Moya (rodrigo-moya) wrote :

If you can easily reproduce, can you please run:

$ ls /usr/lib/gnome-settings-daemon-3.0/

the crash is at an atexit() handler indeed, but gnome-settings-daemon doesn't install any, so I guess it might be an external g-s-d plugin or one of the libraries used in g-s-d. So, once we get the output of that 'ls' command, we'll see what -debug package to install, to get better information of what exit handler is making g-s-d crash

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
status: Confirmed → In Progress

$ ls -l /usr/lib/gnome-settings-daemon-3.0/
total 760
-rw-r--r-- 1 root root 7641 2011-06-10 16:55 a11y-keyboard.gnome-settings-plugin
-rw-r--r-- 1 root root 4728 2011-06-10 16:55 a11y-settings.gnome-settings-plugin
-rw-r--r-- 1 root root 3959 2011-06-10 16:55 automount.gnome-settings-plugin
-rw-r--r-- 1 root root 4957 2011-06-10 16:55 background.gnome-settings-plugin
-rw-r--r-- 1 root root 5456 2011-06-10 16:55 clipboard.gnome-settings-plugin
-rw-r--r-- 1 root root 169 2011-06-10 16:55 gconf.gnome-settings-plugin
drwxr-xr-x 2 root root 4096 2011-05-30 14:20 gtk-modules
-rw-r--r-- 1 root root 264 2011-06-10 16:55 housekeeping.gnome-settings-plugin
-rw-r--r-- 1 root root 5498 2011-06-10 16:55 keybindings.gnome-settings-plugin
-rw-r--r-- 1 root root 5361 2011-06-10 16:55 keyboard.gnome-settings-plugin
-rw-r--r-- 1 root root 34516 2011-06-10 16:55 liba11y-keyboard.so
-rw-r--r-- 1 root root 9584 2011-06-10 16:55 liba11y-settings.so
-rw-r--r-- 1 root root 38844 2011-06-10 16:55 libautomount.so
-rw-r--r-- 1 root root 17888 2011-06-10 16:55 libbackground.so
-rw-r--r-- 1 root root 21980 2011-06-10 16:55 libclipboard.so
-rw-r--r-- 1 root root 13784 2011-06-10 16:55 libgconf.so
-rw-r--r-- 1 root root 39012 2011-06-10 16:55 libhousekeeping.so
-rw-r--r-- 1 root root 51272 2011-06-10 16:55 libkeybindings.so
-rw-r--r-- 1 root root 34688 2011-06-10 16:55 libkeyboard.so
-rw-r--r-- 1 root root 146824 2011-06-10 16:55 libmedia-keys.so
-rw-r--r-- 1 root root 55340 2011-06-10 16:55 libmouse.so
-rw-r--r-- 1 root root 22100 2011-06-10 16:55 libprint-notifications.so
-rw-r--r-- 1 root root 13800 2011-06-10 16:55 libsound.so
-rw-r--r-- 1 root root 47032 2011-06-10 16:55 libwacom.so
-rw-r--r-- 1 root root 34608 2011-06-10 16:55 libxrandr.so
-rw-r--r-- 1 root root 39216 2011-06-10 16:55 libxsettings.so
-rw-r--r-- 1 root root 5830 2011-06-10 16:55 media-keys.gnome-settings-plugin
-rw-r--r-- 1 root root 4391 2011-06-10 16:55 mouse.gnome-settings-plugin
-rw-r--r-- 1 root root 3976 2011-06-10 16:55 print-notifications.gnome-settings-plugin
-rw-r--r-- 1 root root 605 2011-06-10 16:55 sound.gnome-settings-plugin
-rw-r--r-- 1 root root 140 2011-06-10 16:55 wacom.gnome-settings-plugin
-rw-r--r-- 1 root root 6700 2011-06-10 16:55 xrandr.gnome-settings-plugin
-rw-r--r-- 1 root root 5605 2011-06-10 16:55 xsettings.gnome-settings-plugin

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

I have the same entries, except for the gtk-modules directory (so that directory and its contents aren't what's producing this bug).

StacktraceTop:
 ?? ()
 __run_exit_handlers (status=0, listp=0xe86324, run_list_atexit=true) at exit.c:72
 __on_exit (func=0, arg=0xbfa35c84) at on_exit.c:28
 __libc_start_main (main=0x804a8a0 <main+64>, argc=1, ubp_av=0xbfa35c84, init=0x804d680 <__libc_csu_init+64>, fini=0x804d6e0 <_fini+4>, rtld_fini=0x4c5a50, stack_end=0xbfa35c7c) at libc-start.c:232
 __do_global_dtors_aux ()

tags: removed: need-i386-retrace
Timo Witte (spacefish) wrote :

i have the same Problem,
i changed settings in dconf: /org.gnome.settings-daemon.peripherals.mouse
but the daemon was updated before, so i think it´s more a problem with the update than the change, becaus i have reseted all to default in dconf but the crash still persists.

Kate Stewart (kate.stewart) wrote :

Given the number of people affected, am increasing the priority on this.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: Medium → High
Guy Stone (stoneguy3) wrote :

Bug still exists in fully updated Alpha2

cacula (cacula) wrote :

while trying to run update-manager in oneric alpha2 x64 unity

Rodrigo Moya (rodrigo-moya) wrote :

This is due to the atexit installed in ORBit, which is unloaded as soon as the gconf g-s-d plugin is unloaded. So when main() quits, the atexit function from ORBit is not available anymore. So, changing package for the bug and submitting a fix for ORBit in a bit

affects: gnome-settings-daemon (Ubuntu Oneiric) → orbit2 (Ubuntu Oneiric)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package orbit2 - 1:2.14.19-0ubuntu3

---------------
orbit2 (1:2.14.19-0ubuntu3) oneiric; urgency=low

  * debian/patches/001-dont-use-atexit-handlers.patch:
    - Use GNU C extension instead of atexit handlers (LP: #788710)
 -- Rodrigo Moya <email address hidden> Wed, 13 Jul 2011 13:21:40 +0200

Changed in orbit2 (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers